[1] MLD-5.x / Systems / x86 Systeme (PC) / 5.5t: apt-Fehler
 

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 261
    • View Profile
5.5t: apt-Fehler
« on: May 22, 2021, 07:31:16 »
Moin zusammen,

über Nacht ist mir nix eingefallen, aber vieleicht habt ihr nen Tipp, was zu tun ist:
Code: [Select]
apt-get update
apt-get: relocation error: /usr/lib/x86_64-linux-gnu/libapt-private.so.0.0: symbol _ZN3URIcvNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEB5cxx11Ev version APTPKG_5.0 not defined in file libapt-pkg.so.5.0 with link time reference

Mit dem Fehler geht latürnich gar nix mehr in Richtung Update oder Installation.

Wo muss ich dran drehen, dass es wieder läuft?

Danke und VG
Erik
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 658
    • View Profile
5.5t: apt-Fehler
« Reply #1 on: May 22, 2021, 08:26:43 »
Moin Erik,

sieht mir sehr nach einem "Versionsmischmasch" bei den apt-Paketen aus.
Gehe mal einen Snapshot zurück und stoße die Aktualisierung von dort aus an.

Gruß
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 261
    • View Profile
5.5t: apt-Fehler
« Reply #2 on: May 22, 2021, 08:30:08 »
Ok, hab's gelöst:

Jeweils immer mit ls -al die aktuellsten Versionen herausgesucht.
Code: [Select]
cd /var/cache/apt/archives
dpkg -i apt_1.8.2.1-74.1_amd64.deb <Fählermeldung Abhängigkeiten>
dpkg -i libseccomp2_2.3.3-~1_amd64.deb
dpkg -i apt_1.8.2.1-74.1_amd64.deb

So wurde es dann wieder lauffähig. Fehlerhintergrund?

VG
Erik
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19278
    • View Profile
    • ClausMuus.de
5.5t: apt-Fehler
« Reply #3 on: May 22, 2021, 09:22:23 »
Hm, beide Pakete haben sich nicht geändert, und trotzdem hat ein reinstall der Pakete geholfen. Merkwürdig...

Und wie bist Du von der Fehlermeldung auf das Paket libseccomp2 gekommen?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 261
    • View Profile
5.5t: apt-Fehler
« Reply #4 on: May 22, 2021, 15:00:07 »
Hallo Claus.
Und wie bist Du von der Fehlermeldung auf das Paket libseccomp2 gekommen?
Bei der ersten Eingabe von dpkg -i apt*.deb wurde mir halt die Abhängigkeit von libseccomp2 angezeigt.

VG
Erik
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

[1] MLD-5.x / Systems / x86 Systeme (PC) / 5.5t: apt-Fehler
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.