[1] MLD-5.x / General / [MLD-5.4 stable] Minisatip server
 

Offline kwiatek

  • Newbie
  • *
  • Posts: 27
    • View Profile
[MLD-5.4 stable] Minisatip server
« on: November 17, 2021, 22:35:26 »
Hi,

Ich habe u.g. meldung bei minisatip server (MCC100). So richten Sie es ein?

Ich mochte haben:
SatIP server: MCC100
client: das Loewe TV.



Meldung:
Nov 17 22:21:32 MLD user.err vdr: [1641] SATIP-ERROR: Tuning timeout - retuning [device 1]
Nov 17 22:21:53 MLD user.err vdr: [1641] SATIP-ERROR: Tuning timeout - retuning [device 1]
Nov 17 22:22:15 MLD user.err vdr: [1641] SATIP-ERROR: Tuning timeout - retuning [device 1]
Nov 17 22:22:24 MLD user.err vdr: [1638] curl_easy_perform() [rtsp.c,369] failed: Failure when receiving data from the peer (56)
Nov 17 22:22:24 MLD user.err vdr: [1638] SATIP-ERROR: Detected invalid status code 0: rtsp://192.168.2.34/ [device 0]
Nov 17 22:22:24 MLD user.err vdr: [1638] SATIP-ERROR: Pid update failed - retuning [device 0]
Nov 17 22:22:24 MLD user.err vdr: [1638] curl_easy_perform() [rtsp.c,369] failed: Couldn't connect to server (7)
Nov 17 22:22:24 MLD user.err vdr: [1638] SATIP-ERROR: Detected invalid status code 0: rtsp://192.168.2.34/ [device 0]
Nov 17 22:22:24 MLD user.err vdr: [1641] curl_easy_perform() [rtsp.c,340] failed: Couldn't connect to server (7)
Nov 17 22:22:24 MLD user.err vdr: [1641] SATIP-ERROR: Detected invalid status code 0: rtsp://192.168.2.34/ [device 1]
« Last Edit: November 17, 2021, 23:20:37 by kwiatek »
MLD 5.4 - Reycom REC 100 S2-CI

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19467
    • View Profile
    • ClausMuus.de
[MLD-5.4 stable] Minisatip server
« Reply #1 on: November 18, 2021, 13:29:31 »
Hast Du auf dem Server sowohl einen minisatip als auch einen VDR laufen? Falls ja, müssen bei der Konfiguration ein paar Sachen beachtet werden. Ich glaube nicht, das wir das bereits automatisiert machen.
Der Loewe TV soll per satip mit dem Server sprechen?
Hast Du mehrere DVB Devices?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kwiatek

  • Newbie
  • *
  • Posts: 27
    • View Profile
[MLD-5.4 stable] Minisatip server
« Reply #2 on: November 18, 2021, 23:43:43 »
Hi,

Ich brauche nur eine Sat-IP auf dem Server.
Ja, der Loewe Fernseher soll per Satip mit dem Server kommunizieren. Es funktioniert, Loewe verbindet sich mit dem MCC100
Wie Minisatip installiert, funktioniert nur free-TV.
Funktioniert auch nur free-TV, wenn ich das Paket minisatip-dvbapi installiere. Ich habe einen funktionierenden Oscam

Mit welchen Parametern soll minisatip-dvbapi laufen, damit Free- und Pay-TV funktionieren?

Jetzt habe ich folgendes:

-R /usr/share/minisatip/html -w 192.168.2.34:8080 -o --dvbapi 127.0.0.1:2000




« Last Edit: November 19, 2021, 13:48:46 by kwiatek »
MLD 5.4 - Reycom REC 100 S2-CI

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19467
    • View Profile
    • ClausMuus.de
[MLD-5.4 stable] Minisatip server
« Reply #3 on: November 19, 2021, 14:22:50 »
Wenn Du den VDR auf den selben PC laufen hast, wie den minisatip Server, dann musst Du sicher stellen, dass der VDR keine DVB Karten verwendet. Das geht mit der -D... Option in den VDR Aufruf Argumenten (im Setup unter Applications). Möglicherweise wird das auch automatisch gesetzt, da bin ich aber nicht sicher
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kwiatek

  • Newbie
  • *
  • Posts: 27
    • View Profile
[MLD-5.4 stable] Minisatip server
« Reply #4 on: November 19, 2021, 14:32:50 »
So?
MLD 5.4 - Reycom REC 100 S2-CI

Offline kwiatek

  • Newbie
  • *
  • Posts: 27
    • View Profile
[MLD-5.4 stable] Minisatip server
« Reply #5 on: November 19, 2021, 18:37:50 »
Gemacht. Das geht mit der -D... Option in den VDR Aufruf Argumenten (im Setup unter Applications).
Weiter dunkel an pay-tv.




Nov 19 18:29:28 MLD user.info vdr: [631] VDR version 2.4.6 started
Nov 19 18:29:28 MLD user.info vdr: [631] switched to user 'root'
Nov 19 18:29:28 MLD user.info vdr: [631] codeset is 'UTF-8' - known
Nov 19 18:29:28 MLD user.info vdr: [631] override character table is 'ISO-8859-9' - known
Nov 19 18:29:28 MLD user.debug vdr: [631] found 28 locales in /usr/share/locale
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'alb,sqi'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'bos'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'bul'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'chi,zho'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'eus,baq'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'iri,gle'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'jpn'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'lav'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'ltz'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'mlt'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'por'
Nov 19 18:29:28 MLD user.debug vdr: [631] no locale for language code 'smi'
Nov 19 18:29:28 MLD user.info vdr: [631] loading plugin: /usr/lib/vdr/libvdr-dvbapi.so.2.4.6
Nov 19 18:29:28 MLD user.info vdr: [631] loading plugin: /usr/lib/vdr/libvdr-skincurses.so.2.4.6
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/setup.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/sources.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/diseqc.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/scr.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/channels.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/timers.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/commands.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/reccmds.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/svdrphosts.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/remote.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/keymacros.conf
Nov 19 18:29:28 MLD user.info vdr: [631] loading /etc/vdr/camresponses.conf
Nov 19 18:29:28 MLD user.debug vdr: [631] loading /etc/vdr/camtweaks.conf
Nov 19 18:29:28 MLD user.debug vdr: [655] video directory scanner thread started (pid=631, tid=655, prio=low)
Nov 19 18:29:28 MLD user.debug vdr: [631] registered source parameters for 'A - ATSC'
Nov 19 18:29:28 MLD user.debug vdr: [631] registered source parameters for 'C - DVB-C'
Nov 19 18:29:28 MLD user.debug vdr: [631] registered source parameters for 'S - DVB-S'
Nov 19 18:29:28 MLD user.debug vdr: [631] registered source parameters for 'T - DVB-T'
Nov 19 18:29:28 MLD user.debug vdr: [655] video directory scanner thread ended (pid=631, tid=655)
Nov 19 18:29:28 MLD user.debug vdr: [631] detected /dev/dvb/adapter1/frontend0
Nov 19 18:29:28 MLD user.debug vdr: [631] detected /dev/dvb/adapter0/frontend0
Nov 19 18:29:28 MLD user.debug vdr: [631] skipped /dev/dvb/adapter0/frontend0
Nov 19 18:29:28 MLD user.debug vdr: [657] epg data reader thread started (pid=631, tid=657, prio=high)
Nov 19 18:29:28 MLD user.debug vdr: [657] reading EPG data from /var/cache/vdr/epg.data
Nov 19 18:29:28 MLD user.debug vdr: [631] skipped /dev/dvb/adapter1/frontend0
Nov 19 18:29:28 MLD user.info vdr: [631] found 2 DVB devices
Nov 19 18:29:28 MLD user.info vdr: [631] using only 0 DVB devices
Nov 19 18:29:28 MLD user.info vdr: [631] initializing plugin: dvbapi (2.2.4-GIT-v220): SoftCAM for OSCam
Nov 19 18:29:28 MLD user.info vdr: [631] initializing plugin: skincurses (2.4.2): Skóra tekstowa
Nov 19 18:29:28 MLD user.err vdr: [631] ERROR: invalid primary device number: 1
Nov 19 18:29:28 MLD user.err vdr: [631] ERROR: no primary device found - using first device!
Nov 19 18:29:28 MLD user.err vdr: [631] ERROR: invalid primary device number: 1
Nov 19 18:29:28 MLD user.debug vdr: [631] saving /etc/vdr/camtweaks.conf
Nov 19 18:29:28 MLD user.debug vdr: [657] epg data reader thread ended (pid=631, tid=657)
Nov 19 18:29:29 MLD user.info vdr: [631] deleting plugin: skincurses
Nov 19 18:29:29 MLD user.info vdr: [631] deleting plugin: dvbapi
Nov 19 18:29:29 MLD user.debug vdr: [631] max. latency time 0 seconds
Nov 19 18:29:29 MLD user.info vdr: [631] exiting, exit code 2
MLD 5.4 - Reycom REC 100 S2-CI

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19467
    • View Profile
    • ClausMuus.de
[MLD-5.4 stable] Minisatip server
« Reply #6 on: November 20, 2021, 13:50:57 »
Die -D2 Option muss in die VDR Aufruf Argumente.
Hast Du minisatip-dvbapi genommen?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kwiatek

  • Newbie
  • *
  • Posts: 27
    • View Profile
[MLD-5.4 stable] Minisatip server
« Reply #7 on: November 20, 2021, 18:30:00 »

Jetzt habe ich eine clean install, nur minisatip-dvbapi, kein vdr. Minisatip-dvbapi verbindet sich mit Oscam, aber immer noch Dunkelheit.

2021/11/20 17:59:48 155F5C5C c   (client) plain dvbapi-client granted (vdr, au=auto (2 reader))
2021/11/20 17:59:48 155F5C5C c   (dvbapi) dvbapi channelcache loaded from /etc/oscam/oscam.ccache
2021/11/20 17:59:48 155F5C5C c   (dvbapi) Using TCP listen socket, API forced to DVBAPIv3 (0), userconfig boxtype: 11
2021/11/20 17:59:48 155F5C5C c   (dvbapi) Client connected: 'minisatip/v9-d130568' (protocol version = 2)


Minisatip startargs: -R /usr/share/minisatip-dvbapi/html/ -w 192.168.2.34:8080 -o 127.0.0.1:2000


Hat jemand eine Idee?


MLD 5.4 - Reycom REC 100 S2-CI

Offline kwiatek

  • Newbie
  • *
  • Posts: 27
    • View Profile
[MLD-5.4 stable] Minisatip server
« Reply #8 on: November 23, 2021, 21:34:05 »


Nach dem Neustart funktionieren einige Kanäle.

oscam log:

(dvbapi) Demuxer 0 no suitable readers found that can be used for decoding!

MLD 5.4 - Reycom REC 100 S2-CI

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19467
    • View Profile
    • ClausMuus.de
[MLD-5.4 stable] Minisatip server
« Reply #9 on: November 24, 2021, 17:39:47 »
Da kann ich Dir jetzt nicht mehr weiterhelfen, da ich kein oscam verwende.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / General / [MLD-5.4 stable] Minisatip server
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.