[1] MLD-5.x / Development / {5.5U rpi4 ES] Paket rpi-ffmpeg
 

Offline BobW

  • Expert Member
  • *****
  • Posts: 628
    • View Profile
{5.5U rpi4 ES] Paket rpi-ffmpeg
« on: March 26, 2022, 19:18:36 »
Hallo.

In control dieses Pakets steht "RPI-4 ffmpeg libs" im Makefile von vdr-plugin-softhddrm ist eine Referenz darauf.

Das Bauen des Paketes schlägt fehl, da das Makefile von rpi-ffmpeg .so Bibliotheken sucht, es werden aber .a Files erstellt.

Im Grunde wird ein kompletter ffmpeg (4.3.2) gebaut, von dem dann nur die Bibliotheken verwendet werden (vermutlich für softhddrm, es gibt dort aber keine Abhängigkeit).

Und dann gibt es noch das "normale" ffmpeg Paket in der Version 4.1.8

Ich bin echt verwirrt.

Schöne Grüße
BobW

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19636
    • View Profile
    • ClausMuus.de
{5.5U rpi4 ES] Paket rpi-ffmpeg
« Reply #1 on: March 27, 2022, 11:04:06 »
Das ist ein Sonderfall.
Von dem Paket werden tatsächlich nur die .a Dateien benötigt. Die Libs werden statisch in das softhddrm gelinkt. Ein Dynamisches Linken funktioniert beim softhddrm nicht.
Da die .so Dateien nicht benötigt werden, und somit auch nicht das ffmpeg Paket, haben wir uns nicht um den Fehler beim bauen gekümmert, und lassen zur Zeitersparnis die .so Dateien erst gar nicht bauen.
Der Fehler darf also ignoriert werden.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline BobW

  • Expert Member
  • *****
  • Posts: 628
    • View Profile
{5.5U rpi4 ES] Paket rpi-ffmpeg
« Reply #2 on: March 27, 2022, 12:27:41 »
OK, Danke für die Aufklärung.

Das Paket an sich wird aber auch nicht erzeugt, da
Code: [Select]
.
.
INSTALL libavutil/lzo.h
INSTALL libavutil/avconfig.h
INSTALL libavutil/ffversion.h
INSTALL libavutil/libavutil.pc
cp: cannot stat 'src/rpi-ffmpeg/install/lib/*.so*': No such file or directory
make[2]: *** [Makefile:16: package/data] Error 1
grep: ../broken_packages.lst: No such file or directory
Your branch is up to date with 'origin/master'.
.
.
das Makefile die .so kopieren will.
Ist das auch beabsichtigt?

BobW

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19636
    • View Profile
    • ClausMuus.de
{5.5U rpi4 ES] Paket rpi-ffmpeg
« Reply #3 on: March 27, 2022, 23:26:42 »
Ja. Wie gesagt, es werden nur die .a Libs benötigt.
« Last Edit: March 30, 2022, 00:10:47 by clausmuus »
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / Development / {5.5U rpi4 ES] Paket rpi-ffmpeg
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.