[1] MLD-5.x / Development / [5.5U ES] Fehler beim Bauen im lokalen ES
 

Offline BobW

  • Expert Member
  • *****
  • Posts: 628
    • View Profile
[5.5U ES] Fehler beim Bauen im lokalen ES
« on: May 01, 2022, 12:44:06 »
Hallo,

habe mir gestern eine gesamte MLD-5.5 Unstable neu gezogen und make all machen lassen.

1. dvb-mb
Das git directory gibt es nicht mehr. CrayCat hat aber ein eigenes dvb-tbs Paket. Vielleicht möchtet Ihr Euch das ansehen.

2. irkeytable
Fehler beim Bauen:
Code: [Select]
    v4l2-compliance uses libv4l: yes
    v4l2-compliance-32         : no
    BPF IR Decoders:           : no
Usage: ./sync-with-kernel.sh KERNEL_DIR

KERNEL_DIR must be the path to an extracted kernel source dir
and run 'make headers_install' in KERNEL_DIR.
make[5]: *** [Makefile:26: src/v4l-utils/Makefile] Error 1
Your branch is up to date with 'origin/master'.

3. openhab2
Downlaod directory existiert nicht mehr
Code: [Select]
  openhab2:
    Build package: openhab2
--2022-04-30 15:37:18--  https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab%2F2.4.0%2Fopenhab-2.4.0.zip
Resolving bintray.com (bintray.com)... 75.126.118.184
Connecting to bintray.com (bintray.com)|75.126.118.184|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2022-04-30 15:37:19 ERROR 403: Forbidden.

make[3]: *** [../Makefile.getfile:19: src/openhab2.zip] Error 1
make[2]: *** [Makefile:29: src/openhab2.zip] Error 2
Your branch is up to date with 'origin/master'.

4. plex-plugin-*
Zugang zu git hat sich verändert
Code: [Select]
Cloning into 'src/tvheadend-ng.bundle-HEAD'...
fatal: remote error:
  The unauthenticated git protocol on port 9418 is no longer supported.
Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
make[3]: *** [Makefile:38: src/tvheadend-ng.bundle-HEAD] Error 128
make[1]: *** [../Makefile.getfile:19: src/plex-plugin-tvheadend.tgz] Error 1
Cloning into 'src/tvheadend-ng.bundle-HEAD'...
fatal: remote error:
  The unauthenticated git protocol on port 9418 is no longer supported.
Please see https://github.blog/2021-09-01-improving-git-protocol-security-github/ for more information.
make[3]: *** [Makefile:38: src/tvheadend-ng.bundle-HEAD] Error 128
make[1]: *** [../Makefile.getfile:19: src/plex-plugin-tvheadend.tgz] Error 1

5. python-xdg
Code: [Select]
  python-xdg:
    Build package: python-xdg
Collecting pyxdg
  Downloading https://files.pythonhosted.org/packages/ea/13/de39ddf4f9f9cea0c7684cd54a50d79c97ea99c9f6aed798fd13d0bd4609/pyxdg-0.27-py2.py3-none-any.whl (49kB)
Installing collected packages: pyxdg
  Found existing installation: pyxdg 0.25
Cannot uninstall 'pyxdg'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
make[2]: *** [Makefile:21: src/python-pyXDG] Error 1
Your branch is up to date with 'origin/master'.

6. vdr-plugin-dvbsddevice
Server nicht mehr zugänglich, die VDR-Sourcen sind auf git umgezogen.
Code: [Select]
    vdr-plugin-dvbsddevice:
--2022-04-30 16:00:48--  ftp://ftp.tvdr.de/vdr/Plugins/vdr-dvbsddevice-2.2.0.tgz
           => '/root/.cache/mld//vdr-plugin-dvbsddevice-0.tgz'
Resolving ftp.tvdr.de (ftp.tvdr.de)... 88.198.76.220
Connecting to ftp.tvdr.de (ftp.tvdr.de)|88.198.76.220|:21... failed: Connection refused.
make[4]: *** [../Makefile.getfile:19: src/vdr-plugin-dvbsddevice.tgz] Error 1
make[3]: *** [../vdr/Makefile.plugin:65: src/dvbsddevice-0] Error 2
Your branch is up to date with 'origin/master'.

7. vdr-plugin-extrecmenu *-nordlichtsepg *-rcu *-sc *-upnp
Diese Plugins sind wohl mit 2.6.1 nicht mehr kompatibel.

8. vdr-plugin-skinenigmang
Magick++.h wird nicht gefunden, obwohl auf dem ES installiert
Code: [Select]
/usr/include/c++/8/bits/unique_ptr.h:53:28: note: declared here
   template<typename> class auto_ptr;
                            ^~~~~~~~
bitmap.c:12:10: fatal error: Magick++.h: No such file or directory
 #include <Magick++.h>
          ^~~~~~~~~~~~
compilation terminated.
make[5]: *** [Makefile:158: bitmap.o] Error 1
make[5]: *** Waiting for unfinished jobs....
Code: [Select]
root@6bb35bc07407:~# find /usr/include -name 'Magick++.h'
/usr/include/ImageMagick-6/Magick++.h
/usr/include/GraphicsMagick/Magick++.h
root@6bb35bc07407:~#
Sogar doppelt, ob das so sinnvoll ist?

9. vdr-plugin-softhdcuvid
"10_softhdcuvid_Makefile.patch" schlägt total fehl.

Ohne den Patch findet er dann zwei Libs nicht
Code: [Select]
At top level:
codec.c:548:21: warning: 'first_time' defined but not used [-Wunused-variable]
/usr/bin/ld: cannot find -lcuda
/usr/bin/ld: cannot find -lnvcuvid
collect2: error: ld returned 1 exit status
make[4]: *** [Makefile:352: libvdr-softhdcuvid.so] Error 1

*** failed plugins: softhdcuvid

make[3]: *** [Makefile:240: plugins] Error 1
make[2]: *** [../vdr/Makefile.plugin:52: src/softhdcuvid/libvdr-softhdcuvid.so] Error 2
D       src/10_softhdcuvid_Makefile.patch
Your branch is up to date with 'origin/master'.
root@6bb35bc07407:~/MLD-all/vdr-plugin-softhdcuvid#
Es gibt eine ganze Reihe von nvidia Bibliotheken, welche sollte verwendet werden?

Schöne Grüße
BobW

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19636
    • View Profile
    • ClausMuus.de
[5.5U ES] Fehler beim Bauen im lokalen ES
« Reply #1 on: May 01, 2022, 20:51:58 »
1) das wird nicht benötigt und könnte abgeschaltet werden
2) habe ich korrigiert, indem ich eine etwas ältere Version fest eingetragen habe
6) hast Du eine funktionierende Quelle gefunden? Welche?
7) die müssen abgeschaltet werden
9) das war nur ein Versuch, der nicht benötigt wird
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline BobW

  • Expert Member
  • *****
  • Posts: 628
    • View Profile
[5.5U ES] Fehler beim Bauen im lokalen ES
« Reply #2 on: May 03, 2022, 10:06:21 »
Hallo Claus,

Zu 6:
die letzte Quelle für dvbsddevice war/ist für VDR 2.2.0 vom 6. Januar 2017. Soweit ich mich erinnern kann, war das Plugin für das OSD der Full-featured DVB-S Adapter.

Die Karten verwenden DVB-S und NICHT DVB-S2, das macht sie IMHO obsolet und damit auch das Plugin.

Wer das noch verwenden möchte/muss, muss eben auf eine frühere MLD-Version zurückgreifen. Als Anhang die letzte Version.

Zu 2:
Funktioniert leider nicht:
Code: [Select]
Now at patch patches/v4l2-common-header.diff
In file included from ../../include/linux/dvb/dmx.h:28,
                 from .tmp_ioctl.c:3:
/usr/include/linux/types.h:5:10: fatal error: asm/types.h: No such file or directory
 #include <asm/types.h>
          ^~~~~~~~~~~~~
compilation terminated.
./sync-with-kernel.sh: line 90: ./tmp_ioctl32: No such file or directory
rm: cannot remove 'tmp_ioctl32': No such file or directory
  CC       ir_keytable-keytable.o
  CC       ir_keytable-ir-encode.o
  CC       ir_keytable-toml.o
  CC       ir_keytable-keymap.o
  CCLD     ir-keytable
          Füge Abhängigkeit hinzu: coreutils
            Benötigt von: /usr/lib/x86_64-linux-gnu/coreutils/libstdbuf.so
          Füge Abhängigkeit hinzu: libc6
            Benötigt von: /usr/lib/x86_64-linux-gnu/coreutils/libstdbuf.so
          Füge Abhängigkeit hinzu: liblirc0
            Benötigt von: /data/usr/bin/irexec
          Füge Abhängigkeit hinzu: liblirc-client0
            Benötigt von: /data/usr/bin/irexec
          Füge Abhängigkeit hinzu: libudev1
            Benötigt von: /data/usr/bin/irexec
          Füge Abhängigkeit hinzu: libstdc++6
            Benötigt von: /data/usr/bin/irexec
          Füge Abhängigkeit hinzu: libgcc1
            Benötigt von: /data/usr/bin/irexec
          Füge Abhängigkeit hinzu: libx11-6
            Benötigt von: /data/usr/bin/irxevent
          Füge Abhängigkeit hinzu: libxcb1
            Benötigt von: /data/usr/bin/irxevent
          Füge Abhängigkeit hinzu: libxau6
            Benötigt von: /data/usr/bin/irxevent
          Füge Abhängigkeit hinzu: libxdmcp6
            Benötigt von: /data/usr/bin/irxevent
          Füge Abhängigkeit hinzu: libbsd0
            Benötigt von: /data/usr/bin/irxevent
  irkeytable_2022.03.17-17+root_amd64.deb is ready
Your branch is up to date with 'origin/master'.
root@6bb35bc07407:~/MLD-all/irkeytable#
Im übrigen musste ich den Download unter ~/.cache/mld von Hand löschen, bevor das Makefile die Datei neu gezogen hat.

Schöne Grüße
BobW

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19636
    • View Profile
    • ClausMuus.de
[5.5U ES] Fehler beim Bauen im lokalen ES
« Reply #3 on: May 06, 2022, 17:06:33 »
zu 6) Das Paket wird aber trotzdem gebaut. Es scheint also lediglich etwas nicht kompiliert zu werden, was wir nicht benötigen...
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / Development / [5.5U ES] Fehler beim Bauen im lokalen ES
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.