[1] MLD-5.x / General / [MLD-5.5 testing] Keine Verbindung zu LCDd
 

Offline oliwei

  • Newbie
  • *
  • Posts: 2
    • View Profile
[MLD-5.5 testing] Keine Verbindung zu LCDd
« on: May 17, 2022, 21:29:41 »
Hallo,

ich habe zwei kleine Probleme.

Zum einen bekomme ich das Display nicht zum Laufen:
Ich haben ein Antec Fusion mit einem VFD-Display. lcdproc und das lcdproc-Plugin sind installiert. In der LCDd.conf ist imon als driver eingetragen. Ein echo "Test" > /dev/lcd0 gibt den Text auf dem Display aus. Der VDR meldet aber "MLD user.info vdr: could not establish connection to LCDd at 127.0.0.1:13666."

Zum zweiten muss ich nach dem Start immer erstmal ein paar Kanäle wechseln, um Bild und Ton zu bekommen. Ist das Bild erstmal da, ist alles gut und auch ein Neustart des VDR bringt sofort wieder ein Bild.

Ein Debug-Log habe ich hochgeladen: bScyXo

viele Grüße
oliwei

Offline oliwei

  • Newbie
  • *
  • Posts: 2
    • View Profile
[MLD-5.5 testing] Keine Verbindung zu LCDd
« Reply #1 on: June 24, 2022, 18:24:56 »
Ich konnte das Problem wie folgt lösen:

in /etc/LCDd.conf
muss in der Sektion [Server]
Driver=imon
angegeben werden.

in der Sektion [imon] muss
Device=/dev/lcd0
angegeben werden

in in /etc/init.d/lcdproc
oben die Variable
DAEMON_OPTS="-s 1 -f -c /etc/LCDd.conf"
hinzufügen

und den Aufruf von
start-stop-daemon -S -b -q -m -p $PIDFILE -x $DAEMON
in
start-stop-daemon -S -b -q -m -p $PIDFILE -x $DAEMON -- $DAEMON_OPTS
ändern.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19702
    • View Profile
    • ClausMuus.de
[MLD-5.5 testing] Keine Verbindung zu LCDd
« Reply #2 on: June 25, 2022, 10:28:39 »
Hi,

Danke für die Info. Die beiden Optionen -s1 und -f habe ich übernommen. Die Option -c ... ist nicht erforderlich, denn das ist der default Wert.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / General / [MLD-5.5 testing] Keine Verbindung zu LCDd
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.