[1] MLD-5.x / Systems / Raspberry PI / RPI4 + USB3 SSD
 

Offline thomas171

  • Newbie
  • *
  • Posts: 1
    • View Profile
RPI4 + USB3 SSD
« on: July 17, 2022, 11:46:46 »
Hi all,

I’m looking for a modern replacement for my living room vdr with one PCI DVB-S2 card, an external USB receiver and a Hama MCE remote control. My idea is to use some small computer and SATIP with a Telestar SATIP receiver.

I started with a  NUC7CJYHN2, but without any success. No TV output with any MLD version, probably due to missing vaapi driver (BTW: yavdr ansible provided video output, but with poor quality). Only a few keys on the remote control worked. My analysis showed, that OOTB support for Hama MCE vanished between MLD 5.1 and now somewhere in the eventlirc system.

After that experience I switched to another promising platform, a RPI4+USB3 SSD installed in a nice „GeeekPi DeskPi Pro Set-Top-Box“. Installation of MLD 5.5 unstable was easy. SSD taken as install destination, SD-Card removed and MLD boots from SSD. Hama MCE still not working, but that problem could be solved by moving to flirc2.

Unfortunately here the good news end. After a few hours running (without recording) RPI4s oom reaper starts aborting arbitrary processes. Might be „xorg“, „vdr“ or „sshd“ that are aborted. This seems to be a problem that is described here https://github.com/raspberrypi/linux/issues/3210 , but without any real solution. I already tried adding swap space and different power supplies.

At this point, I have no more ideas about how to proceed. Is there anybody with a similar installation?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19702
    • View Profile
    • ClausMuus.de
RPI4 + USB3 SSD
« Reply #1 on: July 18, 2022, 02:14:16 »
Hi,
if I remember right, the oom problem also occur on x86'er systems. Since this problem not occur often, it was not possible to find the reason until now.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / Systems / Raspberry PI / RPI4 + USB3 SSD
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.