[1] MLD-5.x / General / Zwei Beobachtungen nach Paket-Aktualisierung
 

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« on: July 17, 2022, 12:07:27 »
Hallo,

ich habe mich vorhin getraut bei meinem MLD (5.5 testing) im Browser unter "Pakete"->"Aktualisierungen" endlich mal den Punkt "Alle Pakete" zu klicken - das Gute vorweg: Im wesentlichen scheint es geklappt zu haben, es scheint zu laufen :)

Vor den Beobachtungen aber zwei Anmerkungen: Nach dem Klicken geht es sofort los - mein Gedanke bei so etwas (insbesondere, wenn dann gleich alles abgearbeitet wird) wäre, nochmal nachzufragen "Wollen Sie wirklich...?". Und: Bei mir wurde dann rechts erst "Download" und dann glaube ich "Unpacking" jeweils für die Pakete angezeigt und dann wurde die Liste "grau" - da habe ich ein "Erfolgreich beendet" oder ähnliches ein wenig vermisst... Ich habe dann nach 5 Minuten einfach mal den PC neu gestartet. Das sind aber nur Anmerkungen/ persönliche Präferenzen...!

Beobachtung 1:
Wenn ich jetzt (also nach Abschluss des Updates und Neustart des PC) in "Pakete"->"Aktualisierungen" gehe, kommt:
Code: [Select]
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Keine Aktualisierungen verfügbar.
"Keine Aktualisierungen verfügbar" erwarte ich, aber die erste Meldung "Unmet dependencies"... Sollte mich das sorgen - oder ist das ok?

Beobachtung 2:
Im Timer-Menü bekomme ich die (ich glaube) War Eagle Icons nicht mehr angezeigt, sondern nur noch "# > !". Ich habe im OSD nachgesehen: Bei "WarEagle icons" steht "Ja". Und ich habe schon versucht auf "Nein" zu stellen, komplett aus dem OSD raus und wieder rein und auf "Ja", und dann wieder ins Timer-Menü geschaut: Keine Icons... (Als "Oberfläche" habe "nOpacity" - und das auch lange vor der Paket-Aktualisierung, also an dieser Stelle hatte ich nichts geändert)

Kann/ sollte ich etwas zu den Punkten unternehmen?

Vielen Dank & viele Grüße
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #1 on: July 18, 2022, 02:15:17 »
Hi LincolnTC,

Beobachtung 1:
Do as it says, run "apt --fix-broken install"  then see what it suggests.
Beobachtung 2:
I don't have nOpacity skin installed so i don't know what does "WarEagle icons" mean .. sorry.

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #2 on: July 18, 2022, 10:32:55 »
Hallo,

das mit dem  "apt --fix-broken install" werde ich am Wochenende mal machen.

"WarEagle icons"... Zitat: "Mit diesem Patch werden einige Textsymbole (z.B. '#' in der Timerliste bei laufenden Timer) gegen graphische Symbole ausgetauscht." Ich glaube nicht, dass das eine nOpacity spezifische Einstellung ist... Hm, vielleicht gibt es da ja einen Zusammenhang mit dem "broken install"... Mal sehen... Ich melde mich wieder :)

Vielen Dank schon mal für die schnelle Antwort!
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 708
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #3 on: July 22, 2022, 10:15:55 »
Hallo,

der Fehler kommt immer mal wieder, wenn sich Paketabhängigkeiten nicht "vertragen".

Mach das Update mal auf der Konsole und zeige die Ergebnisse. Dann weiß man, welche Pakete betroffen sind und kann zielgerichtet Lösungen einpflegen.

Gruß
baltic
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #4 on: July 22, 2022, 13:14:50 »
Hallo,

ähm, sorry, was genau soll ich machen: "apt --fix-broken install" oder "apt-get upgrade"? In welcher Reihenfolge? Oder nur "apt-get upgrade"?

Sorry, aber meine Linux-Kenntnisse sind nicht sonderlich umfangreich :'( Aber ich würde das dann am Wochenende mal versuchen - wenn ich genau weiß was ich tun soll...

Vielen Dank & viele Grüße
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 708
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #5 on: July 22, 2022, 18:00:10 »
Mache bitte ein

apt-get update && apt-get upgrade

und poste die resultierenden Meldungen.

Und keine Sorge: Wenn etwas schiefgeht, kannst Du immer wieder leicht auf den vorherigen Stand zurück!
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #6 on: July 22, 2022, 21:09:23 »
Hi,

Run
Code: [Select]
apt --fix-broken installThe system will ask you that some packages will be removed and whether you agree or not.
Select
Code: [Select]
NoThen copy/paste what was suggested by the system here because i'm interested to know what caused that issue.
« Last Edit: July 22, 2022, 21:46:01 by gr4vity »

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #7 on: July 22, 2022, 22:35:09 »
Ok, dann werde ich zuerst das tun, was gr4vity geschrieben hat und die Meldungen hier posten. Dann werde ich das tun, was baltic geschrieben hat und natürlich auch die Meldungen posten. Ich versuche, dass ich das am Sonntag machen kann!

Vielen Dank & viele Grüße!
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #8 on: July 24, 2022, 10:43:25 »
Hallo,

also...
Code: [Select]
MLD> apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  vdr-plugin-skinflatplus
The following packages will be upgraded:
  vdr-plugin-skinflatplus
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
34 not fully installed or removed.
Need to get 3.152 kB of archives.
After this operation, 201 kB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort

Und...
Code: [Select]
MLD> apt-get update && apt-get upgrade
Get:1 http://www.minidvblinux.de/download/5.5/files testing InRelease [2.425 B]
Fetched 2.425 B in 0s (10,3 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 vdr-plugin-skinflatplus : Depends: vdr (< 2.4.7.220.3-.) but 2.6.1.221-222 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

"Pakete"->"Aktualisierungen" sagt nach wie vor:
Code: [Select]
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Keine Aktualisierungen verfügbar.

Viele Grüße!
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #9 on: July 24, 2022, 10:51:33 »
Hi,

Thanks for the feedback.
This time run
Code: [Select]
apt --fix-broken install and select yes.
vdr-plugin-skinflatplus will be upgraded ... that's all.

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #10 on: July 24, 2022, 11:52:47 »
Hi,

I just tried it, but unfortunately:
Code: [Select]
MLD> apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  vdr-plugin-skinflatplus
The following packages will be upgraded:
  vdr-plugin-skinflatplus
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
34 not fully installed or removed.
Need to get 3.151 kB of archives.
After this operation, 201 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 http://www.minidvblinux.de/download/5.5/files testing/main amd64 vdr-plugin-skinflatplus amd64 2022.07.24-14+2.6.1.221 [3.151 kB]
Fetched 3.151 kB in 2s (2.058 kB/s)
Create a snapshot of '/mnt/root/@root' in '/mnt/root/2022-07-24 11:47'
Delete subvolume (no-commit): '/mnt/root/2021-12-22 01:23'
(Reading database ... 27898 files and directories currently installed.)
Preparing to unpack .../vdr-plugin-skinflatplus_2022.07.24-14+2.6.1.221_amd64.deb ...
Unpacking vdr-plugin-skinflatplus (2022.07.24-14+2.6.1.221) over (2021.10.03-13.6+2.4.7.220.3) ...
dpkg: error processing archive /var/cache/apt/archives/vdr-plugin-skinflatplus_2022.07.24-14+2.6.1.221_amd64.deb (--unpack):
 unable to open '/etc/vdr/plugins/skinflatplus/icons/MVdefault/extraIcons/Info.png.dpkg-new': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/vdr-plugin-skinflatplus_2022.07.24-14+2.6.1.221_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Viele Grüße!
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #11 on: July 24, 2022, 12:10:09 »
Hi,

You can try
Code: [Select]
apt remove vdr-plugin-skinflatplusThen
Code: [Select]
apt install vdr-plugin-skinflatplus

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 708
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #12 on: July 24, 2022, 19:57:01 »
Ich würde nach der Deinstallation des Paketes noch mal eine Systemaktualisierung anstoßen.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline LincolnTC

  • Newbie
  • *
  • Posts: 24
    • View Profile
Zwei Beobachtungen nach Paket-Aktualisierung
« Reply #13 on: July 26, 2022, 10:31:35 »
Hallo,

nachdem ich Skinopacity verwende ist mein Plan mit "apt remove vdr-plugin-skinflatplus" (gr4vity) das "Problem" zu deinstallieren (das brauche ich doch dann gar nicht...) und dann wie von baltic empfohlen danach noch mal "apt-get update && apt-get upgrade" zu machen. Ich komme allerdings erst wieder in einigen Tagen dazu - aber ich werde Rückmeldung geben!

Vielen Dank an alle Beteiligten für die Hilfe!

Viele Grüße!
Softwareware:
MLD 5.5 (Testing)
Hardware:
Intel Core i5-10500 auf ASUS TUF Gaming H470-Pro mit 8GB
Asus GeForce GT 1030 2GB (SoftHDDevice)
Digital Devices 2x DuoFlex S2 v4A
Flirc
System: SSD // Daten: HDD WD RedPlus
---
Rudimentäre Linux-Kenntnisse sind vorhanden - aber nicht wirklich belastbar...

[1] MLD-5.x / General / Zwei Beobachtungen nach Paket-Aktualisierung
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.