[1] MLD-5.x / Systems / x86 Systeme (PC) / Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
 

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 276
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« on: July 20, 2022, 14:15:43 »
Hallo zusammen,

nach einem Update - so fangen ja ganz tolle Beschäftigungsmaßnahmen an. Da ein System (OMV 4) schon länger nicht mehr auf den aktuellen Stand gebracht wird, musste ich auf OMV 6 (Basis Debian 11 - bullseye) wechseln und das virtualbox-6.1-Paket selbst hinzufügen. Das klappt auch soweit, dass alle Maschinen wieder hochkommen - nur der MLD-Server (5.5) mag sich nicht ans Netz anschließen lassen. Das System bekommt die Netzwerkkarte (Intel 82540OEM) im Brigded-Modus zugewiesen und hatte damit lange Jahre keine Probleme - Alternativen wurden geprüft.
Jetzt sehe ich die Karte nicht mal in dmesg oder lspci -nnk.
Bei den anderen VM - sind alles Windows - klappt der Zugriff wie gewohnt.

Ich habe versucht, mit den LinuxGuestAdditions noch was zu reißen, dort bekomme ich aber immer den Fehler "md5-checksum-error".
Hat jemand eine Idee, wo ich noch schauen kann?

VG
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19702
    • View Profile
    • ClausMuus.de
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #1 on: July 20, 2022, 17:49:04 »
Ich hab grad mal auf die Schnelle eine MLD-5.5 Netinstall vom Januar letzten Jahres auf einer VirtualBox 6.1.32 getestet. Da funktioniert das Netzwerk (Intel PRO/1000 MT).
Claus
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19702
    • View Profile
    • ClausMuus.de
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #2 on: July 20, 2022, 22:36:53 »
Ich habe jetzt noch mal das aktuelle MLD-5.5 testing ausprobiert. Auch da funktioniert bei mir das Netzwerk in der VirtualBox.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 708
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #3 on: July 22, 2022, 10:13:18 »
Hallo,

ein Bekannter hat mit seinem Xen-Server nach Update vergleichbare Probleme. Die bislang üblichen Einträge in der Kernel-Zeile von GRUB werden jedenfalls angemeckert und die Karten nicht zu den domUs (alle Linux) durchgereicht. Ob da evtl. ein Zusammenhang mit OMV besteht (Änderungen im Kernel?) kann ich nicht sagen.
Mein Server ist leider vor einigen Monaten abgeraucht und ich komme nicht dazu, einen neuen aufzubauen. Daher kann ich leider nichts untersuchen oder testen.

Unter VB läuft die MLD aber, wie Claus schon schrieb, völlig problemlos. Die Ursache dürfte also eher beim Host liegen.

Gruß
baltic
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 276
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #4 on: July 23, 2022, 20:19:11 »
Grmpf - ist das jetzt ein Problem von VB beim Weiterreichen oder von Linux-Gästen im Annehmen?

Einerseits bin ich froh, dass ich nicht alleine bin, auf der anderen Seite isses halt doof, gerade jetzt dann noch zusätzlich den MLDserver auf ein anderes System zu setzen. Mit KVM habe ich noch keine Erfahrung und bis dato keine brauchbare Konfiguration hinbekommen. MLD startet dort - bekommt aber keine Adresse zugewiesen (eth0 network fail).

Frage nach Ersatz: Ich brauch das Ding auf dem Dachboden als Headless-Server mit SATip-Anschluss für zentrale Aufnahme, der Datenanschluss kann weiterhin per nfs stattfinden, drauf kommt noch EPG- & SQL-Server. Das hatte als VBox-VM mit 2 CPU & 2 GB jahrelang super geklappt.

VG
Erik
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19702
    • View Profile
    • ClausMuus.de
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #5 on: July 24, 2022, 01:18:25 »
Eventuell musst Du für kvm das network-drivers Paket hinzufügen, oder das kvm-virtio.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 276
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #6 on: July 24, 2022, 18:13:53 »
Hallo Claus,

ich habe beide Pakete hinzugefügt - in beiden Fälle kam aber keine Netzwerkverbindung zustande. Da ich dann beim netinstall aber nicht mehr auf eine Kommandozeile komme, bleibt die VM quasi stehen und muss getillt werden.

VG
Erik
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 708
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #7 on: July 24, 2022, 19:55:10 »
Hi Eric,

mal wirklich GANZ blöd gefragt, weil mir nichts anderes mehr einfällt: In den VB-Einstellungen ist unter "Netzwerk" der Haken bei "Kabel verbunden" gesetzt?
Hast Du mal versucht, per NAT ins Netz zu kommen? Und mit dem Promiscuous-Modus gespielt?

Gruß
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 276
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #8 on: July 24, 2022, 21:11:43 »
Ich hatte zuvor drei laufende VMs - zwei Mal Wintendo 11ter Versuch und den mldserver. Die Konfiguration wurde jeweils nicht verändert. Ich müsste in den vbox-Dateien nachschauen, bin mir aber sicher, dass Bridge eingeschaltet und Lan verbunden ist.

Mit NAT oder Promiscous-Mode hatte ich bis dato nix am Hut.
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 708
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #9 on: July 26, 2022, 09:31:33 »
Hast Du denn schon versucht, eine komplett neue VM aufzusetzen?

Da es bei Claus und mir problemlos funktioniert, ist es sehr unwahrscheinlich, dass VB oder MLD einen systemischen Fehler enthalten. Deshalb würde ich es einmal so versuchen.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 276
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #10 on: July 26, 2022, 12:03:45 »
Das steht als nächstes an, wenn denn der Server wieder funktioniert. In KVM habe ich das mal versucht und es wird auch auf eth0 gewartet, aber eine IP wird nicht per DHCP zugewiesen. Das gleiche passiert aber auch bei einem Live-Image von Knoppix - und der läuft normalerweise auf fast allen Systemen.
Bei KVM will ich aber nicht ausschließen, dass ich das Netzwerk nicht richtig eingerichtet habe. Ich habe für bei OMV6 über den (k.A. wie das genau heißt) untere Setuppunkt für die Bridge das eno2 ausgewählt und in der VM-Konfig auch die entsprechende MAC (oder auch dynamisch) zugewiesen.

Mal sehen, wie es weitergeht, wenn die HW da ist.
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1403
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #11 on: July 26, 2022, 19:03:08 »
Hi,

Könnte es vieleicht enfach daran liegen, das OMV6 kein Virtualbox direkt mehr unterstützt?
Soweit ich weiß ist das ab OMV5 heraus geflogen.

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline Pfeifenraucher

  • Profi Member
  • ****
  • Posts: 276
    • View Profile
Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
« Reply #12 on: July 26, 2022, 21:28:10 »
Virtualbox wird nciht mehr von Debian unterstützt. Das muss Oracle jetzt selber hinbiegen - das läuft per cli ja auch mit Hürden (Linux als Guest), nur die php-Anbindung (phpvirtualbox) ist wohl tricky.
Auch das geht vorbei ...

Meine Hardware (show / hide)

Bis hierhin sind wir bereits gekommen ...

[1] MLD-5.x / Systems / x86 Systeme (PC) / Fehlende Netzwerkkarte in VirtualBox 6.1/MLD5.5
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.