1 [2] MLD-5.x / Systems / Raspberry PI / MLD 5.3 auf RPI tot ?!
 

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19851
    • View Profile
    • ClausMuus.de
MLD 5.3 auf RPI tot ?!
« Reply #15 on: January 14, 2023, 11:57:35 »
Ich hab grad die Idee, dass ich ein kleines Paket erstellen könnte, das lediglich die IP in der hosts Datei korrigiert, und diese über den customize Image Download der MLD Webseite mit in's Image einbaue. Dieses Image könnte dann als Nightbuild genommen werden.
Ob das wirklich so klappt muss sich zeigen...
Dein Vorgehen mit dem auspacken und wieder einpacken der Initramfs sollte aber auch gehen, wenn ich diese Initramfs dann in das Basis tgz der Images einbaue.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline Georg

  • Adv. Member
  • ***
  • Posts: 186
    • View Profile
MLD 5.3 auf RPI tot ?!
« Reply #16 on: January 15, 2023, 20:00:14 »
Moin Claus,

ziemlich dasselbe ist halt doch nicht dasselbe. Mit deiner Kommandozeile bekomme ich ein initrd Image, mit dem die Installation startet. Ich komme bis zum Neustart. Danach bootet der RPI aber nicht. Kein Signal auf dem Fernseher, keinerlei Aktivität der LEDs. Da scheint der RPI auf der SD-Karte kein System zu finden.

Ciao, Georg
MLD 5.3/5.5: RaspberryPi 3 + Telestar Digibit Twin (SAT>IP)

Offline Georg

  • Adv. Member
  • ***
  • Posts: 186
    • View Profile
MLD 5.3 auf RPI tot ?!
« Reply #17 on: January 16, 2023, 21:21:51 »
Moin Claus,

zu meiner Schande muß ich gestehen, daß mir da das Installationspaket für den RPI2 dazwischengerutscht ist. Mit dem korrekten Paket für den RPI3 funktionert die Installation nach der Operation an der initrd.

Hier noch die Vorgehensweise:
- Image auf SD-Karte kopieren
- temporäres Verzeichnis anlegen und dahin wechseln
Code: [Select]
lzma -cd <Pfad zur SD-Karte>/initrd | cpio -idmv- in etc/hosts die erste Zeile mit der 130er Adresse entfernen
Code: [Select]
find . | grep -v "^./boot/" | cpio --quiet -o --owner 0:0 -H newc | lzma -9 > <Pfad zur SD-Karte>/initrd- fertig

Ciao, Georg
« Last Edit: January 16, 2023, 22:06:04 by Georg »
MLD 5.3/5.5: RaspberryPi 3 + Telestar Digibit Twin (SAT>IP)

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19851
    • View Profile
    • ClausMuus.de
MLD 5.3 auf RPI tot ?!
« Reply #18 on: January 17, 2023, 14:43:25 »
Kannst Du auch mal testen, ob ohne die Zeile in der /etc/hosts der live Modus funktioniert? Wenn ich mich richtig erinnere gab es ohne die Zeile im Live System ein Problem beim Installieren von Paketen. Sicher bin ich da aber nicht, da es schon sehr lange her ist, dass ich die Zeile eingebaut hatte,... Eventuell sogar schon zu MLD-5.0 Zeiten, oder schon zu MLD-4 Zeiten ;)
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline Georg

  • Adv. Member
  • ***
  • Posts: 186
    • View Profile
MLD 5.3 auf RPI tot ?!
« Reply #19 on: January 17, 2023, 20:10:07 »
Kann ein paar Tage dauern. Mir gehen gerade die SD-Karten aus. ;-)
MLD 5.3/5.5: RaspberryPi 3 + Telestar Digibit Twin (SAT>IP)

Offline Georg

  • Adv. Member
  • ***
  • Posts: 186
    • View Profile
MLD 5.3 auf RPI tot ?!
« Reply #20 on: January 20, 2023, 16:19:07 »
Moin Claus,

live funktioniert damit auch.

Ciao, Georg
MLD 5.3/5.5: RaspberryPi 3 + Telestar Digibit Twin (SAT>IP)

1 [2] MLD-5.x / Systems / Raspberry PI / MLD 5.3 auf RPI tot ?!
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.