[1] MLD-5.x / General / Probleme beim Upgrade auf 5.1 mit APT
 

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« on: August 31, 2016, 09:22:25 »
Hallo,

ich bin beim Versuch, eine Installation von MLD 5.0 auf einem Raspberry Pi 2 mittels APT auf MLD 5.1 zu aktualisieren, auf mehrere Probleme gestoßen. Folgendes habe ich getan:

Zunächst habe ich das System auf den aktuellen Stand von 5.0 gebracht. Durch ''apt-get update; apt-get dist-upgrade'' wurden neuen Versionen von apt (1.0.9.8-65) und libapt-pkg4.12 (1.0.9.8.2-~1) installiert. Dabei wurde offensichtlich /etc/apt/sources.list (nun leer) durch /etc/apt/sources.list.d/main.list ersetzt.

Dann habe ich in der Datei main.list die 5 durch ein 5.1 ersetzt:
Code: [Select]
deb http://www.minidvblinux.de/download/5.1/files stable main
Unter Debian/Ubuntu müsste man nun zunächst ''apt-get update'' ausführen. Zu meiner Überraschung wurde aber in MLD dadurch die Änderungen in main.list wieder rückgängig gemacht. Also habe ich main.list nochmals geändert und sofort ''apt-get dist-upgrade'' ausgeführt:
Code: [Select]
mld2> apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... The following package was automatically installed and is no longer required:
  libpython2.7
Use 'apt-get autoremove' to remove it.
Done
The following packages will be REMOVED:
  lirc:armhf-rpi2 mld-remote
The following NEW packages will be installed:
  appstarter libcec3 libdbi1 libdiscid0 libfuse2 libgraphicsmagick3 liblcms2-2
  libmysqlclient18 libossp-uuid16 libpulseeight-platform1 librrd4 libwmf0.2-7
  libxft2
The following packages will be upgraded:
  alsa:armhf-rpi2 at backup base btrfs:armhf-rpi2 busybox dpkg dvb-apps
  eventlircd:armhf-rpi2 init initramfs:armhf-rpi2 install irkeytable
  kernel:armhf-rpi2 libdvdnav4 libdvdread4 libgdk-pixbuf2.0-0 libgme0
  libportaudio2 libsmbclient libssh-4 locales network:armhf-rpi2 nfs-client
  perl perl-base psplash rc-core:armhf-rpi2 rpi:armhf-rpi2
  rpi-firmware:armhf-rpi2 ssh suspend vdr vdr-plugin-apt vdr-plugin-cecremote
  vdr-plugin-control vdr-plugin-epgsearch vdr-plugin-epgsync vdr-plugin-femon
  vdr-plugin-iptv vdr-plugin-remoteosd vdr-plugin-remotetimers
  vdr-plugin-rpihddevice:armhf-rpi2 vdr-plugin-setup vdr-plugin-sleeptimer
  vdr-plugin-streamdev-client vdr-plugin-suspendoutput vdr-plugin-svdrpservice
  vlc webserver
50 upgraded, 13 newly installed, 2 to remove and 0 not upgraded.
...

Nach dem Upgrade funktionierte VDR wieder, im Hauptmenü fand sich aber zu meiner Überraschung ein Eintrag "Installiere MiniDVBLinux" (oder so ähnlich). Den habe ich ausgewählt, aber keine Reaktion festgestellt.

Dass beim Upgrade die Pakete lirc und mld-remote gelöscht wurden, dürfte der Grund dafür sein, dass nach dem Neustart nicht mehr alles Tasten der Fernbedienung wie gewohnt funktionierten. Was genau ging / nicht ging kann ich aber leider nichr mehr sagen. Dafür wurde mir durch eine OSD-Nachricht die URL angezeigt, unter der die Konfiguration des Systems möglich sei. Auch im Browser ging es zunächst um eine Installation von MLD.

Das war mir alles nicht geheuer und ich habe zunächst einmal die SD-Karte mit der Sicherung überschrieben, die ich vor dem Upgrade-Versucht erstellt hatte.

Zusammengefasst habe ich als folgende Probleme
 - apt-get update überschreibt Änderungen in /etc/apt/soruces.list.d/main.list
 - Das Upgrade scheint die Installation oder Konfiguration der Fernbedienung zu beeinträchtigen
 - Nach dem Upgrade scheint das System nicht mehr "wirklich" installiert zu sein

Natürlich wäre ich dankbar, wenn mir jemand erläutern könnte, was ich alles so falsch verstanden und gemacht habe  :)

Schönen Gruß,
maf

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19126
    • View Profile
    • ClausMuus.de
Probleme beim Upgrade auf 5.1 mit APT
« Reply #1 on: August 31, 2016, 10:24:26 »
Hi,

Du musst nicht (darfst nicht) die /etc/apt/sources.list.d/main.list bearbeiten, weil diese automatisch generiert wird (ich werde einen entsprechenden Hinweis hinzufügen). Statt dessen musst Du entweder in der /etc/rc.config die MLD Version ändern, bzw. dies über das Setup im Webif machen (und anschließend zweimal ein "apt update" machen), oder was noch einfacher und sicherer ist, den Paketmanager im Webif erneut aufrufen. Dann wird Dir das Upgrade auf die 5.1 direkt angeboten.
Der Fehler mit der wieder auftauchenden Install Funktion wurde schon gelegentlich berichtet, nur hatte ich das selber noch nie, weshalb ich das auch noch nicht untersuchen und beheben konnte. Jedenfalls darf das nicht aufgerufen werden.
Sollte der Fehler mit dem entfernten lirc und mld-remote Paket beim nächsten Versuch wieder auftreten, versuch mal ob Du die beide Pakete wieder installieren kannst, oder ob Dir Konflikte angezeigt werden, bzw. welche zusätzlichen Pakete installiert werden.

Claus
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #2 on: August 31, 2016, 11:22:21 »
Hi Claus,

danke für Deine Hilfe.

Ich habe das System über das Webif erfolgreich aktualisiert. Erst "Alle Pakete" (damit wurde apt aktualisiert), dann "Auf MLD 5.1". Dabei wurden die Pakete lirc und mld-remote wieder gelöscht, ließen sich aber anschließend problemlos installieren:
Code: [Select]
mld2> apt-get install lirc mld-remote
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libpython2.7
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  libftdi1
The following NEW packages will be installed:
  libftdi1 lirc mld-remote
...

(Erst) nach einem Neustart des Systems funktionierte die Fernbedienung auch wieder.

Allerdings steht im Hauptmenü wieder ein Eintrag "Install MiniDVBLinux".  Kann ich etwas tun, um nach der Ursache für diesen Fehler zu suchen? Und was muss ich tun, um den Eintrag zu löschen?

Gruß, maf

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #3 on: August 31, 2016, 11:34:49 »
Nachtrag: Was leider auch noch nicht wieder funktioniert ist das Aufwecken des VDR mit der Fernbedienung.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19126
    • View Profile
    • ClausMuus.de
Probleme beim Upgrade auf 5.1 mit APT
« Reply #4 on: August 31, 2016, 12:42:16 »
Hi,

ich werde erst einmal versuchen ob ich das nachstellen kann.

Claus
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #5 on: September 01, 2016, 15:38:37 »
Zweiter Nachtrag: Ich kann zwar mit der Fernbedienung nicht den VDR "aufwecken" (wobei sich bislang dank CEC auch der Fernseher einschaltete), aber wenn ich den Fernseher einschalte, reagiert MLD. Ich sehe das Boot Logo mit Fortschrittsbalken, dann wird per WOL der Server gestartet und schließlich läuft VDR. Bisher konnte ich den Fernseher einschalten ohne dabei gleich den VDR-Client zu wecken.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19126
    • View Profile
    • ClausMuus.de
Probleme beim Upgrade auf 5.1 mit APT
« Reply #6 on: September 02, 2016, 00:32:58 »
Das heißt, Du konntest bisher den TV einschalten, ohne das die MLD startete, und anschließend die MLD z.B. durch drücken der OK taste auf der TV Fernbedienung über CEC wecken? Oder konntest Du die MLD über CEC wecken, ohne den TV einzuschalten?
Und jetzt get die MLD immer mit dem TV zusammen an?
Eine etwas präzisere Fehler- bzw. Funktionsbeschreibung (was passiert, was sollte passieren) wäre hier hilfreich.

Claus
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #7 on: September 02, 2016, 09:07:45 »
Konstellation: MLD 5.0 und MLD 5.1 jeweils auf RPi 2 mit Medion USB Funkfernbedienung an Samsung TV

Unter MLD 5.0 kann ich mit der Power-Taste der Fernbedienung den VDR herunterfahren. Der Fernseher schaltet sich dadurch aus. Prozesse mit Bezug zu VDR in diesem Zustand:
Code: [Select]
mld1> ps w | grep vdr
17662 root      4172 S    sh -c /etc/vdr/shutdown.d/rc.action 0 0 0 "" 1
17663 root      4172 S    {rc.action} /bin/sh /etc/vdr/shutdown.d/rc.action 0 0 0  1
Wiederum mit der Power-Taste kann ich VDR erneut starten. Dadurch schaltet sich sofort auch der Fernseher ein. Es gibt also eine unmittelbare Reaktion, aber in der Regel noch kein Bild, da der VDR Server hochfahren muss.

Das Einschalten des Fernsehers mit dessen Fernbedienung während des Ruhezustands hat keinen Einfluss auf die MLD 5.0 und den VDR. Ich erhalte vom Fernseher den Hinweis, dass kein HDMI-Signal anliege.

Auch unter MLD 5.1 kann ich mit der Power-Taste den VDR herunterfahren und der Fernseher schaltet sich aus. Prozesse in diesem Zustand:
Code: [Select]
mld2> ps w | grep vdr
 1371 root      4320 S    {runvdr-rhd} /bin/sh /usr/bin/runvdr-rhd -f
 1792 root      4188 S    inotifyd - /var/run/runvdr-rhd D
 6134 root      4188 S    sh -c /etc/vdr/shutdown.d/rc.action 0 0 0 "" 1
 6135 root      4188 S    {rc.action} /bin/sh /etc/vdr/shutdown.d/rc.action 0 0 0  1

Die MLD 5.1 reagiert aber anders als die MLD 5.0 auf das Wiedereinschalten mit der Fernbedienung und das Einschalten des Fernsehers.

Ich dachte zunächst, dass die MLD 5.1 im VDR-Ruhezustand auf die Power-Taste der Fernbedienung nicht reagiert, weil der Fernseher sich nicht sofort einschaltete. Es fehlte die gewohnte unmittelbare Reaktion. Richtig ist jedoch, dass der VDR doch reaktiviert wird. Es dauert nur viel länger, bis sich der Fernseher einschaltet. Als ich ihn beim ersten Test während dieser Wartezeit selbst einschaltete, sah ich das MLD-Logo und den Fortschrittsbalken. Prozesse beim Hochfahren des VDR:
Code: [Select]
mld2> ps w | grep vdr
 1371 root      4320 S    {runvdr-rhd} /bin/sh /usr/bin/runvdr-rhd -f
 1792 root      4188 S    inotifyd - /var/run/runvdr-rhd D
10581 root      4188 S    sh -c /etc/vdr/shutdown.d/rc.action 0 0 0 "" 1
10582 root      4188 S    {rc.action} /bin/sh /etc/vdr/shutdown.d/rc.action 0 0 0  1
11508 root      4320 S    {vdr} /bin/sh /etc/init.d/vdr resume
11509 root      4320 S    {vdr} /bin/sh /etc/init.d/vdr start
11512 root      4188 S    sh -c runvdr </dev/tty5 >/dev/tty5 2>/var/log/vdr
11514 root      4320 S    {runvdr} /bin/sh /usr/bin/runvdr
11719 root      4188 S    sleep 1 #waiting for /etc/init.d/vdr
11742 root      271m S    /usr/bin/vdr -s /etc/vdr/shutdown.d/rc.action -r /etc/vdr/recording.d/rc.action -w 60 -g /tmp -u root --v
11745 root      4188 S    sleep 1 #waiting for vdr startup
mld2> ps w | grep vdr
 1371 root      4320 S    {runvdr-rhd} /bin/sh /usr/bin/runvdr-rhd -f
 1792 root      4188 S    inotifyd - /var/run/runvdr-rhd D
10581 root      4188 S    sh -c /etc/vdr/shutdown.d/rc.action 0 0 0 "" 1
10582 root      4188 S    {rc.action} /bin/sh /etc/vdr/shutdown.d/rc.action 0 0 0  1
11512 root      4188 S    sh -c runvdr </dev/tty5 >/dev/tty5 2>/var/log/vdr
11514 root      4320 S    {runvdr} /bin/sh /usr/bin/runvdr
11742 root      328m S    /usr/bin/vdr -s /etc/vdr/shutdown.d/rc.action -r /etc/vdr/recording.d/rc.action -w 60 -g /tmp -u root --v
11788 root      4320 S    {vdr} /bin/sh /etc/init.d/vdr start
mld2> ps w | grep vdr
 1371 root      4320 S    {runvdr-rhd} /bin/sh /usr/bin/runvdr-rhd -f
 1792 root      4188 S    inotifyd - /var/run/runvdr-rhd D
11512 root      4188 S    sh -c runvdr </dev/tty5 >/dev/tty5 2>/var/log/vdr
11514 root      4320 S    {runvdr} /bin/sh /usr/bin/runvdr
11742 root      330m S    /usr/bin/vdr -s /etc/vdr/shutdown.d/rc.action -r /etc/vdr/recording.d/rc.action -w 60 -g /tmp -u root --v
Es wäre schön, wenn auch unter MLD 5.1 der Fernseher "sofort" eingeschaltet würde und man den Fortschrittsbalken sähe bis ein Bild kommt, weil man dann wüsste, dass das Einschalten funktioniert hat.

Das Einschalten des Fernsehers führt bei MLD 5.1 zu
Code: [Select]
mld2> ps w | grep vdr
 1371 root      4320 S    {runvdr-rhd} /bin/sh /usr/bin/runvdr-rhd -f
 1792 root      4188 S    inotifyd - /var/run/runvdr-rhd D
 9287 root      4188 S    sh -c /etc/vdr/shutdown.d/rc.action 0 0 0 "" 1
 9288 root      4188 S    {rc.action} /bin/sh /etc/vdr/shutdown.d/rc.action 0 0 0  1
10247 root      4188 S    sleep 1 #waiting for /etc/init.d/vdr
10250 root      4320 S    {vdr} /bin/sh /etc/init.d/vdr resume
10251 root      4320 S    {vdr} /bin/sh /etc/init.d/vdr start
10254 root      4188 S    sh -c runvdr </dev/tty5 >/dev/tty5 2>/var/log/vdr
10256 root      4320 S    {runvdr} /bin/sh /usr/bin/runvdr
10258 root      4188 S    sleep 1 #waiting for vdr startup
10264 root      4188 S    {rc.action} /bin/sh /etc/vdr/run.d/rc.action start
10274 root      4320 S    {vdr} /bin/sh /etc/vdr/run.d/vdr start
und letztlich läuft der VDR
Code: [Select]
mld2> ps w | grep vdr
 1371 root      4320 S    {runvdr-rhd} /bin/sh /usr/bin/runvdr-rhd -f
 1792 root      4188 S    inotifyd - /var/run/runvdr-rhd D
10254 root      4188 S    sh -c runvdr </dev/tty5 >/dev/tty5 2>/var/log/vdr
10256 root      4320 S    {runvdr} /bin/sh /usr/bin/runvdr
10484 root      335m S    /usr/bin/vdr -s /etc/vdr/shutdown.d/rc.action -r /etc/vdr/recording.d/rc.action -w 60 -g /tmp -u root --v
Ich würde gerne den Fernseher einschalten können ohne dadurch den VDR (und damit meinen VDR Server) zu starten.

maf

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19126
    • View Profile
    • ClausMuus.de
Probleme beim Upgrade auf 5.1 mit APT
« Reply #8 on: September 02, 2016, 11:17:08 »
Das Verhalten beim Einschalten des TV kann man glaube ich in den cecremote Konfigurationsdatei einstellen. Ich glaube hier im Forum gab's schon ein Thrad zu dem Thema.
Das Verhalten beim Einschalten hatte ich geändert, weil einige TV Geräte mit dem alten Verhalten nicht klar kamen. Ich werde mir das aber noch mal anschauen.

Claus
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #9 on: September 02, 2016, 14:01:24 »
Das Verhalten beim Einschalten des TV kann man glaube ich in den cecremote Konfigurationsdatei einstellen. Ich glaube hier im Forum gab's schon ein Thrad zu dem Thema.
Den Thread habe ich leider noch nicht gefunden. Vielleicht liest ja jemand mit und hat einen Link für mich?

Beim Vergleich von /etc/vdr/plugins/cecremote/cecremote.xml zwischen MLD 5.0 und MLD 5.1 ist mir folgender neuer Abschnitt aufgefallen:
Code: [Select]
mld2> diff cecremote.xml.bkp cecremote.xml
68,72d67
<       <onceccommand command="STANDBY" initiator="TV">
<               <commandlist>
<                       <exec>/etc/vdr/plugins/cecremote/standby.sh</exec>
<               </commandlist>
<       </onceccommand>
Den habe ich versuchsweise in 5.1 entfernt, doch der Fernseher startet immer noch den VDR.

Das Verhalten beim Einschalten hatte ich geändert, weil einige TV Geräte mit dem alten Verhalten nicht klar kamen. Ich werde mir das aber noch mal anschauen.
Danke!

Offline skippy

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2228
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #10 on: September 02, 2016, 16:31:56 »
meine MLDs (show / hide)

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #11 on: September 02, 2016, 16:40:39 »
Vielen Dank für den Hinweis, skippy!

Den Thread muss ich mich ncoh einmal genauer ansehen, um die Bedienung des VDR mit der Fernbedienung des Fernsehers zu optimieren. Er hilft mir aber - soweit ich sehen kann - nicht bei meinen aktuellen Problem, dass die MLD 5.1 (im Gegensatz zu MLD 5.0) den VDR hochfährt, wenn ich den Fernseher mit dessen Fernbedienung einschalte. Dieses "Feature" würde ich gerne deaktivieren.

Gruß, maf

Offline maf

  • MLD-Tester
  • Member
  • ******
  • Posts: 90
    • View Profile
Probleme beim Upgrade auf 5.1 mit APT
« Reply #12 on: April 03, 2021, 20:44:34 »
Falls es nach all der Zeit noch jemandem hilft: Will man verhindern, dass das Einschalten des Fernsehers VDR aufweckt, hilft folgende Änderung:
Code: [Select]
diff /etc/init.d/rc.suspend.soft.orig /etc/init.d/rc.suspend.soft
50,51c50,51
< test -x /usr/bin/cec-client && (cec-client -m & echo $!>/tmp/$$) | grep -q -m 1 "TV .* to 'on'" && echo cec > /var/spool/suspend &
< cec=$(cat /tmp/$$ 2>/dev/null); rm -f /tmp/$$
---
> #test -x /usr/bin/cec-client && (cec-client -m & echo $!>/tmp/$$) | grep -q -m 1 "TV .* to 'on'" && echo cec > /var/spool/suspend &
> #cec=$(cat /tmp/$$ 2>/dev/null); rm -f /tmp/$$
64c64
< kill $cec 2>/dev/null
---
> #kill $cec 2>/dev/null

[1] MLD-5.x / General / Probleme beim Upgrade auf 5.1 mit APT
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.