[1] MLD-5.x / Systems / x86 Systeme (PC) / CEC-Remote geht nach update nicht mehr
 

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 144
    • View Profile
CEC-Remote geht nach update nicht mehr
« on: March 11, 2019, 16:19:08 »
Hallo zusammen,
seit geraumer Zeit läuft die Fernbedienung nur noch mit einem alten Image:
- Kernel 4.20.5.201.6
- vdr-plugin-cecremote 2018-11-01-18.3+2.4.0.217.7

nach update auf
- Kernel 4.20.13.201.10-202.2
- vdr-plugin-cecremote 2018-11-01-19+2.4.0.218.1

im Log finde ich u.a.
Code: [Select]

Mar 11 15:52:35 MLD user.err vdr: [cecremote] CEC ERROR:    error opening serial port '/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1': Is a directory
Mar 11 15:52:35 MLD user.err vdr: [cecremote] CEC ERROR:    could not open a connection (try 4)
Mar 11 15:52:40 MLD user.err vdr: [cecremote] CEC ERROR:    error opening serial port '/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1': Is a directory
Mar 11 15:52:40 MLD user.err vdr: [cecremote] CEC ERROR:    could not open a connection (try 1)
Mar 11 15:52:43 MLD user.err vdr: [cecremote] CEC ERROR:    error opening serial port '/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1': Is a directory
Mar 11 15:52:43 MLD user.err vdr: [cecremote] CEC ERROR:    could not open a connection (try 2)
Mar 11 15:52:44 MLD user.err vdr: [cecremote] CEC ERROR:    error opening serial port '/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1': Is a directory
Mar 11 15:52:44 MLD user.err vdr: [cecremote] CEC ERROR:    could not open a connection (try 3)
Mar 11 15:52:46 MLD user.err vdr: [cecremote] CEC ERROR:    error opening serial port '/sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1': Is a directory
Mar 11 15:52:46 MLD user.err vdr: [cecremote] CEC ERROR:    could not open a connection (try 4)
Mar 11 15:52:47 MLD user.err vdr: [cecremote] unable to open the device on port /sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1
Mar 11 15:52:47 MLD user.err vdr: [cecremote] CEC ERROR:    could not start CEC communications
Mar 11 15:52:47 MLD user.err vdr: [cecremote] PowerOnDevice ignored
Mar 11 15:52:47 MLD user.err vdr: [cecremote] SetActiveSource ignored

anbei der Debug-Link:
Dein Upload Code lautet: 9fW99o

Da der Rücksprung auf den alten Snapshot funktioniert, würde ich einen Hardwarefehler ausschliessen...

Habt Ihr noch Vorschläge zum debuggen?

P.S. wie im Log bemängelt ist der Gerätepfad tatsächlich ein directory:
Code: [Select]

MLD> ls /sys/devices/pci0000:00/0000:00:1a.2/usb5/5-1
5-1:1.0              bcdDevice            bmAttributes         busnum               devpath              ltm_capable          product              serial               urbnum
5-1:1.1              bConfigurationValue  bMaxPacketSize0      configuration        driver               manufacturer         quirks               speed                version
5-1:1.2              bDeviceClass         bMaxPower            descriptors          ep_00                maxchild             removable            subsystem
authorized           bDeviceProtocol      bNumConfigurations   dev                  idProduct            port                 remove               tx_lanes
avoid_reset_quirk    bDeviceSubClass      bNumInterfaces       devnum               idVendor             power                rx_lanes             uevent
MLD>

Gruß K.
« Last Edit: March 11, 2019, 16:53:49 by Klemmerle »
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 144
    • View Profile
CEC-Remote geht nach update nicht mehr
« Reply #1 on: March 25, 2019, 19:16:00 »
... im alten Snapshot wird der CEC-Adapter richtig gesetzt:

Code: [Select]
MLD> dmesg |grep -i cec
[    4.471419] usb 5-1: Product: USB-CEC Adapter
[    4.480727] input: Pulse-Eight USB-CEC Adapter as /devices/pci0000:00/0000:00:1a.2/usb5/5-1/5-1:1.2/0003:2548:1002.0001/input/input5
[    4.480812] hid-generic 0003:2548:1002.0001: input,hidraw0: USB HID v1.10 Mouse [Pulse-Eight USB-CEC Adapter] on usb-0000:00:1a.2-1/input2
MLD>

im System log (alter Snapshot) taucht "CEC" nur einmal auf:
Code: [Select]

Mar 25 18:36:44 (MLD) user.debug vdr: [cecremote] Load keymap


Weiß jemand wie die Adresse des CEC-Adapters an MLD übergeben wird?
U.U. würde ich sie dann manuell setzen.

Gruß K.
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, Tuner: DD Cine S2 V6.5 + Duoflex S2 + CEC-Remote

[1] MLD-5.x / Systems / x86 Systeme (PC) / CEC-Remote geht nach update nicht mehr
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.