[1] MLD-5.x / General / Mehrere Problemchen mit MLD 5.4
 

Offline chriszero

  • Newbie
  • *
  • Posts: 12
    • View Profile
Mehrere Problemchen mit MLD 5.4
« on: April 07, 2019, 13:47:30 »
Hi, nach einiger Zeit ohne VDR hab ichs mir wieder angetan ;-)

Frische netinstall
/var/log/messages wird nicht geschrieben (cat: can't open '/var/log/messages': No such file or directory)
System geht nicht alleine aus, steht zwar dran (wird in xx:xx min ausgeschaltet) fängt aber immer wieder von neuem an...
Fernbedienung bekomme ich ums verecken nicht zum laufen. Antec Fusion iMon mit Logitech Harmony.

Hier mal die Debug logs: BAzsGZ

Was wollt Ihr alles wissen?

Sonnige Grüße,
Christian

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17790
    • View Profile
    • ClausMuus.de
Mehrere Problemchen mit MLD 5.4
« Reply #1 on: April 07, 2019, 14:09:11 »
In Deiner /var/log/sysinit steht das die /etc/init.d/wakeup fehlerhaft ist.
Ansonsten findest Du normalerweise in der /var/log/sysinit oder auf Konsole 1 den Grund, warum das System nicht abschaltet.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline chriszero

  • Newbie
  • *
  • Posts: 12
    • View Profile
Mehrere Problemchen mit MLD 5.4
« Reply #2 on: April 07, 2019, 15:32:14 »
Ja, da ist ein falsche quote drin.
Und zwar bei "filename" der EPG-Titel, bzw der Dateiname hat ein  ' " ' im Titel

Filename kommt von einem Suchtimer
Das sollte escaped werden...

Code: [Select]
#!/bin/sh

utctime="1554364380"
difftime="78887"
channel="501"
filename="Paw Patrol - Helfer auf vier Pfoten~Paw Patrol - Helfer auf vier Pfoten~Folge 61: "Besuch von einem Drachen / Di"
reason="0"

Offline chriszero

  • Newbie
  • *
  • Posts: 12
    • View Profile
Mehrere Problemchen mit MLD 5.4
« Reply #3 on: April 07, 2019, 19:32:02 »
Die Imon Remote läuft jetzt ohne Lirc, direkt als HID-Device über vdr-plugin-remote mit "-i /dev/input/by-id/usb-15c2_0038-event-mouse" als Pluginparamenter
Mit lirc habe ichs nicht hinbekommen, warum auch immer. Früher ging das mal.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17790
    • View Profile
    • ClausMuus.de
Mehrere Problemchen mit MLD 5.4
« Reply #4 on: April 07, 2019, 22:45:24 »
Ich hab das Script geändert, das die /etc/rc.shutdown erstellt. Jetzt werden Anführungszeichen escaped.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline chriszero

  • Newbie
  • *
  • Posts: 12
    • View Profile
Mehrere Problemchen mit MLD 5.4
« Reply #5 on: May 06, 2019, 19:15:55 »
Das Escapen klappt noch nicht 100%ig.
Wenn das letzte Zeichen ein Anführungszeichen ist, wird dieses wohl nicht Escaped.

Siehe:
Code: [Select]
#!/bin/sh

utctime="1557204780"
difftime="42090"
channel="59"
filename="Paw Patrol - Helfer auf vier Pfoten~Paw Patrol - Helfer auf vier Pfoten~Folge 39: \"Die Meerfellfreunde""
reason="0"


Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17790
    • View Profile
    • ClausMuus.de
Mehrere Problemchen mit MLD 5.4
« Reply #6 on: May 06, 2019, 20:12:20 »
Oder es wurde nur das erste Anführungszeichen escaped (ups)...
Hab's korrigiert und hoffe das es jetzt wie geplant funktioniert.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / General / Mehrere Problemchen mit MLD 5.4
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.