[1] MLD-5.x / Systeme / Raspberry PI / MLD-5-4 mit Kodi und Hifiberry Probleme
 

Offline manowar45

  • Newbie
  • *
  • Posts: 12
    • View Profile
MLD-5-4 mit Kodi und Hifiberry Probleme
« on: June 15, 2019, 18:46:25 »
Habe auf meinem Raspi 3 MLD-5.4 Stable installiert und auch Kodi. Ich möchte den Hifiberry aber nur im Kodi nutzen zum Filme gucken. Das Problem ist das der Hifiberry garnicht in Kodi bei der Audiohardware auswählbar ist. Ich hatte zur Sicherheit einmal Libreelec mit Kodi installiert und dort war der Hifiberry auswählbar. Also nur zur Sicherheit das er nicht defekt ist.
Habe in der config.txt den Eintrag dtoverlay=hifiberry-digi gemacht. Im Alsamixer ist er auch als 2. Soundkarte vorhanden allerdings lässt sich keine Lautstärke dort regeln was bei der Onboard-Soundkarte möglich ist.

MLD> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HiFiBerry Digi+ Pro                                                                              HiFi wm8804-spdif-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Erkannt wird der Hifiberry also vom System.
Weiterhin hab ich mal einige relevante Meldungen aus dem Systemlog:

snd-rpi-wm8804 soc:sound: ASoC: CODEC DAI wm8804-spdif not registered - will retry
Jun 15 15:56:56 (none) user.info kernel: [   13.911828] wm8804 1-003b: Linked as a consumer to regulator.0
Jun 15 15:56:56 (none) user.warn kernel: [   13.911840] wm8804 1-003b: 1-003b supply DVDD not found, using dummy regulator
Jun 15 15:56:56 (none) user.info kernel: [   13.913644] wm8804 1-003b: revision E

Vielleicht kann jemand helfen.

Offline manowar45

  • Newbie
  • *
  • Posts: 12
    • View Profile
MLD-5-4 mit Kodi und Hifiberry Probleme
« Reply #1 on: June 18, 2019, 16:58:10 »
Hab das Problem selbst lösen können.
Es muß eine Änderung in der alsa.conf vorgenommen werden. Der Hifiberry muß als Default Karte eingetragen sein, in meinem Fall

defaults.ctl.card 1
defaults.pcm.card 1

Standart sind beide auf 0, also die onboard Karte.

Nun ist der Hifiberry unter Kodi auswählbar und Dolby Digital und DTS funktionieren einwandfrei. Im VDR hab ich weiterhin den Ton über HDMI also onboard Sound.
Ich hatte auch zusätzlich noch etwas in die etc/modules geschrieben: i2c_bcm2835  CONFIG_I2C_BCM2835=m und auch in der config.txt habe ich mit dtoverlay=pi3-disable-bt das bluetooth Modul deaktiviert. Ich weiß nun nicht ob das ausschlaggebend war und will auch nicht weiter rumspielen.
Vielleicht hilft das hier ja mal jemandem weiter.



« Last Edit: June 18, 2019, 17:28:48 by manowar45 »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17790
    • View Profile
    • ClausMuus.de
MLD-5-4 mit Kodi und Hifiberry Probleme
« Reply #2 on: June 18, 2019, 21:23:58 »
Ließ sich die Hifiberry nicht im Setup als Ausgabe Device auswählen?
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline manowar45

  • Newbie
  • *
  • Posts: 12
    • View Profile
MLD-5-4 mit Kodi und Hifiberry Probleme
« Reply #3 on: June 19, 2019, 17:28:21 »
@clausmuus
Das kann ich dir heute schon nicht mehr sagen weil das System den Hifiberry einfach nicht mehr erkennt obwohl ich nichts verändert habe gegenüber gestern. Den Alsamixer kann ich auch nicht aufrufen obwohl er vorhanden ist. Hatte auch mal Systen Neustart gemacht, brachte aber nichts. Ist scheinbar irgendwie eine Glückssache mit dem Teil.

MLD> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
MLD> alsamixer
cannot open mixer: No such file or directory
MLD> cat /proc/asound/cards
 0 [ALSA           ]: bcm2835_alsa - bcm2835 ALSA
                      bcm2835 ALSA

[1] MLD-5.x / Systeme / Raspberry PI / MLD-5-4 mit Kodi und Hifiberry Probleme
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.