[1] 2 3 >>> MLD-5.x / Systems / x86 Systeme (PC) / (MLD 5.4 testing) dvb-mb does it work?
 

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« on: November 08, 2019, 23:26:14 »
Hello,

I upgraded from MLD 5.4 stable to testing version, my dvb-s2 hardware isn't recognized using dvb package therefore i installed dvb-mb.
Now, i have a problem because it doesn't work at all, dvb-core can't be loaded as well.
Here is some logs:

Code: [Select]
[   10.920514] mc: Linux media interface: v0.10
[   10.938191] rc_core: loading out-of-tree module taints kernel.
[   10.938653] WARNING: You are using an experimental version of the media stack.
[   10.938653] As the driver is backported to an older kernel, it doesn't offer
[   10.938653] enough quality for its usage in production.
[   10.938653] Use it with care.
[   10.938653] Latest git patches (needed if you report a bug to linux-media@vger.kernel.org):
[   10.938653]
[   10.956092] dvb_core: disagrees about version of symbol media_devnode_remove
[   10.956094] dvb_core: Unknown symbol media_devnode_remove (err -22)
[   10.956141] dvb_core: disagrees about version of symbol media_create_intf_link
[   10.956142] dvb_core: Unknown symbol media_create_intf_link (err -22)
[   10.956145] dvb_core: disagrees about version of symbol media_create_pad_links
[   10.956145] dvb_core: Unknown symbol media_create_pad_links (err -22)
[   10.956149] dvb_core: disagrees about version of symbol media_create_pad_link
[   10.956150] dvb_core: Unknown symbol media_create_pad_link (err -22)
[   10.956171] dvb_core: disagrees about version of symbol media_device_register_entity
[   10.956171] dvb_core: Unknown symbol media_device_register_entity (err -22)
[   10.956193] dvb_core: disagrees about version of symbol media_entity_pads_init
[   10.956194] dvb_core: Unknown symbol media_entity_pads_init (err -22)
[   10.956214] dvb_core: disagrees about version of symbol media_get_pad_index
[   10.956215] dvb_core: Unknown symbol media_get_pad_index (err -22)
[   10.956231] dvb_core: disagrees about version of symbol media_devnode_create
[   10.956232] dvb_core: Unknown symbol media_devnode_create (err -22)
[   10.956235] dvb_core: disagrees about version of symbol media_device_unregister_entity
[   10.956236] dvb_core: Unknown symbol media_device_unregister_entity (err -22)


Code: [Select]
modprobe: can't load module dvb-core (kernel/drivers/media/dvb-core/dvb-core.ko): Invalid argument
MLD>

My question is, is there anyone who tried dvb-mb package?
Does it work?
Please list the steps you made to make it work.
Did you upgrade from an older MLD version like i did or you just made a fresh installation?

Regards.
« Last Edit: November 08, 2019, 23:29:08 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #1 on: November 08, 2019, 23:44:06 »
The unstable package works fine. Only the dvb-core of the testing has this problem.
Tonight a new kernel version will build. So you can test tomorrow if the new kernel and dvb-mb package will work.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #2 on: November 08, 2019, 23:54:32 »
Hi Claus,
Thanks alot for the clarification,
I was going crazy since yesterday because i don't know what's wrong!  :D
Please take your time, you can build the new kernel after weekend if you like then i will test it.

Have a nice weekend :)

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #3 on: November 11, 2019, 15:15:45 »



It finally works .. thank you  :D
Is it possible to build dvb-mb-vtuner package?

Why don't you include Tvheadend in MLD distribution?
I installed it already and it works fine.



I added this tv-card to the wiki list

I uploaded 2 images for the same card one with .png & .jpg
How i can delete .png image?
« Last Edit: November 11, 2019, 15:29:55 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #4 on: November 11, 2019, 18:55:51 »
The build of the dvb-mb-vtuner don't work. I don't look deeper in this issue.
We do not add Tvheadend since it's enough to have one DVB Service.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #5 on: November 12, 2019, 17:39:11 »
Too bad it doesn't work, please give it another try when you have some spare time as it does work on my pc.

I don't use vnsiserver for a long time, as i remember if i need to scan one transponder i use wirbelscancontrol plugin which isn't available in MLD testing.

Is there an alternative plugin for that?



I tested Skystar eXpress HD remote control but it doesn't work so i edited that in the wiki page.



I'm still unable to delete skystar_2_express_hd.png, i think i need admin privileges for that, so you can do it  :)
« Last Edit: November 12, 2019, 17:42:54 by gr4vity »

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #6 on: November 12, 2019, 17:50:40 »
I receive the following errors when trying to run nvidia-settings - kodi
Should i ignore it or there is a fix for that?

Code: [Select]
ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at either
       /usr/share/nvidia/nvidia-application-profiles-340.107-key-documentation
       or /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       preopulated or validated, and will not be listed in the help text.
       Please see the README for possible values and descriptions.

Code: [Select]
libEGL warning: DRI2: failed to authenticate
libEGL warning: DRI2: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:${ORIGIN}/dri:/usr/lib/dri)



Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #7 on: November 12, 2019, 20:20:43 »
Do you get the libEGL error message on a nvidia system?
Do you use the nvidia or the nvidia.legacy driver?
« Last Edit: November 12, 2019, 20:31:35 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #8 on: November 12, 2019, 20:30:42 »
I have add the missing files.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #9 on: November 12, 2019, 20:45:56 »
Thanks Claus,
I reinstalled nvidia legacy driver, nvidia-settings error isn't displayed anymore.
Yes i'm getting ibEGL error when i run kodi on nvidia system.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #10 on: November 12, 2019, 21:31:02 »
Do you still get the libEGL error?
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #11 on: November 12, 2019, 21:34:50 »
I have now add the swrast lib also to the nvidia.legacy package.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #12 on: November 12, 2019, 21:49:53 »
I have now add the swrast lib also to the nvidia.legacy package.

I installed it, the following packages were also installed
libdrm-amdgpu1 libdrm-nouveau2 libdrm-radeon1 libedit2 libelf1 libllvm3.9
swrast error message is gone
I'm getting this message now
Code: [Select]
libEGL warning: DRI2: failed to authenticate
I can ignore it because kodi works.
« Last Edit: November 12, 2019, 21:53:08 by gr4vity »

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 117
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #13 on: November 12, 2019, 22:30:23 »
Is it possible to upgrade xine-lib to the latest version because the included one is old.
I use v1.2.9 on pc, i had to manually copy it to MLD then had to install some libs,
It works
XINE-LIB version: 1.2.9hg
But it would be better if you can upgrade it.  :)

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17871
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #14 on: November 13, 2019, 16:32:43 »
The actual installed libxine version is the 1.2.8 and there is no newer version for debian stretch available.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] 2 3 >>> MLD-5.x / Systems / x86 Systeme (PC) / (MLD 5.4 testing) dvb-mb does it work?
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.