1 2 3 [4] MLD-5.x / Systems / x86 Systeme (PC) / (MLD 5.4 testing) dvb-mb does it work?
 

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #45 on: November 23, 2019, 19:44:20 »
Hi Claus,

Why do you insist that there are vtuner inside dvb-mb sources?
I don't see any, so i used external vtuner sources.
Maybe i'm mistaken  :-\
Could you tell me the location of vtuner source?
In which folder?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #46 on: November 23, 2019, 21:16:00 »
If you use the external, what do you change, to build it again the dvb-mb drivers.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #47 on: November 24, 2019, 15:08:00 »
If you use the external, what do you change, to build it again the dvb-mb drivers.

Hi,

Please check your inbox,
What about vtunerc.ko which i sent you?
Did you figure out why it crashes if satip-client started automatically?
To make it work
- disable satip automatic restart
- Load vtunerc
- run satip-client -s192.168.1.3 -t0
(replace the above ip address with yours)
« Last Edit: November 24, 2019, 15:24:59 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #48 on: November 30, 2019, 00:27:01 »
There was a general problem with the dvb-mb drivers. It build its own mc.ko driver, witch is not compatible with mc.ko driver of the kernel. But that is needed by the alsa usb sound driver for example.
I have now add a patch to use the kernel mc driver.
Now the dvb-mb vtuner work on my test system.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #49 on: November 30, 2019, 14:31:41 »
Great work Claus  :), i will make sure to use that patch before i ungrade to MLD 5.3.14.
dvb-mb vtuner works on my MLD 5.3.11 as well.
The problem is related to satip init script.
If you install satip then reboot your system you will notice that vtuner doesn't work.
I think you need to create a new satip package because the existing satip version depends on dvb-vtuner.

« Last Edit: November 30, 2019, 16:01:43 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #50 on: November 30, 2019, 16:39:48 »
I have no problem with the satip package. On my test system it works fine with the dvb-mb vtuner, without any changes.
On my system the vtuner kernel modul will be loaded automatically and satip-client can use it. The only thing I have configured ist, to use only one satip device, since all other devices are used by my productive system.
Do you do not have the same issue with the pure dvb-vtuner package?
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #51 on: November 30, 2019, 17:18:06 »
MLD> dpkg -i satip_2019.10.24-24.1_amd64.deb
Selecting previously unselected package satip.
(Reading database ... 19328 files and directories currently installed.)
Preparing to unpack satip_2019.10.24-24.1_amd64.deb ...
Unpacking satip (2019.10.24-24.1) ...
dpkg: dependency problems prevent configuration of satip:
 satip depends on dvb-vtuner; however:
  Package dvb-vtuner is not installed.

I'm confused   :-\
Do you mean the above satip package?
How you are able to install it without any changes?

Yes vtuner will be loaded automatically but it doesn't work for me.
Can you run lsdvb and let me know if you see that vtuner adapter exists?

To make it work i must delete satip init script, reboot then run satip-client manually.

No, i don't have the same issue with pure dvb-vtuner package.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #52 on: November 30, 2019, 19:47:12 »
The actual dvb-mb package provides the dvb-vtuner. So you can install satip after you have installed the dvb-mb package.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #53 on: November 30, 2019, 19:54:09 »
The dvb-mb vtuner.ko an the dvb-vtuner.ko should work equal, since they are build from the same sources.
 
There is no lsdvb tool in the MLD
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #54 on: November 30, 2019, 20:25:33 »
Yes, they are equal and they both work, the problem is satip init script
It works fine with dvb-vtuner but it causes dvb-mb vtuner to crash

vtuner.ko can be loaded automatically after boot but it may not work
Here is lsdvb
If you see vtuner adapter then it works,
If you don't see vtuner adapter then it doesn't.
« Last Edit: November 30, 2019, 22:29:31 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #55 on: December 01, 2019, 12:59:32 »
Since both drivers are the same, I do not understand, why do you have problems with one of them and not with the other?
Maybe your system has a higher load if it init also the hardware dvb devices. You can try to increase the sleep in the satip init script at line 62 to verify that.
Or the vdr starts to early and can't use the vtuner dvb devices if there are also hardware dvb devices. You can check if the count of dvb devices (VDR_DVB_ADAPTER_COUNT) in the /etc/rc.config is correct. Or remove the hardware dvb devices from your system for a test.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #56 on: December 01, 2019, 15:10:49 »
I increased sleep to 10
Problem still not solved.
VDR_DVB_ADAPTER_COUNT="2"
By the way if i select verbose during boot i see that message after satip starts
Starting satip:
Killed                                                               done
Do you see that too?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17914
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) dvb-mb does it work?
« Reply #57 on: December 01, 2019, 20:48:32 »
Does you really have only two dvb devices? Hardware + vtuner?

I do not have that "Killed" message.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 147
    • View Profile
(MLD 5.4 testing) dvb-mb does it work?
« Reply #58 on: December 02, 2019, 15:08:45 »
Yes, i have skystar pci-e + vtuner
I don't know what does "Killed" message mean or what was killed?
vtuner or satip-client or both.
Anyway, i will stick with kernel 5.3.11 for now and will start satip-client manually.
Thanks Claus.
« Last Edit: December 02, 2019, 15:10:33 by gr4vity »

1 2 3 [4] MLD-5.x / Systems / x86 Systeme (PC) / (MLD 5.4 testing) dvb-mb does it work?
 



Users Online Users Online

0 Members and 4 Guests are viewing this topic.