[1] MLD-5.x / Development / Plugin fuer 5.4 stable kompilieren
 

Offline madru

  • Newbie
  • *
  • Posts: 22
    • View Profile
Plugin fuer 5.4 stable kompilieren
« on: January 02, 2020, 10:48:03 »
zuerst möchte ich ein frohes neues Jahr wünschen......


Ich probiere für das aktuelle 5.4 stable DVB-API zu kompilieren und zu installieren.

habe die dev umgestellt auf stable
Code: [Select]
echo “.SILENT:\nCLASS = stable“ > Makefile.config (hoffe das ist korrekt so)
kompilieren läuft durch, beim installieren geht es dann aber schief da ein Downgrade von libresolv.so.2 und librt.so.1 gemacht wird und dann ist alles tot :(

kann mir jemand beschreiben, wie man es korrekt macht?


Danke

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18029
    • View Profile
    • ClausMuus.de
Plugin fuer 5.4 stable kompilieren
« Reply #1 on: January 02, 2020, 17:35:57 »
Die class Einstellung in der Makefile.config ist nicht nötig. Das hat nur Einfluss auf unseren Nightbuild.
Magst Du mal die Ausgabe vom update posten. Eventuell kann ich dann mehr sagen.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18029
    • View Profile
    • ClausMuus.de
Plugin fuer 5.4 stable kompilieren
« Reply #2 on: January 02, 2020, 17:42:18 »
Worum geht's Dir beim selbst kompilieren? Brauchst Du eine neuere Version? Hast Du's schon mit der testing Version versucht.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline madru

  • Newbie
  • *
  • Posts: 22
    • View Profile
Plugin fuer 5.4 stable kompilieren
« Reply #3 on: January 02, 2020, 18:19:12 »
Hallo Claus,

mit testing kann ich alle deb's installieren.

-rw-r--r-- 1 root root   51806 Jan  1 19:12 libgcc1_6.3.0-~1+root_amd64.deb
-rw-r--r-- 1 root root 1371872 Jan  1 19:11 libssl1.1_1.1.0-~2+root_amd64.deb
-rw-r--r-- 1 root root  487556 Jan  1 19:12 libstdc++6_6.3.0-~1+root_amd64.deb
-rw-r--r-- 1 root root   65492 Jan  1 19:11 vdr-plugin-dvbapi_2017.11.25-13.1+2.4.1.218.26+root_amd64.deb

anschießend meint MLD aber ein Update machen zu müssen:

Upgrade all packages
Downloading libstdc++6
Downloading libgcc1
Downloading libssl1.1
Removing vdr-plugin-dvbapi
Unpacking libstdc++6
Setting up libstdc++6
Unpacking libgcc1
Setting up libgcc1
Unpacking libssl1.1
Setting up libssl1.1

und dann geht auch nix mehr:

MLD-SERVER> dpkg -i vdr-plugin-dvbapi_2017.11.25-13.1\+2.4.1.218.26\+root_amd64.deb
Create a snapshot of '/mnt/root/@root' in '/mnt/root/2020-01-02 18:10'
Delete subvolume (no-commit): '/mnt/root/2020-01-02 18:09'
Selecting previously unselected package vdr-plugin-dvbapi.
(Reading database ... 2699 files and directories currently installed.)
Preparing to unpack vdr-plugin-dvbapi_2017.11.25-13.1+2.4.1.218.26+root_amd64.deb ...
Unpacking vdr-plugin-dvbapi (1:2017.11.25-13.1+2.4.1.218.26+root) ...
dpkg: dependency problems prevent configuration of vdr-plugin-dvbapi:
 vdr-plugin-dvbapi depends on libssl1.1 (>= 1.1.0-~2+root); however:
  Version of libssl1.1 on system is 1.1.0-~2.
 vdr-plugin-dvbapi depends on libstdc++6 (>= 6.3.0-~1+root); however:
  Version of libstdc++6 on system is 6.3.0-~1.
 vdr-plugin-dvbapi depends on libgcc1 (>= 6.3.0-~1+root); however:
 Version of libgcc1 on system is 6.3.0-~1.


Eigentlich wollte ich nur von 5.3 auf 5.4 updaten (never change a running system) leider ging das voll in die Hose :(


bin für jede Hilfe dankbar.

Guido
« Last Edit: January 02, 2020, 20:17:46 by madru »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18029
    • View Profile
    • ClausMuus.de
Plugin fuer 5.4 stable kompilieren
« Reply #4 on: January 02, 2020, 18:27:45 »
Und warum nimmst Du nicht das vorhandene dvb-api?
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline madru

  • Newbie
  • *
  • Posts: 22
    • View Profile
Plugin fuer 5.4 stable kompilieren
« Reply #5 on: January 02, 2020, 18:55:30 »
Hallo Claus,

würde ich, wenn ich wüste wo es ein ppa oder die deb's gibt
« Last Edit: January 02, 2020, 20:17:34 by madru »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18029
    • View Profile
    • ClausMuus.de
Plugin fuer 5.4 stable kompilieren
« Reply #6 on: January 02, 2020, 19:26:35 »
Ich hab Dir eine PM geschickt.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / Development / Plugin fuer 5.4 stable kompilieren
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.