[1] MLD-5.x / Systems / Raspberry PI / [MLD 5.4 testing] gstreamer error
 

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 345
    • View Profile
[MLD 5.4 testing] gstreamer error
« on: March 25, 2020, 16:28:31 »
Hi,

I have a problem using gstreamer on Raspberry Pi 3, error message as below:

Code: [Select]
(gst-plugin-scanner:1886): GStreamer-WARNING **: Failed to load plugin '/usr/lib/arm-linux-gnueabihf/gstreamer-1.0/libgstgtksink.so': /usr/lib/arm-linux-gnueabihf/gstreamer-1.0/libgstgtksink.so: undefined symbol: gdk_wayland_display_get_type

(gst-plugin-scanner:1886): GLib-GObject-WARNING **: cannot register existing type 'GstOMXAudioSink'

(gst-plugin-scanner:1886): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gst-plugin-scanner:1886): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(gst-plugin-scanner:1886): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(gst-plugin-scanner:1886): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

How to resolve that issue?

Best Regards.

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1210
    • View Profile
[MLD 5.4 testing] gstreamer error
« Reply #1 on: March 25, 2020, 18:03:20 »
Hi gr4vity,

the main problem is, that the gstreamer plugin is an ongoing development,
and it is not finished yet ;)

I am doing my best to finish it.

best regrads
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 345
    • View Profile
[MLD 5.4 testing] gstreamer error
« Reply #2 on: March 25, 2020, 18:25:58 »
Hello Roland,

Thanks for the quick reply,
No problem, take your time.  ;)

Best Regards.

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 345
    • View Profile
[MLD 5.4 testing] gstreamer error
« Reply #3 on: July 29, 2020, 15:54:25 »
Hi gravity,

the main problem is, that in the firmware for the rpi4 is not finished, yet.
And therefore the develop on the gestreamer is stucking :(

Because the GPU on the rpi4 is complete differnt from the rpi3/2.

best regards,

 Roland
« Last Edit: August 09, 2020, 22:01:57 by rfehr »

[1] MLD-5.x / Systems / Raspberry PI / [MLD 5.4 testing] gstreamer error
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.