[1] MLD-5.x / General / Owncloud setup/config
 

Offline kamarjaeger

  • Newbie
  • *
  • Posts: 18
    • View Profile
Owncloud setup/config
« on: May 30, 2020, 21:57:49 »
Hallo zusammen,

ich will mein MLD Server um owncloud erweitern und war begeistert, dass ihr schon ein passendes Paket habt! Installation lief auch ohne Fehler durch:

Code: [Select]
apt-get install owncloud
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libaio1 libapparmor1 libcurl3 libedit2 libfcgi0ldbl libfftw3-double3 libgcrypt20 libgd3 libgeoip1 libgpg-error0 libicu52 libidn11 libjson-c2
  liblqr-1-0 libltdl7 libmagickcore-6.q16-2 libmagickwand-6.q16-2 libmcrypt4 libonig2 libqdbm14 librtmp1 libsmbclient libssh2-1 libsystemd0 libvpx1
  libxpm4 libxslt1.1 mysql-server nginx php5 smbclient
The following NEW packages will be installed:
  libaio1 libapparmor1 libcurl3 libedit2 libfcgi0ldbl libfftw3-double3 libgcrypt20 libgd3 libgeoip1 libgpg-error0 libicu52 libidn11 libjson-c2
  liblqr-1-0 libltdl7 libmagickcore-6.q16-2 libmagickwand-6.q16-2 libmcrypt4 libonig2 libqdbm14 librtmp1 libsmbclient libssh2-1 libsystemd0 libvpx1
  libxpm4 libxslt1.1 mysql-server nginx owncloud php5 smbclient
0 upgraded, 32 newly installed, 0 to remove and 0 not upgraded.
Need to get 223 MB of archives.
After this operation, 436 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
  libedit2 libgpg-error0 libgcrypt20 libidn11 libaio1 librtmp1 libssh2-1 libcurl3 libfcgi0ldbl libfftw3-double3 libxpm4 libvpx1 libgd3 libgeoip1
  libicu52 liblqr-1-0 libltdl7 libmagickcore-6.q16-2 libmagickwand-6.q16-2 libmcrypt4 libonig2 libqdbm14 libsmbclient libsystemd0 libxslt1.1
  mysql-server nginx libjson-c2 libapparmor1 php5 smbclient owncloud
Authentication warning overridden.
Get:1 http://www.minidvblinux.de/download/5.1/files/ stable/main libedit2 amd64 3.1-~1 [88,9 kB]
Get:2 http://www.minidvblinux.de/download/5.1/files/ stable/main libgpg-error0 amd64 1.17-~1 [32,4 kB]
Get:3 http://www.minidvblinux.de/download/5.1/files/ stable/main libgcrypt20 amd64 1.6.3-~1 [383 kB]
Get:4 http://www.minidvblinux.de/download/5.1/files/ stable/main libidn11 amd64 1.29-~1 [68,7 kB]
Get:5 http://www.minidvblinux.de/download/5.1/files/ stable/main libaio1 amd64 0.3.110-~1 [3.522 B]
Get:6 http://www.minidvblinux.de/download/5.1/files/ stable/main librtmp1 amd64 2.4-~1 [59,9 kB]
Get:7 http://www.minidvblinux.de/download/5.1/files/ stable/main libssh2-1 amd64 1.4.3-~1 [74,2 kB]
Get:8 http://www.minidvblinux.de/download/5.1/files/ stable/main libcurl3 amd64 7.38.0-~2 [221 kB]
Get:9 http://www.minidvblinux.de/download/5.1/files/ stable/main libfcgi0ldbl amd64 2.4.0-~1 [21,2 kB]
Get:10 http://www.minidvblinux.de/download/5.1/files/ stable/main libfftw3-double3 amd64 3.3.4-~1 [862 kB]
Get:11 http://www.minidvblinux.de/download/5.1/files/ stable/main libxpm4 amd64 3.5.11-~1 [36,8 kB]
Get:12 http://www.minidvblinux.de/download/5.1/files/ stable/main libvpx1 amd64 1.3.0-~1 [738 kB]
Get:13 http://www.minidvblinux.de/download/5.1/files/ stable/main libgd3 amd64 2.1.0-~1 [148 kB]
Get:14 http://www.minidvblinux.de/download/5.1/files/ stable/main libgeoip1 amd64 1.6.2-~1 [83,2 kB]
Get:15 http://www.minidvblinux.de/download/5.1/files/ stable/main libicu52 amd64 52.1-~4 [10,9 MB]
Get:16 http://www.minidvblinux.de/download/5.1/files/ stable/main liblqr-1-0 amd64 0.4.2-~1 [25,4 kB]                                               
Get:17 http://www.minidvblinux.de/download/5.1/files/ stable/main libltdl7 amd64 2.4.2-~1 [19,4 kB]                                                 
Get:18 http://www.minidvblinux.de/download/5.1/files/ stable/main libmagickcore-6.q16-2 amd64 6.8.9.9-~1 [1.079 kB]                                 
Get:19 http://www.minidvblinux.de/download/5.1/files/ stable/main libmagickwand-6.q16-2 amd64 6.8.9.9-~1 [389 kB]                                   
Get:20 http://www.minidvblinux.de/download/5.1/files/ stable/main libmcrypt4 amd64 2.5.8-~1 [76,6 kB]                                               
Get:21 http://www.minidvblinux.de/download/5.1/files/ stable/main libonig2 amd64 5.9.5-~1 [115 kB]                                                   
Get:22 http://www.minidvblinux.de/download/5.1/files/ stable/main libqdbm14 amd64 1.8.78-~1 [148 kB]                                                 
Get:23 http://www.minidvblinux.de/download/5.1/files/ stable/main libsmbclient amd64 4.1.17-~1 [60,4 kB]                                             
Get:24 http://www.minidvblinux.de/download/5.1/files/ stable/main libsystemd0 amd64 215-~1 [70,2 kB]                                                 
Get:25 http://www.minidvblinux.de/download/5.1/files/ stable/main libxslt1.1 amd64 1.1.28-~2 [150 kB]                                               
Get:26 http://www.minidvblinux.de/download/5.1/files/ stable/main mysql-server amd64 5.5.43-16 [17,5 MB]                                             
Get:27 http://www.minidvblinux.de/download/5.1/files/ stable/main nginx amd64 1.9.10-9 [547 kB]                                                     
Get:28 http://www.minidvblinux.de/download/5.1/files/ stable/main libjson-c2 amd64 0.11-~1 [20,9 kB]                                                 
Get:29 http://www.minidvblinux.de/download/5.1/files/ stable/main libapparmor1 amd64 2.9.0-~1 [24,7 kB]                                             
Get:30 http://www.minidvblinux.de/download/5.1/files/ stable/main php5 amd64 5.6.17-11 [9.906 kB]                                                   
Get:31 http://www.minidvblinux.de/download/5.1/files/ stable/main smbclient amd64 2-2 [256 kB]                                                       
Get:32 http://www.minidvblinux.de/download/5.1/files/ stable/main owncloud amd64 9.1.0-16 [179 MB]                                                   
Fetched 223 MB in 2min 34s (1.437 kB/s)                                                                                                             
Create a snapshot of '/mnt/root/@root' in '/mnt/root/2020-05-30 20:48'
Selecting previously unselected package libedit2.
(Reading database ... 9616 files and directories currently installed.)
Preparing to unpack .../libedit2_3.1-~1_amd64.deb ...
Unpacking libedit2 (3.1-~1) ...
Selecting previously unselected package libgpg-error0.
Preparing to unpack .../libgpg-error0_1.17-~1_amd64.deb ...
Unpacking libgpg-error0 (1.17-~1) ...
Selecting previously unselected package libgcrypt20.
Preparing to unpack .../libgcrypt20_1.6.3-~1_amd64.deb ...
Unpacking libgcrypt20 (1.6.3-~1) ...
Selecting previously unselected package libidn11.
Preparing to unpack .../libidn11_1.29-~1_amd64.deb ...
Unpacking libidn11 (1.29-~1) ...
Selecting previously unselected package libaio1.
Preparing to unpack .../libaio1_0.3.110-~1_amd64.deb ...
Unpacking libaio1 (0.3.110-~1) ...
Selecting previously unselected package librtmp1.
Preparing to unpack .../librtmp1_2.4-~1_amd64.deb ...
Unpacking librtmp1 (2.4-~1) ...
Selecting previously unselected package libssh2-1.
Preparing to unpack .../libssh2-1_1.4.3-~1_amd64.deb ...
Unpacking libssh2-1 (1.4.3-~1) ...
Selecting previously unselected package libcurl3.
Preparing to unpack .../libcurl3_7.38.0-~2_amd64.deb ...
Unpacking libcurl3 (7.38.0-~2) ...
Selecting previously unselected package libfcgi0ldbl.
Preparing to unpack .../libfcgi0ldbl_2.4.0-~1_amd64.deb ...
Unpacking libfcgi0ldbl (2.4.0-~1) ...
Selecting previously unselected package libfftw3-double3.
Preparing to unpack .../libfftw3-double3_3.3.4-~1_amd64.deb ...
Unpacking libfftw3-double3 (3.3.4-~1) ...
Selecting previously unselected package libxpm4.
Preparing to unpack .../libxpm4_3.5.11-~1_amd64.deb ...
Unpacking libxpm4 (3.5.11-~1) ...
Selecting previously unselected package libvpx1.
Preparing to unpack .../libvpx1_1.3.0-~1_amd64.deb ...
Unpacking libvpx1 (1.3.0-~1) ...
Selecting previously unselected package libgd3.
Preparing to unpack .../libgd3_2.1.0-~1_amd64.deb ...
Unpacking libgd3 (2.1.0-~1) ...
Selecting previously unselected package libgeoip1.
Preparing to unpack .../libgeoip1_1.6.2-~1_amd64.deb ...
Unpacking libgeoip1 (1.6.2-~1) ...
Selecting previously unselected package libicu52.
Preparing to unpack .../libicu52_52.1-~4_amd64.deb ...
Unpacking libicu52 (52.1-~4) ...
Selecting previously unselected package liblqr-1-0.
Preparing to unpack .../liblqr-1-0_0.4.2-~1_amd64.deb ...
Unpacking liblqr-1-0 (0.4.2-~1) ...
Selecting previously unselected package libltdl7.
Preparing to unpack .../libltdl7_2.4.2-~1_amd64.deb ...
Unpacking libltdl7 (2.4.2-~1) ...
Selecting previously unselected package libmagickcore-6.q16-2.
Preparing to unpack .../libmagickcore-6.q16-2_6.8.9.9-~1_amd64.deb ...
Unpacking libmagickcore-6.q16-2 (6.8.9.9-~1) ...
Selecting previously unselected package libmagickwand-6.q16-2.
Preparing to unpack .../libmagickwand-6.q16-2_6.8.9.9-~1_amd64.deb ...
Unpacking libmagickwand-6.q16-2 (6.8.9.9-~1) ...
Selecting previously unselected package libmcrypt4.
Preparing to unpack .../libmcrypt4_2.5.8-~1_amd64.deb ...
Unpacking libmcrypt4 (2.5.8-~1) ...
Selecting previously unselected package libonig2.
Preparing to unpack .../libonig2_5.9.5-~1_amd64.deb ...
Unpacking libonig2 (5.9.5-~1) ...
Selecting previously unselected package libqdbm14.
Preparing to unpack .../libqdbm14_1.8.78-~1_amd64.deb ...
Unpacking libqdbm14 (1.8.78-~1) ...
Selecting previously unselected package libsmbclient.
Preparing to unpack .../libsmbclient_4.1.17-~1_amd64.deb ...
Unpacking libsmbclient (4.1.17-~1) ...
Selecting previously unselected package libsystemd0.
Preparing to unpack .../libsystemd0_215-~1_amd64.deb ...
Unpacking libsystemd0 (215-~1) ...
Selecting previously unselected package libxslt1.1.
Preparing to unpack .../libxslt1.1_1.1.28-~2_amd64.deb ...
Unpacking libxslt1.1 (1.1.28-~2) ...
Selecting previously unselected package mysql-server.
Preparing to unpack .../mysql-server_5.5.43-16_amd64.deb ...
Unpacking mysql-server (5.5.43-16) ...
Selecting previously unselected package nginx.
Preparing to unpack .../nginx_1.9.10-9_amd64.deb ...
Unpacking nginx (1.9.10-9) ...
Selecting previously unselected package libjson-c2.
Preparing to unpack .../libjson-c2_0.11-~1_amd64.deb ...
Unpacking libjson-c2 (0.11-~1) ...
Selecting previously unselected package libapparmor1.
Preparing to unpack .../libapparmor1_2.9.0-~1_amd64.deb ...
Unpacking libapparmor1 (2.9.0-~1) ...
Selecting previously unselected package php5.
Preparing to unpack .../php5_5.6.17-11_amd64.deb ...
Unpacking php5 (5.6.17-11) ...
Selecting previously unselected package smbclient.
Preparing to unpack .../smbclient_2-2_amd64.deb ...
Unpacking smbclient (2-2) ...
Selecting previously unselected package owncloud.
Preparing to unpack .../owncloud_9.1.0-16_amd64.deb ...
Unpacking owncloud (9.1.0-16) ...
Setting up libedit2 (3.1-~1) ...
Setting up libgpg-error0 (1.17-~1) ...
Setting up libgcrypt20 (1.6.3-~1) ...
Setting up libidn11 (1.29-~1) ...
Setting up libaio1 (0.3.110-~1) ...
Setting up librtmp1 (2.4-~1) ...
Setting up libssh2-1 (1.4.3-~1) ...
Setting up libcurl3 (7.38.0-~2) ...
Setting up libfcgi0ldbl (2.4.0-~1) ...
Setting up libfftw3-double3 (3.3.4-~1) ...
Setting up libxpm4 (3.5.11-~1) ...
Setting up libvpx1 (1.3.0-~1) ...
Setting up libgd3 (2.1.0-~1) ...
Setting up libgeoip1 (1.6.2-~1) ...
Setting up libicu52 (52.1-~4) ...
Setting up liblqr-1-0 (0.4.2-~1) ...
Setting up libltdl7 (2.4.2-~1) ...
Setting up libmagickcore-6.q16-2 (6.8.9.9-~1) ...
Setting up libmagickwand-6.q16-2 (6.8.9.9-~1) ...
Setting up libmcrypt4 (2.5.8-~1) ...
Setting up libonig2 (5.9.5-~1) ...
Setting up libqdbm14 (1.8.78-~1) ...
Setting up libsmbclient (4.1.17-~1) ...
Setting up libsystemd0 (215-~1) ...
Setting up libxslt1.1 (1.1.28-~2) ...
Setting up mysql-server (5.5.43-16) ...
Starting mysql-server:                                                                                                                     done
Setting up nginx (1.9.10-9) ...
Generating a 1024 bit RSA private key
..++++++
...............++++++
writing new private key to '/etc/ssl/nginx/owncloud.key'
-----
Starting nginx:                                                                                                                            done
Setting up libjson-c2 (0.11-~1) ...
Setting up libapparmor1 (2.9.0-~1) ...
Setting up php5 (5.6.17-11) ...
Starting php-fpm:                                                                                                                          done
Setting up smbclient (2-2) ...
Setting up owncloud (9.1.0-16) ...

Wenn ich dann über das MLD-WebIF auf die cloud zugreife, komme ich auf den Config-Bildschirm (AdminKonto anlegen, Datenverzeichnis - ist schon vorgegeben, und DB user/pw/name/localhost).
Wenn ich den Entwicklungsthread hier zu owncload (https://www.minidvblinux.de/forum/index.php/topic,7379.75.html) richtig verstanden habe, sollte das script direkt alles konfigurieren, und ich diesen Bildschirm gar nicht zu sehen bekommen?

Da ich leider auch keine Dokumentation finde, wäre es prima, wenn ihr mir hier etwas aushelfen könntet. Mein Server läuft auf MLD 5.1 amd64, zugriff im LAN via ssh.

Besten Dank & Schöne Feiertage
kamarjaeger

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2341
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
Owncloud setup/config
« Reply #1 on: May 31, 2020, 08:35:52 »
Ich habe Owncloud nicht installiert sondern NextCloud aber vom Aufbau sind die sehr ähnlich oder fast gleich. Der Unterschied ist das Next mit der Entwicklung weiter ist. Der Link von dir ist auch schon sehr alt aus 2016, weiß auch nicht wie weit das ganze noch aktuelle ist. Hat es auch einen Grund warum du MLD 5.1 nimmst und nicht eine aktuellere Version oder gibt es das Owncloud Paket nicht  mehr? Sonst von der Anleitung her könntest du auch mal bei NetxCloud schauen wie das dort eingerichtet wird. Wegen dem Paket villt kann @P3f mehr dazu sagen, der hat das Paket damals eingepflegt was ich noch so weiß.
Gruß Mario
Meine Hardware (show / hide)

Offline kamarjaeger

  • Newbie
  • *
  • Posts: 18
    • View Profile
Owncloud setup/config
« Reply #2 on: June 04, 2020, 13:16:12 »
Meine MLD-Installation ist schon ein paar Jährchen alt (damals war 5.1 aktuell) und ich habe bisher einfach keine Neuinstallation / Upgrade vorgenommen. Liegt auch daran, dass ich die letzten Jahre kein TV-Anschluss in den Wohnungen hatte, sodass mein MLD nur als Medienserver für Kodi diente.
Ich hätte auch NextCloud genommen, aber OwnCloud war als fertiges Paket vorhanden, also wollte ich es damit probieren, um möglichst wenig von Hand machen zu müssen. Schließlich ist MLD ja auch eine abgespeckte Distri, was händische Installationen nun mal etwas aufwändiger macht.
Ich habe auch schon versucht, mich anhand der allgemeinen Anleitung zu Owncloud / Nextcloud zu helfen, aber laufe da immer wieder in eine Fehlermeldung, die entweder daran liegt, dass ich remote auf den Server zugreife, oder dass es für die DB schon standard Zugangsdaten durch die Installation gibt, die mir aber nicht bekannt sind. Hier wäre eine Auskunft aus dem Entwicklerkreis natürlich hilfreich.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18578
    • View Profile
    • ClausMuus.de
Owncloud setup/config
« Reply #3 on: June 04, 2020, 13:57:30 »
Im Jahr 2017 haben wir das Setup von Owncloud überarbeitet. Wie gut das davor funktioniert hat, weiß ich nicht.
Einige für Dich interessante Daten sind wohl diese hier:
  'dbname' => 'owncloud',
  'dbuser' => 'owncloud',
  'dbpassword' => 'ownpass',
Die stehen in der Datei /var/www/owncloud/config/config.php
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kamarjaeger

  • Newbie
  • *
  • Posts: 18
    • View Profile
Owncloud setup/config
« Reply #4 on: June 04, 2020, 15:00:02 »
Hallo Claus,

danke für die Infos, das hilft schon einmal. Allerdings bin ich über folgendes gestolpert:

unter /var/www/owncloud/config/config.php sieht es so aus:

Code: [Select]
<?php
$CONFIG 
= array (
  
'instanceid' => '***********',
  
'passwordsalt' => '*****************************',
  
'secret' => '**********************************************',
  
'trusted_domains' => 
  array (
    
=> '192.168.0.***:8014',
  ),
  
'datadirectory' => '/var/www/owncloud/data',
  
'overwrite.cli.url' => 'https://192.168.0.***:8014',
  
'dbtype' => 'mysql',
  
'version' => '9.1.0.15',
  
'dbname' => 'owncloud',
  
'dbhost' => 'localhost',
  
'dbtableprefix' => 'oc_',
);

Die * sind von mir eingefügt, hinter instanceid, passwordsalt und secret stehen jeweils Zahlen/Buchstabenkombos die vermutlich irgendwie generiert wurden (eve. verschlüsselte Schreibweise der Passwörter?). Bei der Eingabe von den Standard-Daten (ownloud/ownpass, root/mld500) erhalte ich folgende Meldung(Anhang).
Also habe ich mich zunächst versucht, via Terminal direkt auf der DB anzumelden:

Code: [Select]
mysql -u 'User' -p
Als root und bei der Passwortanfrage einfach nur bestätigen war ich drauf, andere PW gingen dementsprechend nicht. Über owncloud (ownpass) ging nix.

Also habe ich im Anmeldefeld der cloudDB die im terminal erfolgreiche Version mit root angewendet und als Administrator (ganz oben in der Maske) die MLD Anmeldedaten. Das gab dann nach ettlichen Sekunden Wartezeit erst einmal ein Gateway error  und nach einem Refresh dann "Benutzer gibt es bereits" Ich kann mich jetzt also endlich anmelden, aber die Zugangsdaten sind die Administrator-Daten aus dem ersten Feld der Maske. Irgendwie ist das alles krumm gelaufen, aber ich komme ja jetzt rein und kann mich um die Konfig kümmern.




[1] MLD-5.x / General / Owncloud setup/config
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.