[1] MLD-5.x / General / Client-Server-System
 

Offline triton-mole

  • Member
  • **
  • Posts: 68
    • View Profile
Client-Server-System
« on: September 06, 2020, 22:41:54 »
Hallo,

nachdem ich mit meinem RPi immer noch nicht zu einem stabilen Ergebnis gekommen bin, will ich nun versuchen, mit einem Mini-PC einen Server aufzusetzen, um den Pi nur noch als Client zu nutzen. Vielleicht geht das besser.

Zur Probe habe ich den Server aufgesetzt und er läuft auch soweit.
Zum Test habe ich einen Client auf einer VM am Desktop-PC.

Positiv überrascht hat mich, daß der Client sofort den Server gefunden hat, obwohl ja noch ein weitere MLD im Netzwerk läuft.
Auch das Sharing des EPG vom Server an den Client habe hinbekommen.

Jetzt ist nur meine Frage:
Kann man das System auch so einrichten, daß Aufnahmen komplett vom Server verarbeitet werden?
Daß also, wenn ich am Client im EPG eine Sendung zur Aufnahme auswähle, der Server diese dann aufnimmt und nicht der Client?
Daß ich am Client eine EPG-Suche definiere, die dann auf dem Server gespeichert und verarbeitet wird?
Der Client soll also eigentlich wirklich nur zum Gucken der Aufnahmen oder des laufenden Programmes dienen, alles andere soll der Server erledigen.
Geht das?
Wenn ja, wo finde ich Anleitungen dazu?

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18673
    • View Profile
    • ClausMuus.de
Client-Server-System
« Reply #1 on: September 08, 2020, 22:12:43 »
Das sollte meines Wissens nach die Voreinstellung sein.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline triton-mole

  • Member
  • **
  • Posts: 68
    • View Profile
Client-Server-System
« Reply #2 on: September 08, 2020, 23:08:39 »
Hmm....


Wenn ich am Timer eine Aufnahme programmieren will, bekomme ich die Meldung::
"Probleme beim Ansprechen des fernen Timers 0@192.168.xx.xx"  Die gemeldete IP ist die IP des Servers.

Ich kann aber am Client eine Aufnahme starten, die dann am Client aufzeichnet, nicht am Server.

Auch sehe ich Aufzeichnung auf dem Server nicht im Menü der Aufzeichnungen.

Im Prinzip habe ich nur die Livestreams des Servers am Client und das EPG, was aber schon mal ein guter Anfang ist.  ;)


Gerade merke ich noch: Ich habe am Client die Aufzeichnung gelöscht, die auch einen anderen Namen hatte, als auf dem Server und habe den Client runtergefahren und sehe jetzt, daß der Server nicht mehr aufzeichnet.
« Last Edit: September 08, 2020, 23:25:35 by triton-mole »

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 587
    • View Profile
Client-Server-System
« Reply #3 on: September 09, 2020, 13:13:51 »
Hallo,

der Workflow scheint grundsätzlich zu funktionieren, denn der Client versucht ja offensichtlich, einen Timer auf dem Server zu setzen.
Warum das scheitert, sollte sich aus dem Log des Servers ermitteln lassen. Denkbar sind z.B. fehlende Rechte.

Gruß
baltic
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline triton-mole

  • Member
  • **
  • Posts: 68
    • View Profile
Client-Server-System
« Reply #4 on: September 09, 2020, 19:53:11 »
Also gut, Logfiles habe ich mal hochgeladen.

mvPgZ

Wäre toll, wenn Ihr das mal auswerten könntet.

Danke!

Offline triton-mole

  • Member
  • **
  • Posts: 68
    • View Profile
Client-Server-System
« Reply #5 on: September 14, 2020, 22:17:15 »
Gestern habe ich es immerhin hinbekommen, daß der Client die Aufnahmen auf dem Server "sehen" und abspielen kann, indem ich das NFS-Laufwerk des Servers beim Client als Datenlaufwerk angegeben habe.


Programmieren kann ich immer noch nicht.

Ich würde mich echt freuen, wenn jemand mal meine Logfiles auswerten könnte.

Habe ich unter
mvPgZ
hochgeladen.

Dankeschön!!!!

[1] MLD-5.x / General / Client-Server-System
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.