[1] MLD-5.x / Systems / x86 Systeme (PC) / [5.5 unstable] AMD Radeon mit softhddevice und vdpau
 

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« on: September 07, 2020, 21:40:46 »
Hallo Zusammen,
ich bin gerade dabei MLD 5.5 auf verschieden Platformen zu testen.
Darunter sind auch verschiedene Syteme mit AMD Radeon GPU.

Auf einem Arctic MC001 mit eine älteren Radeon HD 5430 GPU lief softhddevice ootB.
Laut Xorg Log wird dabei der "VDPAU driver: r600", also die libvdpau_r600.so, verwendet.
Diese ist Bestandteil von Mesa.
Das Mesa Paket von MLD wurde also u.a. mit dem r600 Treiber gebaut.
Mit älteren Radeon GPUs, die den r600 Treiber nutzen, funktioniert MLD 5.5 also ohne Probleme.

Auf einem anderen Sytem mit AMD AM1 MB und einem Athlon 5350 mit integrierter Radeon HD 8400 GPU funktioniert die Ausgabe per softhddevice leider nicht.
Laut Log wird kein passender vdpau Treiber gefunden.
Diese GPUs verwenden den radeonsi Treiber, also libvdpau_radeonsi.so, der Bestandteil von Mesa ist.
Leider ist dieser nicht im mesa Paket von MLD enthalten.

Wäre es möglich, das mesa Paket der MLD auch mit dem radeonsi Treiber zu bauen?

Gruß Klaus
« Last Edit: September 08, 2020, 12:07:50 by franky »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18739
    • View Profile
    • ClausMuus.de
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #1 on: September 08, 2020, 22:43:46 »
Versuch's mal mit dem neuen mesa Paket. Das musst Du wahrscheinlich mit einem "apt install mesa --reinstall" installieren.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #2 on: September 09, 2020, 00:34:38 »
Danke für das neue mesa Paket.
Die libvdpau_radeonsi.so ist jetzt auf jeden Fall unter /usr/lib/vdpau vorhanden.
Leider habe ich noch kein TV Bild. Ton ist aber vorhanden.

Ein Log habe ich hochladen lassen. Der Upload Code lautet: 0ltkR6
Im xorg Logfile sieht man, dass kein vdpau-Modul geladen und somit keine Viedobeschleunigung aktiv ist.
Code: [Select]
[    21.249] [    21.399] (==) RADEON(0): DRI3 disabled
[    21.399] (==) RADEON(0): Backing store disabled
[    21.399] (WW) RADEON(0): Direct rendering disabled
[    21.399] (II) RADEON(0): Acceleration disabled
...
[    21.416] (II) Initializing extension GLX
[    21.416] (II) AIGLX: Screen 0 is not DRI2 capable

Bei dem anderen System mit der älteren Radeon, die den r600 Treiber nutzt, schaut das so aus:
Code: [Select]
[    28.155] (II) RADEON(0): [DRI2] Setup complete
[    28.155] (II) RADEON(0): [DRI2]   DRI driver: r600
[    28.155] (II) RADEON(0): [DRI2]   VDPAU driver: r600
....
[    28.171] (II) Initializing extension GLX
[    28.184] (II) AIGLX: Loaded and initialized r600
[    28.184] (II) GLX: Initialized DRI2 GL provider for screen 0
Ich habe die gleiche MLD-Installation auf diesem System gestartet und Bild und Ton.
Das Log von diesem System habe ich auch hochgeladen: cnkjvp

Schade, dass der Neubau von mesa incl. radeonsi nichts gebracht hat.
Evtl. müsste man auch xorg mit Treibern neu bauen, da es ja zwischen xorg und mesa Abhängigkeiten gibt.

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #3 on: October 13, 2020, 18:01:32 »
Hallo Claus,

ich habe jetzt noch mal mit meinem "Kabini"-System (AM1-Athlon5350 APU mit integrierter Radeon HD8400) experimentiert.
Und ich war erfolgreich.  :)

Die radeonsi libs hattest Du ja schon eingebaut, aber im Xorg-Log habe ich entdeckt, dass libglamoregl.so nicht geladen werden kann.
Anscheinend kommt der r600_dri ohne diese lib aus, der radeonsi_dri braucht sie aber.
Die libglamoregl.so war dann auch nicht unter /usr/lib/xorg/modules/ zu finden.
Ich hatte mich aber erinnert, dass die lib auch Bestandteil des xorg-intel Paketes ist.
Hab dann einfach auf auf meinem Intel-System mit MLD 5.5 die lib in ein tar.gz Archiv gepackt und auf dem Radeon-System wieder ausgepackt.

Nach einem Reboot hatte ich dann ein TV-Bild mit unter 10% Systemlast bei HD-Sendern.
Somit funktioniert VDPAU einwandfrei, was sich auch bei Tests mit Kodi bestätigt hat.

Könntest Du die libglamoregl.so noch in das xorg-radeon Paket der 5.5 unstable einbauen.
Die radeonsi libs sind ja schon im mesa Paket der 5.5 enthalten.

Es wäre auch super, wenn Du radeonsi in das xorg-radeon und mesa Paket der 5.4 testing einbauen könntest.

Schon mal vielen Dank!

Gruß Klaus

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18739
    • View Profile
    • ClausMuus.de
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #4 on: October 14, 2020, 22:26:48 »
Danke fürs untersuchen. Ich hab die Lib hinzu gefügt.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #5 on: October 15, 2020, 00:05:49 »
Ich danke für die schnelle Umsetzung.
Ich habe die 5.5 auf dem Kabini-System gerade auf einem Stick neu installiert.
Jetzt hat es wunderbar funktioniert - sofort TV-Bild. Super!  :)

Wie schaut es bei der 5.4. testing aus?
Ich habe gesehen, dass zwar xorg-radeon neu ist (incl. libglamoregl.so), aber mesa noch auf altem Stand ist.
Es fehlen also derzeit noch die radeonsi libs, die Du bei der 5.5 schon im September beim mesa-Paket eingebaut hast.
Wie stehen die Chancen, dass Du diese libs analog zur 5.5 auch in das mesa-Paket der 5.4 testing einbaust?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18739
    • View Profile
    • ClausMuus.de
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #6 on: October 15, 2020, 19:57:38 »
Hi,
da bin ich nicht sicher, ob wir das noch in die 5.4 mit aufnehmen. Pit hatte im Februar für die 5.5 eine andere Mesa Version eingestellt. Warum nur für die 5.5 weiß ich nicht genau, es besteht aber durchaus die Möglichkeit das die neuere Version nicht zum nvidia der 5.4 kompatibel ist.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
[5.5 unstable] AMD Radeon mit softhddevice und vdpau
« Reply #7 on: October 15, 2020, 23:39:09 »
Danke für die Info!
Hauptsache "radeonsi" und somit meine "Kabini"-System funktioniert überhaupt mit MLD. :)

[1] MLD-5.x / Systems / x86 Systeme (PC) / [5.5 unstable] AMD Radeon mit softhddevice und vdpau
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.