[1] MLD-5.x / Systems / x86 Systeme (PC) / MLD 5.5 auf NUC10i3FNH?
 

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« on: October 03, 2020, 14:50:00 »
Hallo zusammen,

ich wollte meinen VDR upgraden und habe jetzt einen NUC10i3FNH. Mein Fernziel ist ein Frontend mit 4k-Unterstützung (4k für Fotos schauen - TV ist  ja i.d.R. nur HD).
Bevor ich jetzt in die Logs zur Beseitigung weiterer Hindernisse gehe, habe ich folgende Fragen an Euch:

1)  Welche Frontends für MLD und Intel können 4k/UHD - sind welche in Entwicklung (im VDR-Portal gibt es verschiedene Varianten VAAPI etc. - werden die auch nach MLD portiert?)
2) Ein erster Versuch mit dem Net-boot-image hat einen xorg-Intel Treiber i915 geladen - es gab aber kein Bild.

Mein aktueller Status hier ist:
- Bios update durchgeführt (FN0045)
- kann von USB-Stick booten (Im Bios "Secure Boot" abgeschaltet und booten von USB enabled), habe von einem USB-Stick auf einen zweiten "installiert" - booten geht.
- kann nicht von SD-Karte booten (wird nicht in der Boot-Medium-Liste aufgelistet)
- Netzwerk wird nicht immer erkannt.

also momentan läuft das System rudimentär, aber ohne Bild (nur Splash Screen) und Ton...

Gruß Klemmerle

P.S.
Dein Upload Code lautet: mOnxOJ
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #1 on: October 03, 2020, 17:48:03 »
Hallo Kemmerle,

teste mal nicht die 5.5 sondern die 5.4 stable oder testing.
Die 5.4 testing hat derzeit das besser funktionierende Kodi 18 im Paket kodi-stable dabei.

Die 5.5 hat mit den Intel-Treibern noch Probleme.

Einen CoreI der 10ten Generation habe ich mangels HW bisher noch nicht getetestet.
Intel CoreI Systeme bis zur 8ten Generation haben bei mir mit MLD 5.4 aber super funktioniert.

Was verwendest Du eigentlich bei dem Nuc für DVB-HW?
Oder willst Du Sat-IP verwenden?

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #2 on: October 03, 2020, 18:34:12 »
Hallo Franky,
Ich habe als Signalquelle eine Octopus Net. Die 5.4 werde ich gleich nachher mal testen...

Gruß K.

Update: Bei der 5.4 wird leider weder das interne Netzwerk noch mein USB-Adapter erkannt...
« Last Edit: October 03, 2020, 20:23:23 by Klemmerle »
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18739
    • View Profile
    • ClausMuus.de
MLD 5.5 auf NUC10i3FNH?
« Reply #3 on: October 03, 2020, 22:12:06 »
In den Logs ist zu sehen, das der Intel i965 Treiber die gefundene Grafikkarte nicht unterstützt.
Demnach könnte das eine ein wenig zu neue Hardware ist.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #4 on: October 04, 2020, 09:26:09 »
Hallo Claus,
danke für die Info,
Nachdem es bei https://www.vdr-portal.de/forum/index.php?thread/133780-yavdr-ansible-focal-auf-nuc10i3-etc/&pageNo=1 unter Ubuntu-Focal Fortschritte gibt, hoffe ich, daß es bei MLD nur eine Frage der Zeit (und Entwickler-Support) ist, bis der NUC10 auch unterstützt wird.

Falls für MLD Tester gesucht werden - ich bin gerne dabei.  :)

Gruß K.

P.S. laut cinfo wird für den NUC10 der iHD_drv_video.so Treiber benötigt.
https://www.vdr-portal.de/forum/index.php?thread/132976-softhdcuvid-jetzt-mit-vaapi-und-hdr-support/&postID=1326623#post1326623
« Last Edit: October 04, 2020, 09:58:31 by Klemmerle »
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18739
    • View Profile
    • ClausMuus.de
MLD 5.5 auf NUC10i3FNH?
« Reply #5 on: October 06, 2020, 22:07:22 »
Ich hab den iHD_drv_video.so Treiber zum xorg-intel Paket hinzugefügt. Bitte teste mal ob das hilft. Ich weiß aber nicht ob in der xorg Configuration etwas geändert werden muss. Derzeit steht da das der "modesetting" Treiber verwendet werden soll. Alternativ kann dort auch "intel" eingetragen werden. Welche Treiber Datei die nachladen können weiß ich nicht.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #6 on: October 07, 2020, 09:57:19 »
Moin Claus,
vor dem Testen muß ich noch das Netzwerk zum laufen kriegen. Weder die Nuc-Schnittstelle noch meine zwei USB-Adapter werden erkannt. (MLD-5.5_netinstall_2020.08.22-181.7+1542_amd64.img)

Bei Ubuntu-Server 20.04 (hier läuft das Netzwerk) habe ich folgende Logs gefunden:
1) syslog:
Spoiler (show / hide)
2) dmesg:
Spoiler (show / hide)
3) lsmod:
Spoiler (show / hide)

kann man mit den Infos das Netzwerk unter MLD zum Laufen kriegen?

Gruß K.
« Last Edit: October 07, 2020, 09:59:10 by Klemmerle »
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18739
    • View Profile
    • ClausMuus.de
MLD 5.5 auf NUC10i3FNH?
« Reply #7 on: October 07, 2020, 11:03:31 »
Hi,
erstelle Dir Bitte ein Angepasstes Image, bei dem Du den netinstaller auswählst, und zusätzlich das network-drivers Paket hinzufügst. Dann sollte das Netzwerk funktionieren.
Alternativ kannst Du den USB Stick auch an einem anderen PC booten, und dort das network-drivers Paket installieren. Anschließend sollte mit dem Stick auch am NUC das Netzwerk funktionieren.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #8 on: October 07, 2020, 12:13:22 »
Hallo Claus,
das Image incl. Netzwerktreiber und SatIP hat die Netzwerkkarte automatisch erkannt. (Die Version ohn SatIP mußte ich manuell einrichten ???)
Webif geht. TV-Bild habe ich aber keines:
Code: [Select]
  VDR exits at Mi Okt  7 12:05:45 CEST 2020
vdr: intel_memman.c:38: intel_memman_init: Assertion `intel->bufmgr' failed.
Aborted

vainfo habe ich per apt nachinstalliert. Das liefert:
Quote
  MLD> vainfo
error: XDG_RUNTIME_DIR not set in the environment.
error: can't connect to X server!
libva info: VA-API version 1.4.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_4
vainfo: intel_memman.c:38: intel_memman_init: Assertion `intel->bufmgr' failed.
Aborted

Vielleicht findest Du ja noch was:
Code: [Select]
  Dein Upload Code lautet: 6B7xoQ
Gruß Klemens
« Last Edit: October 07, 2020, 12:17:37 by Klemmerle »
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #9 on: October 08, 2020, 17:55:57 »
Hallo Klemens,

wäre es möglich, dass Du mal ein Debian-Live vom aktuellen stable=Buster und testing=Bullseye ausprobierst?
In Buster, auf der MLD 5.5 basiert, ist zwar auch schon der iHD_drv_video.so drin, es ist aber fraglich, ober er ohne aktuelle Mesa-Version auch mit den Intel CPUs/GPUs der 10. Generation in deinem NUC funktioniert.
Bullseye enthält ein Mesa 20.1 mit dem neuen Intel-dri-Treiber iris_dri.so, der auch die neuen Intel-GPUs unterstützen sollte.

Die Live-ISOs gibts hier:
Buster: https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/
Bullseye: https://cdimage.debian.org/mirror/cdimage/weekly-live-builds/amd64/iso-hybrid/
« Last Edit: October 08, 2020, 18:05:56 by franky »

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #10 on: October 09, 2020, 15:10:38 »

Buster: https://cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/
Bullseye: https://cdimage.debian.org/mirror/cdimage/weekly-live-builds/amd64/iso-hybrid/

Hallo Franky,
(1) "debian-live-10.6.0-amd64-xfce.iso" (EE) unable to find a valid framebuffer device --- der Bildschirm bleibt nach der Auswahl "live" schwarz...
(2) "debian-live-testing-amd64-xfce.iso" : Funktioniert - auf 2160p30 umgestellt und in Firefox Youtube-4k-Testfilme geschaut: - o.k. (El. Leistung: 22W)
Nur der Testfilm 8k Peru HDR (in Youtube 2160p60-Einstellung) ruckelte etwas (35W)

Damit ist Debian Testing vergleichbar mit dem neuesten Ubuntu Live Image (20.04)
Diskussion über sinnvolle Auflösungen und Shader gibts hier bei YaVDR-Ansible:
https://www.vdr-portal.de/forum/index.php?thread/133780-yavdr-ansible-focal-auf-nuc10i3-etc/&postID=1330012#post1330012

Oder in kurz: den VDR in 2160p30 laufen zu lassen ist nicht sinnvoll...

Gruß K.
« Last Edit: October 09, 2020, 15:20:23 by Klemmerle »
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #11 on: October 09, 2020, 15:35:01 »
Hallo Klemens,

(1) Ist ja Debian stable "Buster" auf dem die MLD 5.5 unstable basiert.
     Somit wird es vermutlich extrem schwierig bis unmöglich, dein System mit MLD 5.5  zum Laufen zu bringen.

(2) Debian testing "Bullseye" hat halt als Nachfolger von "Buster" eine aktuellere Basis.
      Vermutlich verwendet da dein System bereits den "iris" dri-Treiber und den "iHD" VAAPI-Treiber.
      Wäre es möglich, dass Du mal ein xorg-log und die Ausgabe von vainfo postest.

Evtl. kann Claus mehr dazu sagen, ob bzw. wann MLD deine HW unterstützen könnte.

Gruß Klaus

Offline franky

  • Newbie
  • *
  • Posts: 35
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #12 on: October 10, 2020, 16:02:34 »
Hallo Klemens,

Du kannst dir den erneuten Test mit "Bullseye" sparen.

Ich habe mal "Bullseye und "Sid" auf meinem i3-7100 Testsystem getestet.
Auch bei diesem Intel CorI der 7. Generation werden nicht mehr die i965 Treiber verwendet.
Bei beiden läuft als VAAPI-Treiber der "iHD" und als dri-Treiber der "iris" aus Mesa 20 mit OpenGL 4.6.
Deshalb funktioniert auch dein CoreI der 10. Generation mit "Bullseye".

Offline Klemmerle

  • Adv. Member
  • ***
  • Posts: 168
    • View Profile
MLD 5.5 auf NUC10i3FNH?
« Reply #13 on: October 10, 2020, 21:32:23 »
Hallo Franky, danke fürs Aufklären - da muß ich wohl abwarten.... :-)
MLD 5.4 testing on Intel Core2 Duo E8400, NVIDIA GF108 [GeForce GT 430], TV Philips 4k, DD Octopus Net Max S8 + CEC-Remote via PulseEight

[1] MLD-5.x / Systems / x86 Systeme (PC) / MLD 5.5 auf NUC10i3FNH?
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.