[1] MLD-5.x / Systems / Raspberry PI / [rpi4/MLD 5.4. unstable] smb-mount mal wieder
 

Offline outis

  • Adv. Member
  • ***
  • Posts: 162
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« on: January 01, 2021, 20:36:31 »
Hallo,

ich versuche vergeblich, eine Sambafreigabe eines alten Teac WAP6000 zu mounten. Versucht habe ich es bislang so:

auf Freigabenamen prüfen mit smbclient -L

Code: [Select]
Sharename       Type      Comment
---------       ----      -------
HDD Disk 1      Disk     

Dann diverse Befehle:
Code: [Select]
MLD-Server4> mount -t -cifs '//192.168.100.138/HDD Disk 1' /media/cifs/
mount: mounting //192.168.100.138/HDD Disk 1 on /media/cifs/ failed: No such device
Code: [Select]
MLD-Server4> mount //192.168.100.138/HDD\ Disk\ 1 /media/cifs/ --username=jochen
Password for jochen@//192.168.100.138/HDD Disk 1:
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount: mounting //192.168.100.138/HDD Disk 1 on /media/cifs/ failed: Host is down
Was Quatsch ist, der Host ist nicht down. Die Fehlermeldung ist unabhängig davon, ob die Leerzeichen im Freigabenamen mit \, " oder ' behandelt werden. Sie bleibt auch, wenn -t cifs explizit angegeben wird. Auch, wenn mit -o vers=1.0 oder 3.0 gearbeitet wird.

Es geht darum, Aufnahmen vom rpi zum WAP6000 zu verschieben. Hätte ich gerne mit samba gemacht, nfs spricht der WAP6000 nicht. ssh geht auch nicht.

Danke im voraus für hilfreiche Hinweise zum Samba-Mount.

Viele Grüße

Jochen
Viele Grüße
Jochen

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18954
    • View Profile
    • ClausMuus.de
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #1 on: January 01, 2021, 22:25:49 »
Hast Du mal testweise eine Freigabe versucht, die keine Leerzeichen enthält?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline outis

  • Adv. Member
  • ***
  • Posts: 162
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #2 on: January 02, 2021, 12:39:45 »
Moin, Claus,

folgendes Bild ham wa:
Code: [Select]
MLD-Server4> mount //192.168.100.108/Music /media/cifs/ -t cifs --username=jochen
Password for jochen@//192.168.100.108/Music:
MLD-Server4> ls /media/cifs/
infobrowser.opml        Radiomitschnitte        Synology-Konfiguration
lost+found              rsync                   wget

Also smb-mount zu einem alten cubietruck erfolgreich.

Eine Freigabe ohne Leerzeichen kann ich auf dem WAP nicht anlegen. Denn der lässt sich nicht per ssh konfigurieren. Und vergibt halt für eine eingebaute Festplatte den Freigabenamen mit den Leerzeichen. Das ist auch kein Problem für Windows, auch nicht für mein Linux-Mint.

Mint zeigt den WAP im Dateibrowser als den Ort:
Code: [Select]
smb://wap6000/hdd%20disk%201/
Die Maskierung mit %20 nützt mir aber auf dem rpi auch nicht:
Code: [Select]
MLD-Server4> mount //192.168.100.138/hdd%20disk%201 /media/cifs/ -t cifs --usern
ame=jochen
Password for jochen@//192.168.100.138/hdd%20disk%201:
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount: mounting //192.168.100.138/hdd%20disk%201 on /media/cifs/ failed: Host is down

Versuche mit -o vers= helfen auch nicht.

Linux-Mint mountet den WAP allerdings nicht direkt als cifs/smbfs, sondern so:
Code: [Select]
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
Edit: Die Fehlversuche auf dem rpi finden übrigens keinen Widerhall in den log-files. Keine Einträge diesbezüglich.
« Last Edit: January 02, 2021, 12:44:11 by outis »
Viele Grüße
Jochen

Offline outis

  • Adv. Member
  • ***
  • Posts: 162
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #3 on: January 02, 2021, 12:48:48 »
Der cubietruck mountet den WAP:

Code: [Select]
jochen@cubie:~$ sudo mount -t cifs '//192.168.100.138/hdd disk 1' /mnt  -o username=jochen
Password for jochen@//192.168.100.138/hdd disk 1:  *********
jochen@cubie:~$ ls /mnt
bt  Videos
Viele Grüße
Jochen

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1250
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #4 on: January 02, 2021, 14:44:09 »
Hi Jochen,

hast du denn auf der MLD das Verzeichnis '/media/cifs/' ?

Code: [Select]
MLD-Server4> mount -t -cifs '//192.168.100.138/HDD Disk 1' /media/cifs/
mount: mounting //192.168.100.138/HDD Disk 1 on /media/cifs/ failed: No such device

Gruß,
  Rolabd
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline outis

  • Adv. Member
  • ***
  • Posts: 162
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #5 on: January 02, 2021, 15:02:04 »
Ja, das ist da:

Code: [Select]
MLD-Server4> ls /media/
cifs      dvd       usb-sda1

Es kommt auch immer ein Fehler, egal ob bei der Freigabe oder dem Mountpoint am Ende ein slash steht oder nicht, allerdings unterschiedlich:
Code: [Select]
MLD-Server4> mount '//192.168.100.138/hdd disk 1/' /media/cifs/  --username=joch
en
Password for jochen@//192.168.100.138/hdd disk 1/:
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount: mounting //192.168.100.138/hdd disk 1/ on /media/cifs/ failed: Invalid argument
Code: [Select]
MLD-Server4> mount '//192.168.100.138/hdd disk 1' /media/cifs/  --username=joche
n
Password for jochen@//192.168.100.138/hdd disk 1:
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount: mounting //192.168.100.138/hdd disk 1 on /media/cifs/ failed: Host is down

Man beachte den (fehlenden) slash am Ende der Freigabe.
Viele Grüße
Jochen

Offline outis

  • Adv. Member
  • ***
  • Posts: 162
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #6 on: January 02, 2021, 15:16:37 »
Ah, so möchte man's haben:

Code: [Select]
mount "//192.168.100.138/HDD Disk 1" /media/cifs/  -o vers=1.0 --username=jochen
Viele Grüße
Jochen

Offline Piet

  • Member
  • **
  • Posts: 69
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #7 on: January 02, 2021, 16:48:52 »
Sieht für mich so aus, als ob Host is down als Meldung kommt, wenn Nicht SMB 1 genutzt wird. Ansonsten sehe ich, daß Du beim Parameter -t vor das cifs noch ein - geschrieben hast.


Offline outis

  • Adv. Member
  • ***
  • Posts: 162
    • View Profile
[rpi4/MLD 5.4. unstable] smb-mount mal wieder
« Reply #8 on: January 02, 2021, 16:58:53 »
Sieht für mich so aus, als ob Host is down als Meldung kommt, wenn Nicht SMB 1 genutzt wird.
Ja, das denke ich auch.
Quote
Ansonsten sehe ich, daß Du beim Parameter -t vor das cifs noch ein - geschrieben hast.
Das ist natürlich Blödsinn. Nun ja, hat ja am Ende geklappt. Und autofs ist's auch zufrieden.
Code: [Select]
MLD-Server4> cat /etc/auto.cifs-shares
WAP -fstype=cifs,vers=1.0,... :"//192.168.100.138/HDD Disk 1/Videos/vdr-Aufnahmen"
Viele Grüße
Jochen

[1] MLD-5.x / Systems / Raspberry PI / [rpi4/MLD 5.4. unstable] smb-mount mal wieder
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.