Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - skippy

1
Hallo Rainer,

im Verzeichnis /etc/init.d liegen die Scripte, die beim Starten bzw. beim Beenden des Systems durchlaufen werden. Als Beispielscript dient das Programm mit dem Namen "example". Davon erstellst du dir eine Kopie und benennst die Datei sprechend z.B. aufnahmen_aktualisieren. Im Startbereich "start)" ersetzt du die Zeile
Code: [Select]
# add here your start actionsdurch den Befehl. Dann musst du noch dafür sorgen, dass das Script nach dem Mounten der Laufwerke aufgerufen wird. Ich würde es zunächst mal nach dem Start des VDR versuchen. Dazu musst du im Bereich "init)" den Eintrag
Code: [Select]
#after=""    # init scripts that must be started before this
wie folgt anpassen:
Code: [Select]
after="vdr"    # init scripts that must be started before this
Sofern es nicht funktioniert könntest du noch etwas mit "after" bzw. "before" im Script experimentieren. Im WebIf unter Logfiles/Einschalt Meldungen kannst du sehen, welche Scripte in welcher Reihenfolge bei dir gestartet wurden. Wichtig ist natürlich auch, dass du das Kommentarzeichen "#" am Anfang der Zeilen entfernst, die ausgeführt werden sollen.

Viel Erfolg und viele Grüße skippy

2
Raspberry PI / [MLD 5.5 unstable / RPI4] Probleme mit der Anzeige
« on: October 21, 2020, 12:35:02 »
Sorry, aber wieso macht man sich die Mühe und packt dann alles zusammen bzw. stellt es bereit obwohl klar ist, dass es nicht funzt?

Hallo Markus,

der RPi funktioniert derzeit nur als Server, also ohne Grafikausgabe. Von daher ist es schon sinnvoll, dass dafür Pakete angeboten werden.

Viele Grüße skippy

3
Hallo Rainer,

wenn ich mich noch richtig erinnere, müsste die Anlage der Datei ".update" im Aufnahmeverzeichnis z.B. via

Code: [Select]
touch /data/tv/.update
helfen. Das musst du jetzt nur noch in ein init-Script packen, das nach dem Mount des Serververzeichnisses läuft.

Viele Grüße skippy

4
Hallo Rainer,

das kannst du im WebIf unter "Konfiguration/Netzwerk/Server/Wait for the Server" aktivieren, dass der Client solange wartet, bis die Serverfreigabe zur Verfügung steht. Zumindest funktioniert es, wenn du Client und Server standardmäßig installiert hast. Kann sein, dass es durch deine diversen Änderungen noch Probleme gibt.

Hier mal meine /etc/fstab vom Client. Wenn ich mich noch richtig erinnere, wird durch die Option "bg" in der Zeile, wo das Datenverzeichnis des MLD-Server eingebunden wird, das Warten erzwungen

Code: [Select]
proc        /proc           proc      defaults            0 0
sys         /sys            sysfs     defaults            0 0
run         /run            tmpfs     defaults            0 0
tmp         /tmp            tmpfs     defaults            0 0
dev         /dev            devtmpfs  defaults            0 0
devpts      /dev/pts        devpts    mode=0620,gid=5     0 0
/dev/dvd    /media/dvd      auto      ro,noauto           0 0
/dev/cdrom  /media/cdrom    auto      ro,noauto           0 0
MLD-SERVER:/data  /mnt/data  nfs    bg        0 0
UUID=053ae3d4-a181-4668-bf43-7b6dc6e2ef0e  /  auto  defaults  0 1
UUID=e6236255-3774-440e-8a7d-61288dad0dbc  /mnt/mmcblk0p3  auto  defaults  0 2
/mnt/mmcblk0p3  /data  none  bind  0 0
/mnt/mmcblk0p3/.cache  /var/cache  none  bind  0 0
UUID=4165-188C  /boot  auto  defaults  0 2

Viele Grüße skippy

5
192.168.1.51:/data/tv  /mnt/tv          nfs     defaults        0       0                                         

Hallo Rainer,

wenn ich es richtig sehe, mountest du die Aufnahmen vom Server nach /mnt/tv. Der VDR erwartet sie aber unter /data/tv. Entweder mountest du die Aufnahmen direkt nach /data/tv oder erstellst noch einen Link von /mnt/tv nach /data/tv. Schau vorher mal, ob die Aufnahmen auf dem Client unter /mnt/tv sichtbar sind.

Ich bin übrigens ein Freund vom Paket avahi-linker. Das sorgt dafür, dass die Aufnahmen automatisch unter den MLDs sichtbar sind. Das Paket auf allen MLDs installieren. Auf dem Client vorher das Paket nfs-client desinstallieren. Ich weiß nicht mehr, ob das automatisch bei der Installation des avahi-linkers erfolgt, sofern es vorhanden ist.

Viele Grüße skippy

6
Allgemeines [ General ] / Alles Gute zum Geburtstag Claus
« on: September 20, 2020, 16:38:41 »
Hallo Claus,

auch von mir alles Gute zu deinem runden Geburtstag. Tolles Wetter zum Feiern hast du ja. Lass dich verwöhnen und reich mit RPis beschenken ;-)

Liebe Grüße skippy

7
Gibt es da irgend eine Stelle, wo man solche Tips nachlesen kann?

Hallo schlaubi,

das VDR-Forum und das VDR-Wiki sind dir bekannt? Da findest du Infos zu grundsätzlichen Dingen zum VDR. Das MLD-Wiki beschäftigt sich hauptsächlich mit den MLD-spezifischen Dingen, das du auch gern ergänzen kannst, falls du Sachen beizutragen hast, die da noch nicht stehen.

Viele Grüße skippy

8
Raspberry PI / Anzeige beim RPI4
« on: August 09, 2020, 12:04:06 »
Hallo Claus,

immerhin hatte ich mit dem gstreamer schon mal ein Bild. Als ich dann jedoch unter Programme/Autostart den VDR eingetragen und einen Neustart durchgeführt habe, kommt kein Bild, sondern die Meldung auf dem Bildschirm:

Code: [Select]
/etc/init.d/appstarter: line 1: rundvdr-gst: Permission denied
Die Rechte der Datei sehen für mich aber gut aus - Owner und Group ist root und die Rechte sind 755. Nach ca. 5 Minuten kommt dann doch noch das Fernsehbild.

Noch ein Hinweis zu gstreamer: Ich weiß, dass der noch nicht komplett rund läuft, wollte hier aber mal kurz meine Beobachtungen schildern:
1) das Bild sieht so aus, als ob ganz leicht abgehackt abläuft, also immer ein paar Frames verschluckt werden
2) bei der ARD habe ich zumindest bei der aktuellen Sendung das Phänomen, dass der Ton (in Dolby Digital laut Programmzeitschrift) bei Musik klar und deutlich rüber kommt. Wenn dann der Moderator spricht ist der Ton so leise, dass er nicht zu verstehen ist. Kommt dann wieder ein Musikbeitrag, ist der Ton normal.

Viele Grüße skippy

9
Raspberry PI / Anzeige beim RPI4
« on: August 08, 2020, 21:41:20 »
Hi gr4vity,

das liegt meist daran, dass mein Englisch nicht so gut ist und ich mir meist nicht die Mühe mache, Threads zu übersetzen, die mich nicht auf den ersten Blick interessieren.

Viele Grüße skippy

10
Raspberry PI / Anzeige beim RPI4
« on: August 08, 2020, 18:41:32 »
Beim RPI4 und der MLD-5.5 wird jetzt nach dem Booten des Images das Webif angezeigt.

Hi Claus,
ja, das ich bestätigen, funktioniert. Beim Wechsel und Aufbau der Web-Seite habe ich aber immer ca. 5 Sek. einen schwarzen Bildschirm - getestet an meinem Samsung TV mit max 4K-Auflösung. Gibt es schon eine Möglichkeit, die MLD als Client auf dem RPi4 einzusetzen. GStreamer hat bei mir noch kein Bild gebracht.

Viele Grüße skippy

11
Allgemein [ General ] / xmltv2vdr mit headless server
« on: June 29, 2020, 13:18:44 »
@ Claus: genau, epg2vdr, wie Roland bereits geschrieben hat.

Die Problematik aus meiner Sicht ist, dass bei magenta-tv  die EPG-Daten wohl nicht für alle Sendungen übertragen werden, sondern nur für die aktuell laufende und die nächste (now + next). Soweit mir bekannt ist, werden die externen EPG-Daten zu denen die über den Stream kommen dazu gemischt. Wenn keine Sendungs-EPG-Daten, dann gibt es auch nichts zu mischen. Ich weiß nicht, ob man das in der epgd-Konfiguration irgendwo einstellen kann, dass er nur die externen Daten nehmen soll. Wie bereits geschrieben, ist da das VDR-Portal vermutlich die bessere Adresse für solche Fragen.

Viele Grüße skippy

12
Allgemein [ General ] / xmltv2vdr mit headless server
« on: June 28, 2020, 15:27:48 »
Hallo,

ich vermute, dass das Problem die magenta-Sender sind. Die hat keiner von uns, dass wir das damit nicht testen können. Vielleicht ist zu diesem Thema mal eine Anfrage im vdr-portal hilfreich. Dort hat man sich schon früher mit dem Thema beschäftigt. Z.B. habe ich diesen Thread und diesen Thread dort gefunden. Ggf. hilft dir das schon einmal weiter.

Für tvm musste ich nichts extra installieren. Das wurde bei mir bei der Konfiguration des epgd über das Web-IF mit angeboten.

Viele Grüße skippy

13
Allgemein [ General ] / xmltv2vdr mit headless server
« on: June 28, 2020, 12:15:18 »
Wie bereits geschrieben - die channelmap.conf wird eigentlich automatisiert von der MLD erzeugt. Was passiert denn bei dir, wenn du die Generierung über das Web-Interface per Button auslöst? Speichere aber deine mühsam händisch erzeugte Datei weg, da sie vermutlich überschrieben wird.

TVM ist die Fallback-Lösung, falls keine Daten über epgdata kommen. Auch das wird im Web-Interfache konfiguriert - war zumindest so, als ich es eingerichtet habe. Für die EPG-Daten ist es egal, ob HD oder SD - die Programmdaten sind hier identisch ;-)

Viele Grüße  skippy

14
Allgemein [ General ] / xmltv2vdr mit headless server
« on: June 27, 2020, 14:56:31 »
gern - s. Anlage. Du kannst dir aber bei epgdata auch die Infos runterladen. Sollte auch mit deinem Testpin klappen. In der XML-Datei findest du dann den Sender und unter "CH4" die ID

Viele Grüße skippy

15
Allgemein [ General ] / xmltv2vdr mit headless server
« on: June 27, 2020, 14:08:36 »
Grundsätzlich sehen die LOG-Meldungen gut zum epgd gut aus. Da ich nicht genau weiß, was du wie konfiguriert hast, füge ich mal einen Screen-Shot meiner Konfiguration bei (den EPG-Data key habe ich verändert, dass jemand auf die Idee kommt, den auszuprobieren, wird es nicht klappen). Oben im Fenster wird der Inhalt aus der Channelmap.conf angezeigt. Für ARD solltest du auch einen Eintrag mit
Code: [Select]
epgdata:71 = haben. Hinter dem "=" kommt dann der Sender aus der Channels.conf. Ich empfange über DVB-C, deshalb das "C" im String. Wie geschrieben, wird die Datei automatisch erzeugt, wenn du auf den Button "Erstelle Channelmap" drückst. Wenn du im Browser die Adresse deines MLD-Geräts mit Port 8017 eingibst, dann sollte dir die Programmübersicht analog zur 2. Anlage angezeigt werden.

Viele Grüße skippy