Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - skippy

1
Allgemein [ General ] / DVB-C und DVB-S Tuner an einem Rechner?
« on: January 14, 2021, 18:00:43 »
Hallo und herzlich willkommen bei der MLD,

der Mischbetrieb von DVB-S und DVB-C sollte möglich sein. Ich selbst hatte mal übergangsweise DVB-C und DVB-T im Einsatz. Wichtig ist, dass du den Inhalt aus der channel.conf für DVB-S und den Inhalt aus der DVB-C in eine channels.conf kopierst (z.B. zuerst alle DVB-S Sender und danach alle DVB-C Sender) und diese dann verwendest.

Viel Erfolg und viele Grüße skippy

2
Allgemein [ General ] / WDR Düsseldorf
« on: January 12, 2021, 11:51:32 »
Hallo zusammen,

die Seite kannte ich auch noch nicht. Ich habe im Wiki einen Verweis auf diesen Thread gesetzt.

Viele Grüße skippy

3
Allgemein [ General ] / MLD 5.5 epgd Einträge doppelt vorhanden
« on: December 13, 2020, 17:18:26 »
Hallo Matthias,

ich habe deinen Beitrag in den FAQ des Wikis verlinkt.

Vielen Dank und viele Grüße skippy

4
/mnt/192.168.1.51__data  /data  none  bind  0 0   

Hallo Rainer,

nach meinem Kenntnisstand ist der Weg mit bind über die fstab veraltet, sollte aber auch funktionieren, wenn du statt "/data" "/data/tv" schreibst.  Versuche es statt dessen mal mit einem symbolischen Link von /mnt/192.168.1.51__data (komischer Name für ein Verzeichnis, aber ok) nach /data/tv, damit in /data/tv auch die Aufnahmen angezeigt werden.

Code: [Select]
ln -s /mnt/192.168.1.51__data /data/tv
Vorher noch die o.g. Zeile in der fstab auskommentieren oder löschen.

Viele Grüße skippy

5
Allgemein [ General ] / MLD5.5 Channel.conf editieren
« on: December 06, 2020, 12:09:13 »
Hallo Stefan,

das liegt an der Standardeinstellung des VDR, dass er immer wieder nach neuen Kanälen sucht. Das kannst du im Setup unter DVB (Kanäle aktualisieren auf "0") abstellen - s. VDR-Benutzerhandbuch.

Viele Grüße skippy

6
Hallo Rainer,

im Verzeichnis /etc/init.d liegen die Scripte, die beim Starten bzw. beim Beenden des Systems durchlaufen werden. Als Beispielscript dient das Programm mit dem Namen "example". Davon erstellst du dir eine Kopie und benennst die Datei sprechend z.B. aufnahmen_aktualisieren. Im Startbereich "start)" ersetzt du die Zeile
Code: [Select]
# add here your start actionsdurch den Befehl. Dann musst du noch dafür sorgen, dass das Script nach dem Mounten der Laufwerke aufgerufen wird. Ich würde es zunächst mal nach dem Start des VDR versuchen. Dazu musst du im Bereich "init)" den Eintrag
Code: [Select]
#after=""    # init scripts that must be started before this
wie folgt anpassen:
Code: [Select]
after="vdr"    # init scripts that must be started before this
Sofern es nicht funktioniert könntest du noch etwas mit "after" bzw. "before" im Script experimentieren. Im WebIf unter Logfiles/Einschalt Meldungen kannst du sehen, welche Scripte in welcher Reihenfolge bei dir gestartet wurden. Wichtig ist natürlich auch, dass du das Kommentarzeichen "#" am Anfang der Zeilen entfernst, die ausgeführt werden sollen.

Viel Erfolg und viele Grüße skippy

7
Raspberry PI / [MLD 5.5 unstable / RPI4] Probleme mit der Anzeige
« on: October 21, 2020, 12:35:02 »
Sorry, aber wieso macht man sich die Mühe und packt dann alles zusammen bzw. stellt es bereit obwohl klar ist, dass es nicht funzt?

Hallo Markus,

der RPi funktioniert derzeit nur als Server, also ohne Grafikausgabe. Von daher ist es schon sinnvoll, dass dafür Pakete angeboten werden.

Viele Grüße skippy

8
Hallo Rainer,

wenn ich mich noch richtig erinnere, müsste die Anlage der Datei ".update" im Aufnahmeverzeichnis z.B. via

Code: [Select]
touch /data/tv/.update
helfen. Das musst du jetzt nur noch in ein init-Script packen, das nach dem Mount des Serververzeichnisses läuft.

Viele Grüße skippy

9
Hallo Rainer,

das kannst du im WebIf unter "Konfiguration/Netzwerk/Server/Wait for the Server" aktivieren, dass der Client solange wartet, bis die Serverfreigabe zur Verfügung steht. Zumindest funktioniert es, wenn du Client und Server standardmäßig installiert hast. Kann sein, dass es durch deine diversen Änderungen noch Probleme gibt.

Hier mal meine /etc/fstab vom Client. Wenn ich mich noch richtig erinnere, wird durch die Option "bg" in der Zeile, wo das Datenverzeichnis des MLD-Server eingebunden wird, das Warten erzwungen

Code: [Select]
proc        /proc           proc      defaults            0 0
sys         /sys            sysfs     defaults            0 0
run         /run            tmpfs     defaults            0 0
tmp         /tmp            tmpfs     defaults            0 0
dev         /dev            devtmpfs  defaults            0 0
devpts      /dev/pts        devpts    mode=0620,gid=5     0 0
/dev/dvd    /media/dvd      auto      ro,noauto           0 0
/dev/cdrom  /media/cdrom    auto      ro,noauto           0 0
MLD-SERVER:/data  /mnt/data  nfs    bg        0 0
UUID=053ae3d4-a181-4668-bf43-7b6dc6e2ef0e  /  auto  defaults  0 1
UUID=e6236255-3774-440e-8a7d-61288dad0dbc  /mnt/mmcblk0p3  auto  defaults  0 2
/mnt/mmcblk0p3  /data  none  bind  0 0
/mnt/mmcblk0p3/.cache  /var/cache  none  bind  0 0
UUID=4165-188C  /boot  auto  defaults  0 2

Viele Grüße skippy

10
192.168.1.51:/data/tv  /mnt/tv          nfs     defaults        0       0                                         

Hallo Rainer,

wenn ich es richtig sehe, mountest du die Aufnahmen vom Server nach /mnt/tv. Der VDR erwartet sie aber unter /data/tv. Entweder mountest du die Aufnahmen direkt nach /data/tv oder erstellst noch einen Link von /mnt/tv nach /data/tv. Schau vorher mal, ob die Aufnahmen auf dem Client unter /mnt/tv sichtbar sind.

Ich bin übrigens ein Freund vom Paket avahi-linker. Das sorgt dafür, dass die Aufnahmen automatisch unter den MLDs sichtbar sind. Das Paket auf allen MLDs installieren. Auf dem Client vorher das Paket nfs-client desinstallieren. Ich weiß nicht mehr, ob das automatisch bei der Installation des avahi-linkers erfolgt, sofern es vorhanden ist.

Viele Grüße skippy

11
Allgemeines [ General ] / Alles Gute zum Geburtstag Claus
« on: September 20, 2020, 16:38:41 »
Hallo Claus,

auch von mir alles Gute zu deinem runden Geburtstag. Tolles Wetter zum Feiern hast du ja. Lass dich verwöhnen und reich mit RPis beschenken ;-)

Liebe Grüße skippy

12
Gibt es da irgend eine Stelle, wo man solche Tips nachlesen kann?

Hallo schlaubi,

das VDR-Forum und das VDR-Wiki sind dir bekannt? Da findest du Infos zu grundsätzlichen Dingen zum VDR. Das MLD-Wiki beschäftigt sich hauptsächlich mit den MLD-spezifischen Dingen, das du auch gern ergänzen kannst, falls du Sachen beizutragen hast, die da noch nicht stehen.

Viele Grüße skippy

13
Raspberry PI / Anzeige beim RPI4
« on: August 09, 2020, 12:04:06 »
Hallo Claus,

immerhin hatte ich mit dem gstreamer schon mal ein Bild. Als ich dann jedoch unter Programme/Autostart den VDR eingetragen und einen Neustart durchgeführt habe, kommt kein Bild, sondern die Meldung auf dem Bildschirm:

Code: [Select]
/etc/init.d/appstarter: line 1: rundvdr-gst: Permission denied
Die Rechte der Datei sehen für mich aber gut aus - Owner und Group ist root und die Rechte sind 755. Nach ca. 5 Minuten kommt dann doch noch das Fernsehbild.

Noch ein Hinweis zu gstreamer: Ich weiß, dass der noch nicht komplett rund läuft, wollte hier aber mal kurz meine Beobachtungen schildern:
1) das Bild sieht so aus, als ob ganz leicht abgehackt abläuft, also immer ein paar Frames verschluckt werden
2) bei der ARD habe ich zumindest bei der aktuellen Sendung das Phänomen, dass der Ton (in Dolby Digital laut Programmzeitschrift) bei Musik klar und deutlich rüber kommt. Wenn dann der Moderator spricht ist der Ton so leise, dass er nicht zu verstehen ist. Kommt dann wieder ein Musikbeitrag, ist der Ton normal.

Viele Grüße skippy

14
Raspberry PI / Anzeige beim RPI4
« on: August 08, 2020, 21:41:20 »
Hi gr4vity,

das liegt meist daran, dass mein Englisch nicht so gut ist und ich mir meist nicht die Mühe mache, Threads zu übersetzen, die mich nicht auf den ersten Blick interessieren.

Viele Grüße skippy

15
Raspberry PI / Anzeige beim RPI4
« on: August 08, 2020, 18:41:32 »
Beim RPI4 und der MLD-5.5 wird jetzt nach dem Booten des Images das Webif angezeigt.

Hi Claus,
ja, das ich bestätigen, funktioniert. Beim Wechsel und Aufbau der Web-Seite habe ich aber immer ca. 5 Sek. einen schwarzen Bildschirm - getestet an meinem Samsung TV mit max 4K-Auflösung. Gibt es schon eine Möglichkeit, die MLD als Client auf dem RPi4 einzusetzen. GStreamer hat bei mir noch kein Bild gebracht.

Viele Grüße skippy