1 [2] MLD-5.x / Systems / Raspberry PI / [MLD 5.5 Unstable] TeVii S660 läuft nicht (gelöst)
 

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #15 on: April 13, 2021, 21:28:12 »
Hast du im WebIF bei 'Konfiguration/Anzeige' was eingestellt?
Denn es schmiert bei dir der VDR ab, das wird nichts mit dem TeVii zu tun haben.

Das ist alles auf default ... ich habe es auch bereits mit "Ausprobieren" und "Installieren" versucht. Es ist ein ganz normaler 19 Zoll Monitor angehängt, genauergesagt ein alter NEC MultiSync LCD1970NXp. Xorg startet auf dem Monitor. Ist evtl das Umschalten auf eine andere Auflösung (vdr) das Problem?

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #16 on: April 14, 2021, 09:00:23 »
Denn es schmiert bei dir der VDR ab, das wird nichts mit dem TeVii zu tun haben.
Ich habe es gerade nochmal versucht. Dieses Mal habe ich die Auflösung des TV auf feste Werte eingestellt (SD, 50 Hz...). Der Monitor zeigt das MLD-Logo + einen Mauszeiger. Xorg ist also da -- dennoch startet VDR nicht. Hier ein weiteres debug-Log: nfIX89

Da ich übrigens im Moment kein Sound-Dev angehängt habe, erhalte ich auch:
Code: [Select]
Found hardware: "bcm2835_headpho" "Broadcom Mixer" "" "" ""
Hardware is initialized using a generic method
alsactl: get_control:256: Cannot read control '3,0,0,Playback Channel Map,0': Invalid argument
failed
Kann das ein Problem sein?

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #17 on: April 14, 2021, 09:31:35 »
Eher nicht. Aber schau mal ins Web-IF, ob sich der Ton ganz deaktivieren lässt. Das weiß ich gerade nicht auswendig.

Ansonsten könntest Du mal softhddevice entfernen und das streamdev-plugin installieren. Danach neu starten und per vlc, mplayer o.ä. versuchen, eine Wiedergabe am Arbeitsrechner zu bekommen.
Zudem kannst Du dann mal mit

dmesg ,

cat /var/log/messages und

cat /var/log/vdr

schauen, was so passiert.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #18 on: April 14, 2021, 11:21:57 »
Ansonsten könntest Du mal softhddevice entfernen und das streamdev-plugin installieren. Danach neu starten und per vlc, mplayer o.ä. versuchen, eine Wiedergabe am Arbeitsrechner zu bekommen.
Ok!
Ein weiterer Versuch: Ich habe gewählt: Ausprobieren --> VDR --> Client: gStreamer (anstelle des default-Wertes SHD).
Das liefert aber:
Code: [Select]
Downloading updates
E: Unable to correct problems, ... you have unmet dependencies.
Removing install-net
Removing live

So läuft es also auch nicht.  :-\

Danach ein noch ein anderer Versuch: Ausprobieren --> VDR --> Server.
Das installiert dann den streamdev-server. Jetzt erhalte ich immerhin das VDR Menu auf dem ansonsten schwarzen Bildschirm. Ich kann auch die default Kanalliste sehen.

Korrektur:
Von diesem Notebook mit VLC und http://192.168.178.47:3000/S19.2E-1-1019-10301.ts kann ich jetzt streamen. Die Hardware ist also ok!
Trotzdem ein weiteres debug-Log; dieses Mal unter: r3vnnZ


« Last Edit: April 14, 2021, 11:28:03 by whiterabbit »

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #19 on: April 14, 2021, 11:26:30 »
Hi,

hast du irgenwann oder wie einmal einen Timer gesetzt?
Code: [Select]
Apr 14 11:15:26 MLD-rpi4 user.err vdr: [19370] ERROR: Kanal blockiert (zeichnet auf)!
Das Device ist belegt, aus diesem Grund bekommst du auf dem Notebook mit VLC nicht zu sehen.

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #20 on: April 14, 2021, 11:29:41 »
Hi,

hast du irgenwann oder wie einmal einen Timer gesetzt?
Code: [Select]
Apr 14 11:15:26 MLD-rpi4 user.err vdr: [19370] ERROR: Kanal blockiert (zeichnet auf)!
Das Device ist belegt, aus diesem Grund bekommst du auf dem Notebook mit VLC nicht zu sehen.

Gruß,
  Roland
Sorry, in der Zwischenzeit habe ich meinen Beitrag korrigiert ... Streamen funktioniert doch ... im Browser sehe ich unter :3000 das Webinterface aber im VLC muss offenbar der Transportstream mit angegeben werden...

Aber so richtig komfortabel ist das über Port 3000 / VLC so noch nicht. Gibt doch sicher ein besseres Frontend mit Menuführung?
« Last Edit: April 14, 2021, 11:37:08 by whiterabbit »

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #21 on: April 14, 2021, 11:44:42 »
Von diesem Notebook mit VLC und http://192.168.178.47:3000/S19.2E-1-1019-10301.ts kann ich jetzt streamen. Die Hardware ist also ok!

Meine Rede. Das Problem ist also das Ausgabedevice, wo ich aber leider nicht viel beitragen kann, da ich keinen Pi4 habe.

Sorry, in der Zwischenzeit habe ich meinen Beitrag korrigiert ... Streamen funktioniert doch ... im Browser sehe ich unter :3000 das Webinterface aber im VLC muss offenbar der Transportstream mit angegeben werden...

Genau.

Aber so richtig komfortabel ist das über Port 3000 / VLC so noch nicht. Gibt doch sicher ein besseres Frontend mit Menuführung?

Du kannst auf http://<ip-des-RPi4>:3000/channels.html gehen und dort den Link auf den Sender kopieren. Der muss dann im VLC eingetragen werden. Evtl. kann man aber auch eine Playlist im VLC erstellen und dann direkt zugreifen. Habe ich noch nie probiert, ist also nur eine Idee, was man probieren könnte.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #22 on: April 14, 2021, 11:49:39 »
Du kannst auf http://<ip-des-RPi4>:3000/channels.html gehen und dort den Link auf den Sender kopieren. Der muss dann im VLC eingetragen werden. Evtl. kann man aber auch eine Playlist im VLC erstellen und dann direkt zugreifen. Habe ich noch nie probiert, ist also nur eine Idee, was man probieren könnte.
Ok -- immerin einen Schritt weiter. So kann man damit ja schon mal was machen. In der Zwischenzeit habe ich auch noch das hier entdeckt -- könnte einem das Leben vereinfachen:
http://www.sigvdr.de/Software/EasyStream/EasyStream.html

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #23 on: April 14, 2021, 11:59:17 »
Ja, wirklich ein schöner Ansatz. Nur leider uralt, sprich, seit vielen Jahren nicht mehr gepflegt.  :'(

rpm-Pakete gibt es nicht, ob die debs noch installieren und laufen sei dahingestellt und ob ein Bau aus den Sourcen klappt wäre zu prüfen.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #24 on: April 14, 2021, 12:05:01 »
ob die debs noch installieren und laufen sei dahingestellt
Gerade auf KUbuntu 20.04 installiert -- läuft. Wenn es bessere Alternativen gibt, wäre ich aber auch nicht abgeneigt. Schön wäre es ja evtl auch auf ein Tablet streamen zu können (mit Menuführung) ... geht da evtl was mit Kodi o.ä.?

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #25 on: April 14, 2021, 13:11:54 »
Mit Kodi sollte es gehen und das gibt es für Android ja als App.

Allerdings wird das hier jetzt völlig OT. Bitte markiere den Thread als gelöst und eröffne einen neuen zu dem Thema.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

1 [2] MLD-5.x / Systems / Raspberry PI / [MLD 5.5 Unstable] TeVii S660 läuft nicht (gelöst)
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.