[1] 2 3 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
 

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
Hallo zusammen,


Leider hat sich mein Absturz-Problem des VfR nicht geändert.


Im VDR Log habe ich diese Meldung gefunden:


exception occured: pthread_mutex_lock failed: errno 22: Invalid argument free(): invalid pointer Aborted
Leider kann ich damit nicht viel anfangen.


Ein Debug-Log habe ich hochgeladen.
Code 5BUQR2
[/size]
Vielleicht kann mir ja noch jemand helfen


Gruß Stefan

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #1 on: June 06, 2021, 09:39:27 »
Die Meldung besagt, das versucht wurde Speicher frei zu geben, der nicht reserviert wurde. Also ein Programmierfehler.
Welches Programm (oder Plugin) das Problem hat, lässt sich anhand des Logs nicht sagen.
Mir ist aber aufgefallen, dass das dvb-sudteck Treiber Paket veraltet ist. Das war nur im unstable Zweig aktualisiert. Du hattest aber inzwischen auf den Testing Zweig gewechselt. Installiere da Bitte mal das update. Eventuell hilft das ja.
« Last Edit: June 06, 2021, 09:43:24 by clausmuus »
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #2 on: June 06, 2021, 15:37:25 »
OK, vielen Dank.
Hab das sundtek Update installiert und werde weiter testen.


Gruß, Stefan

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #3 on: June 09, 2021, 15:19:22 »
Hallo,


es scheint ein Problem mit meinem verwendeten USB-Stick zu sein.
Habe jetzt eine USB-SSD besorgt und alles neu installiert.
Scheint jetzt zu laufen.


Gruß,
Stefan

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #4 on: June 16, 2021, 17:01:32 »
Hallo,


Jetzt habe ich alles getauscht, bis auf die Tuner.
Der Fehler ist immer noch der gleiche.
Es scheint, als habe der Sundtek Tuner ein Problem.


Gruß, Stefan




Das ist die Fehlermeldung:


[size=0px]INFO: validating live server ip '0.0.0.0' exception occured: pthread_mutex_lock failed: errno 22: Invalid argument free(): invalid pointer Aborted VDR exits at Mi Jun 16 16:24:41 CEST 2021 INFO: validating live server ip '0.0.0.0'[/size]

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #5 on: June 16, 2021, 19:42:02 »
Hallo,


Jetzt habe ich alles getauscht, bis auf die Tuner.
Der Fehler ist immer noch der gleiche.
Es scheint, als habe der Sundtek Tuner ein Problem.


Gruß, Stefan




Das ist die Fehlermeldung:


[size=0px]INFO: validating live server ip '0.0.0.0' exception occured: pthread_mutex_lock failed: errno 22: Invalid argument free(): invalid pointer Aborted VDR exits at Mi Jun 16 16:24:41 CEST 2021 INFO: validating live server ip '0.0.0.0'[/size]

nimm doch mal ein paar plugins aus, die nicht benötigt werden.
Um zu sehen, ob es wirklich an den Tunern liegt.

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #6 on: June 17, 2021, 06:50:13 »
ok,


ich habe jetzt noch
- dbus2vdr (braucht man das? Ich glaube es war von Anfang an installiert)
- epg2timer
- epgsearch
- live
- restfulapi
- skincurses
- streamdev-server
- vnsiserver


das ganze soll als headless server laufen


Danke schonmal und Gruß,
Stefan

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #7 on: June 17, 2021, 14:13:39 »
Zum testen würde ich alles außer dem streamdev-server und skincurses entfernen.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline sundtek

  • Newbie
  • *
  • Posts: 34
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #8 on: June 21, 2021, 22:46:14 »
Hi,

schau mal im chat vorbei, dann kann ich mir das mal ansehen:
https://support.sundtek.de/chat.php

Wir hatten vor einiger Zeit einen Fehler im Treiber gefunden, dass sich die Transaktionen auf beiden Tunern gestört haben (da die Tuner die gleiche Adresse verwenden und dort ein Auto-Mechanismus verwendet wird um die Transaktionsfenster zum jeweiligen Chip zu steuern. Wir hatten eher TVHeadend über längere Zeit getestet. Vielleicht gibt's beim VDR noch n anderes Szenario.

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #9 on: June 23, 2021, 08:02:12 »
Hallo,


vielen Dank. Ich muss sehen, wenn Zeit ist. Ich probiere es vielleicht heute abend


Gruß,
Stefan

Offline sundtek

  • Newbie
  • *
  • Posts: 34
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #10 on: June 23, 2021, 18:13:27 »
Schau morgen bitte so um 6 am Abend oder am Vormittag vorbei (schätze Tagsüber bist du nicht da).

Zur Zeit wurde ein Crash insgesamt 2 mal (inkl. dem hier) gemeldet und immer jeweils mit Dual Tunern

Der andere hat 2 sehr alte Tuner (2011) plus Dual Tuner auf einem RPI und mit dem Dual Tuner hat er kein Problem / nur mit den 2 alten Single Tunern (die schalten zu langsam und da springen Timeouts an.

Nach 2 Falschannahmen.

VDR verursacht wohl Memory Corruptions, es sind wohl die letzteren Versionen betroffen, das Problem wird aktuell aktiv im VDR überprüft (es wird aber wohl mehr Feedback von den Usern benötigt, es benötigt wohl ne gewisse Konstellation um das Problem zu triggern

Somit ist das hier das einzige aktive Problem.
« Last Edit: July 05, 2021, 08:13:59 by sundtek »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #11 on: June 25, 2021, 15:56:41 »
Hallo sundtek,

sag Bitte bescheid wenn wir da irgendwie helfen können. Ich selber habe nur zwei unterschiedliche Singletuner Sundteck Sticks, so das ich das nicht näher untersuchen kann.
Eventuell ist aber ja Stefan bereit Dich per SSH auf sein System zu lassen, damit Du das näher untersuchen kannst (sofern das helfen sollte). Bei der MLD kann mit einem Klick im Setup ein SSH Zugang geöffnet werden, ohne dafür Ports öffnen zu müssen.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline r100gs

  • Newbie
  • *
  • Posts: 30
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #12 on: June 28, 2021, 06:29:19 »
Hallo zusammen,


vielen Dank für eure Hilfsbereitschaft.
wir können das gerne mit ssh versuchen.
Ich habe im Moment nur leider ein paar private Sachen zu tun.
Ich hoffe nächste Woche schaut es besser aus.


Gruß,
Stefan

Offline sundtek

  • Newbie
  • *
  • Posts: 34
    • View Profile
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #13 on: July 05, 2021, 08:16:59 »
Es scheint wohl ein Problem im VDR zu sein, es wird aktuell noch überprüft und benötigt mehr Feedback von Usern. Mit valgrind haben wir gesehen dass Teile von PID Filtern im Speicher freigegeben werden und danach immer noch darauf zugegriffen wird (es gab bei den letzten 2-3 VDR Versionen diesbezüglich Updates).
Diese Konstellation verursacht Memory Corruptions und lässt den VDR dann früher oder später an irgendwelchen Stellen abstürzen.
Schätze das Problem sollte aber bald gelöst werden, eventuell braucht's auch gewisse Einstellungen um das Problem überhaupt auszulösen.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
« Reply #14 on: July 05, 2021, 14:29:16 »
@Stefan,
in dem Fall wäre eventuell ein Test mit Pits (p3f) dev Version ein Versuch wert, da er darüber die neuste VDR Version anbietet.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] 2 3 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.5 Testing auf Rpi4 mit 2xSundtek Dual VfR schmiert ab
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.