[1] 2 3 >>> MLD-5.x / Systeme / Raspberry PI / RPI 4 5.5 unstabe "board requires newer software"
 

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
Hi,

mein 86iger PC ist in die Brüche gegangen, da ich schon einen neuen RPI 4 mit 8 GB und einen TBS 5520 SE habe, wollte ich gleich mein System umstellen. Ich habe zuerst mit der testing Version probiert. Da aber ging das img File gar nicht. Das Image (_customized_2022.05.30-+5.5-k9zUTV.img) ließ sich nicht installieren. Da kann ma auch kein rpihddevice plugin auswählen.  Dann habe ich es mit der unstable Vereion probiert. Da habe ich dann beim starten die Anzeige: start.elf: is not compatible - This board requires newer software. Könnt ihr da etwas machen?

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #1 on: May 30, 2022, 21:03:24 »
Hi,

Rpihddevice is not compatible with RPI4, you should install softhddevice-drm instead.
Regarding start.elf you can install rpi-firmware package and see if it works.

Best Regards.

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1412
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #2 on: May 30, 2022, 22:04:16 »
Hi,

mein 86iger PC ist in die Brüche gegangen, da ich schon einen neuen RPI 4 mit 8 GB und einen TBS 5520 SE habe, wollte ich gleich mein System umstellen. Ich habe zuerst mit der testing Version probiert. Da aber ging das img File gar nicht. Das Image (_customized_2022.05.30-+5.5-k9zUTV.img) ließ sich nicht installieren. Da kann ma auch kein rpihddevice plugin auswählen.  Dann habe ich es mit der unstable Vereion probiert. Da habe ich dann beim starten die Anzeige: start.elf: is not compatible - This board requires newer software. Könnt ihr da etwas machen?

Gruß Bernd

der rpi4 geht mit dem vdr-plugin-rpihddevice nicht, da es eine komplett andere Hardware ist, nur der rpi2/3 geht damit.
Wie gr4vity schon schrieb geht das vdr-plugin-softhddevice-drm.

Gruß,
  Roland

P.s: anstatt ein customized zu nehmen nimm eine netinstall image, und danach alles installieren was du brauchst.
Netinstall ist immer die besser Wahl, danach kann man alles installiern was man braucht.
« Last Edit: May 30, 2022, 22:07:49 by rfehr »
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #3 on: May 31, 2022, 18:15:31 »
ich habe es erst mit dem Netinstall von der Testing Version versucht, aber das kam überhaupt nichts, und man konnte auch nicht über den Explorer zugreifen, das Image ist wohl defekt. Mit dem Image von der Unstable Version lief die Installation ohne Probleme durch. Ich habe jetzt aber kein Fernsehbild. Das Menue kann ich sehen, und nachdem ich per nfs meine Aufnamen gemountet habe, kann ich sie auch anschauen. Es sieht so aus als ob meine TBS 5520 SE Box nicht erkannt wird. Weder ein dmesg|grep dvb noch ein dmesg|grep usb gibt da eine Anzeige. Muss da noch etwas zusätzlich installiert werden, oder fehlt da noch eine Einstellung?

Gruß Bernd 
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #4 on: May 31, 2022, 23:43:40 »
Hi,
If you can't find dvb-tbs package then it won't work and you have to wait for Claus to build it for you.

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #5 on: June 01, 2022, 11:43:29 »
Hi gr4vity,

Thanks for your answer, so I have to wait for claus.

Regards Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #6 on: June 03, 2022, 10:22:03 »
Ich habe das unstable dvb-tbs Paket für den RPI 4 bauen lassen. Bitte teste mal ob's funktioniert.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #7 on: June 04, 2022, 15:34:01 »
Hallo Claus,

ich habe es installiert bekommen, habe aber noch kein Fernsehbild, der VDR läuft aber, ich bekomme das Menue angezeigt. Ich kann aber nicht erkennen ob die TBS Box erkannt wird, ich habe bislang immer ein "dmesg|grep dvb gemacht", und dann wurde die Box oder Karte angezeigt. Hier kommt kommt nichts. Wie erkenne ich ob die Box richtig  installiert ist? Aufnahmen kann ich über das NFS Share sehen. Hast du eine Idee waran das liegen kann? Muß ich noch zusätzliche Konfigurationen machen?

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #8 on: June 04, 2022, 17:12:06 »
Hi Bernd,

What is the output of the following command?
Code: [Select]
modprobe dvb-usb-tbs5922se
Best Regards.


Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #9 on: June 04, 2022, 18:12:24 »
Zum einen kannst Du wie von gr4vity geschrieben per lsmod schauen ob ein Treiber geladen wurde, zum anderen gibt es unter /dev/dvb/adapter... Ordner, wenn ein passender Treiber geladen wurde, und eine eventuell benötigte Firmware gefunden wurde.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #10 on: June 04, 2022, 18:49:05 »
Hier ist die Ausgabe:

Code: [Select]
bbmld> modprobe dvb-usb-tbs5922se
modprobe: can't load module dvb_core (kernel/drivers/media/dvb-core/dvb-core.ko): Invalid argument

und lsmod gibt folgende Ausgabe:

[code
bbmld> lsmod
Module                               Size  Used by    Tainted: G
v3d                                  73728  0
gpu_sched                        45056  1 v3d
vc4                                 262144  7
rpivid_hevc                        45056  0
i2c_bcm2835                     16384  0
snd_soc_bcm2835_i2s       16384  0
bcm2835_v4l2                    40960  0
bcm2835_codec                  40960  0
snd_soc_core                   229376  2 vc4,snd_soc_bcm2835_i2s
videobuf2_dma_contig        20480  2 rpivid_hevc,bcm2835_codec
v4l2_mem2mem                 36864  2 rpivid_hevc,bcm2835_codec
bcm2835_mmal_vchiq         28672  2 bcm2835_v4l2,bcm2835_codec
videobuf2_v4l2                   32768  4 rpivid_hevc,bcm2835_v4l2,bcm2835_codec,v4l2_mem2mem
snd_compress                    20480  1 snd_soc_core
videobuf2_vmalloc               16384  1 bcm2835_v4l2
vc_sm_cma                         32768  1 bcm2835_mmal_vchiq
videobuf2_memops              16384  2 videobuf2_dma_contig,videobuf2_vmalloc
videobuf2_common              65536  8 rpivid_hevc,bcm2835_v4l2,bcm2835_codec,videobuf2_dma_contig,v4l2_mem2mem,videobuf2_v4l2,videobuf2_vmalloc,videobuf2_memops
snd_pcm_dmaengine               16384  1 snd_soc_core
videodev                               249856  6 rpivid_hevc,bcm2835_v4l2,bcm2835_codec,v4l2_mem2mem,videobuf2_v4l2,videobuf2_common
drm_kms_helper                    253952  2 vc4
mc                                          45056  6 rpivid_hevc,bcm2835_codec,v4l2_mem2mem,videobuf2_v4l2,videobuf2_common,videodev
syscopyarea                             16384  1 drm_kms_helper
sysfillrect                                 16384  1 drm_kms_helper
sysimgblt                                 16384  1 drm_kms_helper
fb_sys_fops                             16384  1 drm_kms_helper
cec                                          49152  1 vc4
drm                                       528384  6 v3d,gpu_sched,vc4,drm_kms_helper
ir_rc6_decoder                         16384  0
drm_panel_orientation_quirks    16384  1 drm
backlight                                  20480  1 drm
gpio_ir_recv                             16384  0
uinput                                     20480  1
snd_bcm2835                          24576  0
snd_pcm                               106496  6 vc4,snd_soc_bcm2835_i2s,snd_soc_core,snd_compress,snd_pcm_dmaengine,snd_bcm2835
snd_timer                               32768  1 snd_pcm
snd                                        73728  5 snd_soc_core,snd_compress,snd_bcm2835,snd_pcm,snd_timer
[/code]

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #11 on: June 04, 2022, 19:03:22 »
Hi Claus,

Code: [Select]
bbmld> modprobe dvb-usb-tbs5922se
modprobe: can't load module dvb_core (kernel/drivers/media/dvb-core/dvb-core.ko): Invalid argument

It seems that dvb-tbs package needs to be recompiled.

Best Regards.
« Last Edit: June 04, 2022, 23:49:40 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #12 on: June 05, 2022, 00:36:24 »
Hm, interessting. Since that is a fresh build...
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #13 on: June 05, 2022, 17:12:17 »
Hi Claus,

You can install dvb-tbs package on your Rpi then insert dvb-usb-tbs5922se into kernel and see if you get any error message.

Best Regards.

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #14 on: June 05, 2022, 21:52:36 »
I have media_build installed on my MLD-5.5 x86 testing,
Just tried to insert dvb-usb-tbs5922se module into the kernel and got no errors.

Code: [Select]
MLD> modprobe dvb-usb-tbs5922se
MLD>

Code: [Select]
[   97.351122] usbcore: registered new interface driver tbs5922se
lsmod shows the following:

Code: [Select]
dvb_usb_tbs5922se      20480  0
dvb_usb                36864  1 dvb_usb_tbs5922se
tas2101                28672  1 dvb_usb_tbs5922se

rc_core                45056  3 dvb_usb_tbs5922se,dvb_usb,cec

dvb_core              139264  3 dvb_usb_tbs5922se,dvb_usb,ngene
mc                     53248  2 dvb_usb,dvb_core

Code: [Select]
MLD> modinfo ./dvb-usb-tbs5922se.ko
filename:       ./dvb-usb-tbs5922se.ko
author:         Bob Liu <Bob@turbosight.com>
description:    Driver for TBS 5922SE
license:        GPL
parm:           adapter_nr:DVB adapter numbers
parm:           debug:set debugging level (1=info 2=xfer (or-able)).
version:        0.1
alias:          usb:v04B4p5923d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v734Cp5923d*dc*dsc*dp*ic*isc*ip*in*
srcversion:     978EBECC11A962DC7B83FEC
depends:        dvb-usb,dvb-core,tas2101,rc-core
vermagic:       5.15.40.2+ SMP mod_unload modversions
« Last Edit: June 05, 2022, 21:57:51 by gr4vity »

[1] 2 3 >>> MLD-5.x / Systeme / Raspberry PI / RPI 4 5.5 unstabe "board requires newer software"
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.