1 [2] 3 >>> MLD-5.x / Systeme / Raspberry PI / RPI 4 5.5 unstabe "board requires newer software"
 

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #15 on: June 10, 2022, 14:19:49 »
Hi,

ich wollte mal vorsichtig anfragen, ob sich da etwas getan hat?

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #16 on: June 11, 2022, 00:27:52 »
Ich hatte letzte Woche einen frischen Build des testing Systems gestartet. Leider waren der Build ist nicht komplett durchgelaufen. Ich habe den Build jetzt noch mal neu gestartet.
Sollte der Build diesmal durchlaufen gibt es in zwei Tagen neue Testing Images. Mit dem kannst Du es dann noch mal versuchen.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #17 on: June 11, 2022, 20:31:57 »
Hallo Claus,

ich danke dir und werde es dann Montag Abend nochmal probieren.

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #18 on: June 12, 2022, 18:46:17 »
Der frische testing Build ist seit letzter Nacht fertig, und kann getestet werden.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #19 on: June 12, 2022, 21:25:23 »
Hi Claus,

ich habe es gleich mal ausprobiert. Ich habe immer noch keine Bild, VDR ist aber aktiv. In der Paketliste erscheint:

Code: [Select]
dvb-tbs 2022.06.08-28+5.12.6.205
ein dmesg|grep dvb gibt folgendes aus:

Code: [Select]
bbmld> dmesg|grep dvb
[   20.627651] dvb_core: loading out-of-tree module taints kernel.
[   20.630814] dvb_core: disagrees about version of symbol vb2_core_queue_init
[   20.630841] dvb_core: Unknown symbol vb2_core_queue_init (err -22)
[   20.630916] dvb_core: disagrees about version of symbol vb2_core_reqbufs
[   20.630934] dvb_core: Unknown symbol vb2_core_reqbufs (err -22)
[   20.630979] dvb_core: disagrees about version of symbol vb2_core_expbuf
[   20.630996] dvb_core: Unknown symbol vb2_core_expbuf (err -22)
[   20.631345] dvb_core: disagrees about version of symbol vb2_core_queue_release
[   20.631363] dvb_core: Unknown symbol vb2_core_queue_release (err -22)
[   20.631468] dvb_core: disagrees about version of symbol vb2_buffer_done
[   20.631555] dvb_core: Unknown symbol vb2_buffer_done (err -22)
[   20.631591] dvb_core: disagrees about version of symbol vb2_plane_vaddr
[   20.631607] dvb_core: Unknown symbol vb2_plane_vaddr (err -22)
[   20.631695] dvb_core: disagrees about version of symbol vb2_vmalloc_memops
[   20.631715] dvb_core: Unknown symbol vb2_vmalloc_memops (err -22)
[   20.631754] dvb_core: disagrees about version of symbol vb2_core_poll
[   20.631774] dvb_core: Unknown symbol vb2_core_poll (err -22)
[   20.631813] dvb_core: disagrees about version of symbol vb2_core_streamon
[   20.631833] dvb_core: Unknown symbol vb2_core_streamon (err -22)
[   20.631956] dvb_core: disagrees about version of symbol vb2_core_querybuf
[   20.631974] dvb_core: Unknown symbol vb2_core_querybuf (err -22)
[   20.631995] dvb_core: disagrees about version of symbol vb2_core_qbuf
[   20.632012] dvb_core: Unknown symbol vb2_core_qbuf (err -22)
[   20.632047] dvb_core: disagrees about version of symbol vb2_mmap
[   20.632063] dvb_core: Unknown symbol vb2_mmap (err -22)
[   20.632097] dvb_core: disagrees about version of symbol vb2_core_dqbuf
[   20.632114] dvb_core: Unknown symbol vb2_core_dqbuf (err -22)
[   20.632158] dvb_core: disagrees about version of symbol vb2_core_streamoff
[   20.632175] dvb_core: Unknown symbol vb2_core_streamoff (err -22)

und ein lsmod:

Code: [Select]
bbmld> lsmod
Module                         Size  Used by    Tainted: G
v3d                             73728  0
gpu_sched                   45056  1 v3d
bcm2835_codec            40960  0
i2c_bcm2835                16384  0
snd_soc_bcm2835_i2s  16384  0
videobuf2_dma_contig  20480  1 bcm2835_codec
v4l2_mem2mem           36864  1 bcm2835_codec
bcm2835_v4l2              40960  0
bcm2835_mmal_vchiq   28672  2 bcm2835_codec,bcm2835_v4l2
vc_sm_cma                  32768  1 bcm2835_mmal_vchiq
videobuf2_v4l2             32768  3 bcm2835_codec,v4l2_mem2mem,bcm2835_v4l2
vc4                              262144 10
videobuf2_vmalloc         16384  1 bcm2835_v4l2
videobuf2_memops       16384  2 videobuf2_dma_contig,videobuf2_vmalloc
videobuf2_common       65536  7 bcm2835_codec,videobuf2_dma_contig,v4l2_mem2mem,bcm2835_v4l2,videobuf2_v4l2,videobuf2_vmalloc,videobuf2_memops
videodev                       249856  5 bcm2835_codec,v4l2_mem2mem,bcm2835_v4l2,videobuf2_v4l2,videobuf2_common
mc                               45056  5 bcm2835_codec,v4l2_mem2mem,videobuf2_v4l2,videobuf2_common,videodev
snd_soc_core                229376  2 snd_soc_bcm2835_i2s,vc4
snd_compress               20480  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
drm_kms_helper            253952  3 vc4
syscopyarea                 16384  1 drm_kms_helper
sysfillrect                      16384  1 drm_kms_helper
sysimgblt                      16384  1 drm_kms_helper
fb_sys_fops                  16384  1 drm_kms_helper
cec                               49152  1 vc4
drm                              528384  7 v3d,gpu_sched,vc4,drm_kms_helper
ir_rc6_decoder               16384  0
gpio_ir_recv                   16384  0
drm_panel_orientation_quirks    16384  1 drm
backlight                         20480  1 drm
uinput                            20480  1
snd_bcm2835                 24576  0
snd_pcm                        106496  7 snd_soc_bcm2835_i2s,vc4,snd_soc_core,snd_compress,snd_pcm_dmaengine,snd_bcm2835
snd_timer                       32768  1 snd_pcm
snd                                73728  8 snd_soc_core,snd_compress,snd_bcm2835,snd_pcm,snd_timer

Ich habe einmal nach dem Fehler: dvb_core: disagrees about version of symbol vb2_core_queue_init gegoogelt dabei habe ich etwas gefunden: https://tvheadend.org/boards/4/topics/35675. Ich habe eine TBS5922se Multi-standard Universal TV Tuner USB Box, nicht wie bei gr4vity eine TBS5920se. Kann das damit zusammen hängen?

Gruß Bernd

VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #20 on: June 13, 2022, 00:03:38 »
Hi,
ich denke der Treiber funktioniert nicht, weil der einfach nicht zur verwendeten Kernelversion passt.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #21 on: June 13, 2022, 14:26:00 »
was kann man da machen?
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #22 on: June 13, 2022, 16:13:54 »
Ich sehe das so, dass sich die DVB Karte nicht ohne erheblichen Aufwand mit einem aktuellen MLD System verwenden lässt. Du müsstest also eine ältere MLD Version verwenden (bei der das dvb-tbs Paket noch in der alten Version dabei ist), oder Dir eine andere DVB Karte zulegen.
Es könnte auch sein, dass der alte Treiber in der MLD-5.5 nur an einer Kleinigkeit scheitert, aber das lässt sich nicht einfach ergründen.
« Last Edit: June 13, 2022, 16:15:25 by clausmuus »
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #23 on: June 23, 2022, 16:43:22 »
Hi Claus,

Ich war leider2 Wochen unterwegs, deshalb konnte ich nichts testen. Ich habe jetzt meinen alten RASPI 3 B + probiert. Mit der 5.3 Stable und dem dvb-mb Treiber, habe ich aber auch keine Bild. Kann das noch einen anderen Grund haben? Würde denn der RPI4 mit einem Sundtek USB Stick funktionieren? Hast du damit Erfahrung?

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #24 on: June 23, 2022, 20:10:53 »
Die Sundteck Sticks machen erfahrungsgemäß am seltensten Probleme. Genauergesagt ließen sich bisher noch alle auftretenden Probleme mit Sundteck Sticks beheben.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #25 on: July 24, 2022, 16:15:36 »
Hallo zusammen,

ich habe jetzt endlich Zeit gefunden mir den Sundtek usb Tuner zu installieren. Er hat gleich ein Bild gebracht. Jetzt habe ich aber das Problem, dass das Bild stehen bleibt. Im /var/log/vdr steht folgender Fehler:

Code: [Select]
Im AlsaPlayer: ring buffer empty

nach kurzer Zeit kommt es wieder. Das wiederholt sich dann in Abständen. Hat da jemand eine Erklärung, oder kann man der Ursache noch weiter verfolgen?

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19813
    • View Profile
    • ClausMuus.de
RPI 4 5.5 unstabe "board requires newer software"
« Reply #26 on: July 25, 2022, 19:23:08 »
Dafür könnten Empfangsprobleme verantwortlich sein.
Verwendest Du Sat, Kabel oder Terrestrischen Empfang?
Wie lang sind die Abstände zwischen den Störungen, bzw. wie lange funktioniert es ohne Störung?
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #27 on: July 28, 2022, 18:34:39 »
Ich verwende SAT, ca. 35 Minuten nach dem Einschalten war das Bild für ca. 10 Sekunden weg. Dann kam es kurz wieder danach wiederholte sich das Ganze in unterschiedlichen Abständen.

Ich habe jetzt noch mal einen Tag gewartet und heute gabe es längere Zeit ein Bild, dann ging es wieder los. Heute sehe ich in den Log Files folgendes:

Code: [Select]
bbmld> tail -f /var/log/vdr
VDR exits at Do Jul 28 18:22:05 CEST 2022
VideoRenderFrame: error_flag or FRAME_FLAG_CORRUPT
VDR exits at Do Jul 28 18:22:57 CEST 2022
VideoRenderFrame: error_flag or FRAME_FLAG_CORRUPT
VDR exits at Do Jul 28 18:23:50 CEST 2022
VideoRenderFrame: error_flag or FRAME_FLAG_CORRUPT
VDR exits at Do Jul 28 18:24:42 CEST 2022
VideoRenderFrame: error_flag or FRAME_FLAG_CORRUPT
VDR exits at Do Jul 28 18:25:38 CEST 2022
VDR exits at Do Jul 28 18:26:36 CEST 2022

bbmld> tail -f /var/log/messages
Jul 28 18:28:18 MLD-rpi4 user.err vdr: [6237] emergency exit requested - shutting down
Jul 28 18:28:28 MLD-rpi4 user.err vdr: [6237] emergency exit!
Jul 28 18:29:15 MLD-rpi4 user.err vdr: [6481] ERROR: video data stream broken
Jul 28 18:29:15 MLD-rpi4 user.err vdr: [6481] initiating emergency exit
Jul 28 18:29:15 MLD-rpi4 user.err vdr: [6444] emergency exit requested - shutting down
Jul 28 18:29:23 MLD-rpi4 user.err vdr: [6444] emergency exit!
Jul 28 18:30:10 MLD-rpi4 user.err vdr: [6690] ERROR: video data stream broken
Jul 28 18:30:10 MLD-rpi4 user.err vdr: [6690] initiating emergency exit
Jul 28 18:30:10 MLD-rpi4 user.err vdr: [6653] emergency exit requested - shutting down
Jul 28 18:30:17 MLD-rpi4 user.err vdr: [6653] emergency exit!

Kannst du da etwas mit anfangen?

Gruß Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

Offline gr4vity

  • Expert Member
  • *****
  • Posts: 604
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #28 on: July 28, 2022, 20:22:41 »
Hi barny,
You forgot to mention if you get these erros with some specific channel or all channels?

Offline barny

  • Adv. Member
  • ***
  • Posts: 115
    • View Profile
RPI 4 5.5 unstabe "board requires newer software"
« Reply #29 on: July 29, 2022, 18:11:07 »
Hi gr4vity,

it is on all channels, this morning it worked for 5 to 6 hours, then it is broken. I saw in the log:
Code: [Select]
bbmld> tail -f /var/log/messages
Jul 29 14:38:39 MLD-rpi4 user.info kernel: [20855.662003] [   2743]     0  2743     1596      581    36864        0             0 sh
Jul 29 14:38:39 MLD-rpi4 user.info kernel: [20855.662024] [   2752]     0  2752     1564      498    36864        0             0 tail
Jul 29 14:38:39 MLD-rpi4 user.info kernel: [20855.662050] oom-kill:constraint=CONSTRAINT_NONE,nodemask=(null),cpuset=/,mems_allowed=0,global_oom,task_memcg=/,task=mediasrv,pid=1260,uid=0
Jul 29 14:38:39 MLD-rpi4 user.err kernel: [20855.662196] Out of memory: Killed process 1260 (mediasrv) total-vm:82728kB, anon-rss:6636kB, file-rss:2176kB, shmem-rss:3672kB, UID:0 pgtables:96kB oom_score_adj:0
Jul 29 14:38:39 MLD-rpi4 user.info kernel: [20855.671095] oom_reaper: reaped process 1260 (mediasrv), now anon-rss:0kB, file-rss:0kB, shmem-rss:3672kB
Jul 29 14:38:54 MLD-rpi4 user.err vdr: [6723] ERROR (dvbdevice.c,1929): /dev/dvb/adapter0/frontend0: No such device or address
Jul 29 14:38:54 MLD-rpi4 user.err vdr: [6723] ERROR (dvbdevice.c,1929): /dev/dvb/adapter1/frontend0: No such device or address
Jul 29 14:38:54 MLD-rpi4 user.err vdr: [6723] ERROR: invalid primary device number: 3
Jul 29 15:19:19 MLD-rpi4 user.err vdr: [9711] ERROR (dvbdevice.c,1929): /dev/dvb/adapter0/frontend0: No such device or address
Jul 29 15:19:19 MLD-rpi4 user.err vdr: [9711] ERROR (dvbdevice.c,1929): /dev/dvb/adapter1/frontend0: No such device or address

after a reboot everything was OK for some time. Means /dev/dvb/adapter0/frontend0: No such device or address that the stream from the SAT Switch is broken?

Regards Bernd
VDR: RPI 4 8 GB RAM MLD 5.5 Testing
RPI 3 MLDClient 5.5

1 [2] 3 >>> MLD-5.x / Systeme / Raspberry PI / RPI 4 5.5 unstabe "board requires newer software"
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.