1 2 [3] 4 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.4 auf RPI3 - nur Klötzchengrafik
 

Offline iNOB

  • Profi Member
  • ****
  • Posts: 382
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #30 on: May 16, 2020, 14:01:05 »
Du bist damit nicht alleine. Alles nach 5.1 ist als SATIP-Client nicht zu gebrauchen. Hab da schon endlose Stunden damit verbracht herauszufinden an was das liegen könnte. Meiner Meinung nach ist das ein Kernel Problem welches dafür sorgt, dass nach einiger Zeit nur noch Klötzchengrafik angezeigt wird. Es hat jedenfalls nichts mit der Stromversorgung, der Temperatur oder irgendeiner Plugineinstellung zu tun.

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2389
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #31 on: May 16, 2020, 17:48:34 »
Wenn es ein Kernel Problem sein sollte wie du meinst, dann müssten das dann alle User haben. Habe hier Rpi 3 MLD 5.4 mit SAT IP und auch mit USB DVB-S2 laufen und auch MLD 5.5 SAT IP und alle funktionieren Problemlos. 
Gruß Mario
Meine Hardware (show / hide)

Offline iNOB

  • Profi Member
  • ****
  • Posts: 382
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #32 on: May 17, 2020, 10:37:23 »
Der einzige RPI der bei mir völlig problemlos läuft, ist ein RPI2b mit MLD 5.1. SAT>IP kommt von einem OctopusNet. Wenn deine Hard-/Softwarekombi läuft ist das schön für dich. Meine Testgeräte liefen eben nicht und ich hab auch keine große Lust meine Lebenszeit mit weiteren Installations- und Testorgien zu verschwenden. Ich gebe lieber etwas mehr Geld aus und benutze einen Intel NUC, da weiß ich wenigstens, dass der mit MLD auf Anhieb mit SAT>IP funktioniert. Und zwar auch, wenn man damit nicht nur FTA TV schauen will.
« Last Edit: May 17, 2020, 10:42:46 by iNOB »

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 170
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #33 on: May 17, 2020, 11:07:56 »
Der rpi3 scheint ein besonderes Problemkind zu sein. Ich kann nicht abschätzen, wie groß der Anteil derer ist, die mit ihm Probleme haben - aber einige haben sich hier im Forum ja doch geoutet

Was gibt es für Möglichkeiten, diese Probleme zu lösen?

Kann man für den rp3 eine gesonderte Software - Linie mit älteren Kernel pflegen? Wie groß ist der Aufwand, und wer kann das übernehmen?

Oder Ist es besser, den IP3 aus der Liste der sinnvollen MLD - Geräte rauszunehmen? - Bevor sich bei den Nutzern und den Machern des MLD bergeweise Frust anhäuft.

Und gibt es noch eine Möglichkeit, an die ich jetzt nicht denke?

Wünsche Euch einen schönen Sonntag!
Wolf

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #34 on: May 17, 2020, 11:24:40 »
Letztes Jahr im Sommer habe ich diesen Thread eröffnet.
Nun finde ich es interessant, daß er aus der Versenkung geholt wurde.  :) ;)

Bei mir funktioniert auf dem RPI 3 die MLD 5.3 einwandfrei - vor wenigen Tagen neu installiert da das System durch herumprobieren mit SatIP von mir zerschossen wurde.
Wenn MLD 5.4 bei euerer HW nicht richtig funktioniert, probiert doch einmal die 5.3 Version.
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #35 on: May 17, 2020, 11:36:22 »
Hi,

Ich habe gerade mal die 5.4 Stable auf meinen RPI3 als Sat-IP Client installiert,
bei mir läuft das Bild ohne Probleme.

HD Sender, SD Sender kann ich nicht testen, da ich für meinen RPI3 keine mpeg2 Linzenz habe.

Gruß,
  Roland

1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline outis

  • Adv. Member
  • ***
  • Posts: 169
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #36 on: May 17, 2020, 11:48:35 »
Ich kann auch nicht klagen, denn die Aufnahmen, die mein rpi3/MLD5.4 hinter dem SAT-IP Transmitter als Server angefertigt hatte, waren auch störungsfrei.

Wenn also so unterschiedliche Erfahrungen vorliegen und die Probleme nicht vor dem rpi generiert werden, dann fallen mir als Erklärungsansätze ein Qualitätsschwankungen bei den Bauteilen des rpi und/oder Seiteneffekte von SD-Karten.
Viele Grüße
Jochen

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #37 on: May 17, 2020, 11:52:35 »
@ rfehr
Es scheint mir, daß die MLD 5.4 Version einen neueren Kernel hat als die Version 5.3.
Wenn meine Annahme stimmt, werden im Kernel von 5.4 nicht mehr alle USB DVB-S2 Sticks richtig unterstützt - wie meiner. Aber das ist nur mein Gedanke.
Daß es mit SatIP und client richtig funktioniert liegt möglicherweise daran, daß bei so einer Installation nun einmal auch kein DVB Device installiert ist.
Aber - nur so ein Gedanke von mir.  ;)
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #38 on: May 17, 2020, 12:07:22 »
Hi kuro,

habe mal meinen Sundtek DVB-C Stick augegraben, der läuft mit MLD5.4 Stable auch ohne Probleme auf dem RPI3.

Gruß,
  Roland
« Last Edit: May 17, 2020, 12:12:06 by rfehr »
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #39 on: May 17, 2020, 12:52:28 »
Hallo Roland
Seit vielen Jahren habe mich wegen DVD-S2 Empfängern an https://www.linuxtv.org/wiki/index.php/Category:Hardware orientiert.
Wie aktuell diese Seite ist, weiß ich leider nicht.
Wie ich mitbekommen habe, gibt es eine eigene Installation für Sundtek in MLD.
Das mag auch den Unterschied ausmachen - ich DVB Treiber aus Linuxkernel, du Sundtec Installation.
Ich denke dass im Kernel von MLD 5.4 diverse USB Sticks nicht mehr richtig unterstützt werden.
Bei der Version 5.3 funktioniert meine HW einwandfrei.
LG Roman
« Last Edit: May 17, 2020, 13:02:12 by kuro13 »
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #40 on: May 17, 2020, 13:19:16 »
Hi kuro,

du setzt den PCTV DVB-S2 Stick (461e) ein richtig ?

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #41 on: May 17, 2020, 13:48:41 »
Hi kuro,

ich habe mir mal deine 'alten' Log angeschaut, die du mal hier hinterlegt hattest.

Ich glaube es liegt nicht am Kernel oder am Treiber für den Stick, sondern an der VDR Version,
bzw. an einer library.

Code: [Select]
Jul  8 09:33:16 (none) user.err vdr: [20836] rpihddevice: [libav] Header missing
Jul  8 09:33:16 (none) user.err vdr: [20836] rpihddevice: failed to decode audio frame!
Jul  8 09:33:20 (none) user.err vdr: [20836] rpihddevice: failed to decode audio frame!
Jul  8 09:33:22 (none) user.err vdr: [20836] rpihddevice: [libav] Header missing

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #42 on: May 17, 2020, 14:34:53 »
Quote
Ich habe einmal von der 5.4 Installation ein Log hochgeladen.
TuQPRr
Meinst du diesen Log von mir vom 8.7.2019?
Hat sich in Sachen MLD 5.4 stable im RPI 3 indessen etwas verändert?
Wenn ja - probiere ich neu.  :)
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #43 on: May 17, 2020, 15:40:52 »
Es ist auf jedenfall jetzt der vdr 2.4.1
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #44 on: May 17, 2020, 17:21:17 »
Nun habe ich eben wieder probiert:

MLD-5.4_netinstall_2020.03.13-181+1474_armhf-rpi3.img

MLD-5.5_netinstall_2020.05.10-181.6+1580_armhf-rpi3.img

Bei beiden Versionen - im Live Versuch - das gleiche Ergebnis - siehe angehängtes Bild.
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

1 2 [3] 4 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.4 auf RPI3 - nur Klötzchengrafik
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.