[1] 2 3 4 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.4 auf RPI3 - nur Klötzchengrafik
 

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« on: July 02, 2019, 18:27:39 »
Hallo Miteinander

Nun habe ich wieder einmal versucht, auf meinem RPI3 MLD 5.4 Stable zu installieren.
Aber - es ist leider wie vor ca. einem halben Jahr - funktioniert nicht richtig.
Meine Hardware: RPI 3, 32 GB Karte, PCTV DVB-S2 Stick (461e)
Unter MLD 5.3 funktioniert diese HW einwandfrei - bei MLD 5.4 nur Klötzchengrafik.

Dann habe ich geschaut:

MLD> dmesg | grep DVB
[  171.170771] em28xx 1-1.3:1.0: DVB interface 0 found: isoc
[  171.501625] em28xx 1-1.3:1.0: Identified as PCTV DVB-S2 Stick (461e) (card=92                                                   
[  171.511014] em28xx 1-1.3:1.0: Binding DVB extension
[  172.374080] em28xx 1-1.3:1.0: DVB interface 0 found: isoc
[  172.941647] em28xx 1-1.3:1.0: Identified as PCTV DVB-S2 Stick (461e) (card=92                                                   
[  172.942138] em28xx 1-1.3:1.0: Binding DVB extension
[  173.035781] dvbdev: DVB: registering new adapter (1-1.3:1.0)
[  173.035804] em28xx 1-1.3:1.0: DVB: registering adapter 0 frontend 0 (Montage                                                   
[  173.038214] em28xx 1-1.3:1.0: DVB extension successfully initialized

Unter https://www.linuxtv.org/wiki/index.php/Pinnacle_PCTV_DVB-S2_Stick_(461e) sieht es so aus, dass diese USB Karte von Linux unterstützt wird, sogar die Firmware ist in MLD installiert.

Was mache ich nur falsch oder ist diese Hardwarekombination für MLD 5.4 nicht geeignet?

Gerade habe ich wieder die 5.3 Karte eingesteckt - funktioniert einwandfrei.
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline iNOB

  • Profi Member
  • ****
  • Posts: 382
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #1 on: July 03, 2019, 13:35:18 »
Hat der TV-Stick eine eigene Stromanbindung, oder zieht der seinen Saft aus dem USB-Port?

Eventuell hilfts wenn man in der config.txt den Parameter zum Aufheben der Strombegrenzung (von 600mA auf 1200mA) setzt:

max_usb_current=1

Bringt natürlich nur was, wenn das RPI-NT auch den Saft dazu liefert...

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #2 on: July 03, 2019, 19:48:19 »
Danke für die Antwort.
Der USB TV Stick hat eine eigene Stromversorgung, das dürfte also nicht das Problem sein.
Ich werde auf der funktionierenden MLD 5.3 Installation einmal in der config.txt schauen, ob da der Parameter max_usb_current=1 gesetzt ist.
Ob es am Orginalnetzteil (2500 mA) liegt, weiß ich nicht.
Wie schon geschrieben - MLD 5.3 funktioniert einwandfrei.
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #3 on: July 03, 2019, 23:36:36 »
Bei der MLD ist Strombegrenzung per Voreinstellung abgeschaltet. Da dran sollte es also nicht liegen.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Georg

  • Adv. Member
  • ***
  • Posts: 164
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #4 on: July 07, 2019, 21:12:00 »
Moin, moin,

ich habe die 5.4 länger nicht mehr ausprobiert. Beim letzten Versuch hatte ich dieselben Probleme. Bei mir ist es das Vorgängermodell des USB-Empfängers (siehe Signatur), selbstverständlich auch mit eigenem Netzteil. Derzeit ist wieder die 5.3 ohne nennenswerte Probleme im Einsatz.

Ciao, Georg
MLD 5.3: RaspberryPi 3 + PCTV 460e

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #5 on: July 08, 2019, 07:49:43 »
Welches DVB Paket habt Ihr unter der MLD-5.3 installiert. Und ist da die Firmware Version die Selbe wie unter 5.4?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #6 on: July 08, 2019, 09:54:54 »
Gerade habe ich MLD 5.4 auf dem RPI 3 neu installiert - ohne die geringsten Änderungen.
Unter 5.3 und 5.4 sind die Pakete dvb und dvb-autodetect installiert.

Bei beiden Versionen sehe ich unter /lib/firmware - dvb-demond-m88ds3103.fm
Welche firmware dann "genommen" wird, dazu reichen momentan meine Kenntnisse nicht.  :(
Ich habe einmal von der 5.4 Installation ein Log hochgeladen.
TuQPRr
Edit: Bei der 5.3 Installation sind nur - dvb DVB Treiber aus Linuxkernel - installiert. (Laut WebIF)
« Last Edit: July 08, 2019, 10:59:10 by kuro13 »
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #7 on: July 08, 2019, 16:51:22 »
Magst Du von der 5.3 auch noch ein Log hoch laden?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #8 on: July 08, 2019, 19:23:53 »
Habe ich gemacht - von der gut funktionierenden 5.3 Installation.
Upload Code: IQcM4y
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline Georg

  • Adv. Member
  • ***
  • Posts: 164
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #9 on: July 08, 2019, 20:07:20 »
Ich habe gerade meine 5.4 auf den aktuellen Stand gebracht. Das Bild ist weiterhin unbrauchbar.

MLD 5.4: uq9cSr
MLD 5.3: KjZOCa

Ciao, Georg
MLD 5.3: RaspberryPi 3 + PCTV 460e

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2389
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #10 on: July 09, 2019, 00:28:28 »
Habt ihr auch schon mal die unstable versucht? Habe die hier am Laufen und geht einwandfrei. Nur habe ich einen Suntek USB Stick in Verwendung. System ist am aktuellen Stand.
Gruß Mario
Meine Hardware (show / hide)

Offline Georg

  • Adv. Member
  • ***
  • Posts: 164
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #11 on: July 09, 2019, 08:50:54 »
MLD 5.4 Unstable: PjCl7Q

Das Bild ist damit auch nicht besser.

Ciao, Georg
MLD 5.3: RaspberryPi 3 + PCTV 460e

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #12 on: July 09, 2019, 09:33:31 »
Heutiger, zweimaliger Versuch auf 32 GB SD Karte - 5.4 testing:
Nicht einmal ein Bild, obwohl richtige Kanalliste eingestellt wurde.
Also - ich gebe es momentan auf mit MLD 5.4 und dieser Hardware.

Edit: MLD 5.3 funktioniert auf einer 8 GB Karte.
« Last Edit: July 09, 2019, 09:36:19 by kuro13 »
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #13 on: July 09, 2019, 16:18:35 »
Was ein Glück, das die RPI 5.4 seit einigen Wochen nicht geändert wurde ...
Mit anderen Worten, wenn's damit letzte Wochen (ein bischen) funktioniert hat, sollte es heute genau so (fast) gut funktionieren.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline kuro13

  • MLD-Tester
  • Profi Member
  • ******
  • Posts: 447
    • View Profile
MLD 5.4 auf RPI3 - nur Klötzchengrafik
« Reply #14 on: July 09, 2019, 16:59:22 »
Quote
Was ein Glück, das die RPI 5.4 seit einigen Wochen nicht geändert wurde ...
Mit anderen Worten, wenn's damit letzte Wochen (ein bischen) funktioniert hat, sollte es heute genau so (fast) gut funktionieren.

Das verstehe ich jetzt nicht.
MLD 5.4 mit dem PCTV DVB-S2 Stick funktioniert auf dem RPI3 nicht richtig (Bild nur Klötzchen, kein Ton), MLD 5.3 funktioniert prächtig.
Asus AT3IONT-I - nVidia Grafik, Mystique SaTiX-S2 V2 Dual, Atric Einschaltmodul an com1
sda - SSD - MLD 5.1 - 64 Stable
sdb - 256 GB SSD (Aufnahmen)
RPI 3 MLD 5.3 Stable, PCTV DVB-S2 Stick (461e), FB an GPIO

[1] 2 3 4 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.4 auf RPI3 - nur Klötzchengrafik
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.