1 [2] 3 4 >>> MLD-5.x / General / (MLD 5.4 testing) kernel 5.3.5.202.31 amd64
 

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #15 on: October 23, 2019, 17:39:35 »
Hello Claus,

Thank you very much, i already compiled vtuner module by changing the path in Makefile.
The funny thing is after i did all that i noticed that vtuner is already included in MLD 5.3.5 kernel sources  :D :D

root@92bafaf276d7:/MLD/kernel/src/linux-5.3.5/drivers/media/vtuner# ls
Kconfig        vtunerc.ko     vtunerc.o       vtunerc_main.o
Makefile       vtunerc.mod    vtunerc_ctrldev.c  vtunerc_priv.h
modules.order  vtunerc.mod.c  vtunerc_ctrldev.o  vtunerc_proxyfe.c
vtuner.h       vtunerc.mod.o  vtunerc_main.c    vtunerc_proxyfe.o

So why you don't make it available for download in MLD 5.4 testing branch?

MLD> apt search vtuner
Sorting... Done
Full Text Search... Done

I think docker containers are similar to virtual machines in windows, i'm still learning about it though.
For ex.,
MLD> docker images -a
REPOSITORY          TAG                 IMAGE ID            CREATED             SIZE
mld/devel           5.4                 cd043bf25c68        2 days ago          967MB
<none>              <none>              01e85ee1f011        2 days ago          582MB
<none>              <none>              220f8b9d5448        2 days ago          539MB
<none>              <none>              da6238eec7e8        2 days ago          101MB
<none>              <none>              28e0fb4d2e31        2 days ago          101MB
debian              stretch             4f5edfdf153f        6 days ago          101MB
MLD> docker rmi 01e85ee1f011
Error response from daemon: conflict: unable to delete 01e85ee1f011 (cannot be forced) - image has dependent child images

I don't know what are those images with <none> tag which i'm unable to delete   :-\
Any idea?
I was playing around then installed an image called dperson/samba then deleted it so it's not one of those images.

Secondly,
docker network inspect bridge
"IPv4Address": "172.17.0.2/16",
What i can do with the container ip address?

« Last Edit: October 23, 2019, 17:42:29 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #16 on: October 23, 2019, 18:03:29 »
I'm not sure, but until my last tests with the vtuner module, it don't work. That's the reason why we disable the vtuner package. The vtuner module is added by a patch to the MLD kernel.

The docker image with tag <none> are layers, that are used by other images. In you case by the mld/devel image. Every block in the docker file create a layer. That's the normal way it works.

If you want to access the docker container from outside e.g. by ssh or scp, you must forward a port of the host to the internal used port. This is only possible on container creation time. But you can do a ssh connection from inside the container to outside without any problems. You must only install the ssh client package inside the container.
On our MLD development server we are running sometimes the develserver. This tool start a simple apt repository server that allow to install packages direct from the MLD docker container. But for this you must also configure a port forwarding into the container. you can find some info about it in the MLD wiki.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #17 on: October 23, 2019, 20:58:05 »
I think i know why the vtuner module you tested didn't work because of this.
DEVICE:0 ADAPTER:1 FRONTEND:0 (vTuner proxyFE DVB-S2)
       FE_QPSK Fmin=0MHz Fmax=2MHz

It should be FE_QPSK Fmin=950MHz Fmax=2150MHz

The vtuner module which i build yesterday works fine,
Do you want that i upload it here?

By the way i wanted to compile crazycat media_build in order to fix my SNR measurement problem but it failed.
Do you know how to fix that?


* Start building *
******************
make -C /MLD/media_build/v4l allyesconfig
make[1]: Entering directory '/MLD/media_build/v4l'
No version yet, using 5.3.5.202.31
make[2]: Entering directory '/MLD/media_build/linux'
Applying patches for kernel 5.3.5.202.31
patch -s -f -N -p1 -i ../backports/api_version.patch
patch -s -f -N -p1 -i ../backports/pr_fmt.patch
patch -s -f -N -p1 -i ../backports/debug.patch
patch -s -f -N -p1 -i ../backports/drx39xxj.patch
Patched drivers/media/dvb-core/dvbdev.c
Patched drivers/media/v4l2-core/v4l2-dev.c
Patched drivers/media/rc/rc-main.c
make[2]: Leaving directory '/MLD/media_build/linux'
./scripts/make_kconfig.pl /lib/modules/5.3.5.202.31/build /lib/modules/5.3.5.202.31/build 1
Preparing to compile for kernel version 5.3.5
File not found: /lib/modules/5.3.5.202.31/build/.config at ./scripts/make_kconfig.pl line 33, <IN> line 4.
Makefile:387: recipe for target 'allyesconfig' failed
make[1]: *** [allyesconfig] Error 2
make[1]: Leaving directory '/MLD/media_build/v4l'
Makefile:26: recipe for target 'allyesconfig' failed
make: *** [allyesconfig] Error 2
can't select all drivers at ./build line 545
root@92bafaf276d7:/MLD/media_build#



File not found: /lib/modules/5.3.5.202.31/build/.config
Should i change the path in make_kconfig.pl ?
« Last Edit: October 23, 2019, 21:08:12 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #18 on: October 23, 2019, 22:41:32 »
Thank you for the test with the vtuner. Can you please post a diff to fix it.

Until your media_build build there is an absolute path "/lib/modules/5.3.5.202.31/...". I think this must be the path to the mld kernel.
Dou you have take a look to our dvb-mb package. That is our old media_build package. If you want to use it as template, you mut check it out "make checkout name=dvb-mb" and than remove the first line of the Makefile because that disable the package.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #19 on: October 24, 2019, 11:38:04 »
Please test the "dvb-vtuner" package of MLD unstable.
You can use the "satip" package to configure and activate the vtuner connection.
« Last Edit: October 24, 2019, 11:44:33 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #20 on: October 24, 2019, 16:27:27 »
Guten Tag Claus,

dvb-vtuner package  MLD unstable Depends: kernel (>= 5.2.17.202.28).

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #21 on: October 24, 2019, 18:15:23 »
Ja, das ist der unstable Kernel
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #22 on: October 24, 2019, 20:09:20 »
Unfortunately, i can't test it.
Is it possible to build dvb-vtuner package for MLD 5.4 testing?

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #23 on: October 24, 2019, 22:55:57 »
It's now also for the testing available.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #24 on: October 25, 2019, 14:09:33 »
I have tested it, it works great with minisatip installed on my Raspberry Pi.  Vielen Dank!  :D

But i had to repack the dvb-vtuner and satip packages because i don't want to remove the dvb package, also had to delete dvb-core - mc modules from dvb-vtuner package.

I like to have the physical tuner and vtuner work simultaneously as follows

MLD> lsdvb

      lsdvb: Simple utility to list PCI/PCIe DVB devices
      Version: 0.0.4
      Copyright (C) Manu Abraham

usb (739350280:32739 6299728:0) on PCI Domain:4197676 Bus:0 Device:-121293840 Function:32764
   DEVICE:0 ADAPTER:0 FRONTEND:0 (Technisat SkyStar USB HD (DVB-S/S2))
       FE_QPSK Fmin=950MHz Fmax=2150MHz
File: /sys/class/dvb/dvb1.frontend0/device/uevent open failed
   DEVICE:0 ADAPTER:1 FRONTEND:0 (vTuner proxyFE DVB-S2)
       FE_QPSK Fmin=950MHz Fmax=2150MHz

By the way Technisat SkyStar eXpress HD is not recognized by this kernel, i don't know why.
For this reason i want to compile crazycat media_build.
« Last Edit: October 25, 2019, 14:16:30 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #25 on: October 25, 2019, 15:17:15 »
I think the conflickt with the dvb package is historically configured. I will change it.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #26 on: October 25, 2019, 19:09:43 »
Yes, it's configured to make it work as a satip client only.
If you want to run satip server or watch live tv using your physical tuner you can't unless you uninstall vtuner and satip packages.

« Last Edit: October 25, 2019, 21:57:44 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18022
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #27 on: October 25, 2019, 22:50:40 »
It's changed.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #28 on: October 26, 2019, 15:49:36 »
It's changed.

Very good  :)
I forgot to mention something, if you use VDR you must configure diseqc to work with 2 tuners,
Remember when i made a thread about that and you said this question is asked once every 5 years?
Now it's useful.   :D

In enigma2 it can be easily configured in settings



The whole discussion about configuring diseqc with 2 tuners can be found here.

https://www.minidvblinux.de/forum/index.php/topic,8886.0.html
« Last Edit: October 26, 2019, 18:24:11 by gr4vity »

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 193
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #29 on: October 26, 2019, 16:02:41 »
Now i have a problem with xorg and intel graphics card.
If i install mesa + xorg-drivers packages only 800x600 resolution is supported.
On the other hand, if i remove mesa + xorg-drivers packages then install xorg-intel
All available resolutions are supported but nothing works.

For ex.,
Here is VDR Log
Code: [Select]
load_plugins: plugin dxr3-mpeg2 failed to instantiate itself.
load_plugins: plugin vdpau_mpeg12 failed to instantiate itself.
video_out: vo_open (0x7fbb00081d40)
video_out_opengl: tried to set unsupported property 0
load_plugins: plugin mpeg2 will be used for video streamtype 00.
video_out_opengl: setup of '2D_Tex_Fragprog'
video_out_opengl_fragprog: b 0 c 128 s 128 [RGB]
video_out_opengl: tried to set unsupported property 0
Segmentation fault

Any idea?
« Last Edit: October 26, 2019, 16:24:27 by gr4vity »

1 [2] 3 4 >>> MLD-5.x / General / (MLD 5.4 testing) kernel 5.3.5.202.31 amd64
 



Users Online Users Online

0 Members and 2 Guests are viewing this topic.