1 2 [3] 4 >>> MLD-5.x / General / (MLD 5.4 testing) kernel 5.3.5.202.31 amd64
 

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #30 on: October 26, 2019, 16:46:18 »
Only as info: The xorg-intel package contains parts of the mesa package, that are needed for the intel hardware.
But a problem that some users reported is, that some Intel graphic cards do not support the preconfigured deinterlacer. May be that's also your problem. If you install the xorg-drivers package the deinterlacer is disabled by default. That can be configured in the softhddevice Plugin settings.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #31 on: October 26, 2019, 18:17:42 »
* 720p:                           hide                                         
Scaling:                          Normal                                       
Deinterlace:                      Temporal                                     
SkipChromaDeinterlace:            no                                           
Inverse Telecine:                 no                                           
Denoise (0..[0]..1000):           0                                             
Sharpen (-1000..[0]..1000):       0                                             
Cut top and bottom (pixel):       0                                             
Cut left and right (pixel):       0     

I have checked softhddevice plugin settings
Deinterlace isn't disabled, it's set to temporal, should i change that to some other setting?
« Last Edit: October 26, 2019, 18:44:52 by gr4vity »

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) linux-headers-5.3.5.202.31
« Reply #32 on: October 26, 2019, 18:59:42 »
Now i have a problem with xorg and intel graphics card.
If i install mesa + xorg-drivers packages only 800x600 resolution is supported.
On the other hand, if i remove mesa + xorg-drivers packages then install xorg-intel
All available resolutions are supported but nothing works.

Perhaps i didn't describe the problem correctly,
"All available resolutions are supported but nothing works"
Nothing works ... i mean the applications like VDR, Kodi doesn't work.
But all available resolutions are working.
MLD> xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
VGA1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080     60.00*+
   1680x1050     59.95 
   1600x900      60.00 
   1280x1024     75.02    60.02 
   1440x900      59.89 
   1366x768      59.79 
   1280x800      59.81 
   1152x864      75.00 
   1280x720      60.00 
   1024x768      75.03    70.07    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32 
   640x480       75.00    72.81    66.67    59.94 
   720x400       70.08 
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

« Last Edit: October 26, 2019, 19:01:39 by gr4vity »

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #33 on: October 30, 2019, 16:51:27 »
Hi Claus,

I was trying to delete an old snapshot but received an error that it can't be deleted.
Therefore i manually deleted the snapshot directory.
After that i noticed that docker container doesn't work anymore.
It seems that it was inside the snapshot directory which i deleted.  >:(

Anyway, i installed docker on my pc but still can't figure out how to compile crazycat media_build
Can you give me steps in order to solve that issue?
How come it reads outside the container trying to find
/lib/modules/5.3.5-050305-lowlatency/build/.config ?

 I downloaded dvb-mb package but i dont know what to do next.

******************
* Start building *
******************
make -C /MLD/kernel/src/linux-5.3.5/media_build/v4l allyesconfig
make[1]: Entering directory '/MLD/kernel/src/linux-5.3.5/media_build/v4l'
No version yet, using 5.3.5-050305-lowlatency
make[2]: Entering directory '/MLD/kernel/src/linux-5.3.5/media_build/linux'
Applying patches for kernel 5.3.5-050305-lowlatency
patch -s -f -N -p1 -i ../backports/api_version.patch
patch -s -f -N -p1 -i ../backports/pr_fmt.patch
patch -s -f -N -p1 -i ../backports/debug.patch
patch -s -f -N -p1 -i ../backports/drx39xxj.patch
Patched drivers/media/dvb-core/dvbdev.c
Patched drivers/media/v4l2-core/v4l2-dev.c
Patched drivers/media/rc/rc-main.c
make[2]: Leaving directory '/MLD/kernel/src/linux-5.3.5/media_build/linux'
./scripts/make_kconfig.pl /lib/modules/5.3.5-050305-lowlatency/build /lib/modules/5.3.5-050305-lowlatency/build 1
Preparing to compile for kernel version 5.3.5
File not found: /lib/modules/5.3.5-050305-lowlatency/build/.config at ./scripts/make_kconfig.pl line 33, <IN> line 4.
Makefile:387: recipe for target 'allyesconfig' failed
make[1]: *** [allyesconfig] Error 2
make[1]: Leaving directory '/MLD/kernel/src/linux-5.3.5/media_build/v4l'
Makefile:26: recipe for target 'allyesconfig' failed
make: *** [allyesconfig] Error 2
can't select all drivers at ./build line 545
root@51eefd5dce90:/MLD/kernel/src/linux-5.3.5/media_build#

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #34 on: October 30, 2019, 21:05:17 »
Normaly you should not build external drivers inside the kernel folder. But you musst inform the driver makefile where to find the kernel by a make option like I do in the dvb-mb make file.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #35 on: October 31, 2019, 15:01:46 »
I have no idea where i can find dvb-mb makefile but i edited the driver makefile myself.
It starts building normally but failed at the end as follows:

Code: [Select]
******************
* Start building *
******************
make -C /MLD/kernel/src/linux-5.3.5 allyesconfig
make[1]: Entering directory '/MLD/kernel/src/linux-5.3.5'
scripts/kconfig/conf  --allyesconfig Kconfig
#
# No change to .config
#
make[1]: Leaving directory '/MLD/kernel/src/linux-5.3.5'
make -C /MLD/kernel/src/linux-5.3.5
make[1]: Entering directory '/MLD/kernel/src/linux-5.3.5'
  DESCEND  objtool
  CALL    scripts/atomic/check-atomics.sh
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  CHK     kernel/kheaders_data.tar.xz
  GEN     .version
  CHK     include/generated/compile.h
  UPD     include/generated/compile.h
  CC      init/version.o
  AR      init/built-in.a
  LD      vmlinux.o
drivers/media/dvb-frontends/stv091x.o:(.data+0x480): multiple definition of `stvlist'
drivers/media/tuners/stv6120.o:(.data+0x140): first defined here
drivers/media/dvb-frontends/tas2971.o:(.data+0x3a0): multiple definition of `stvlist'
drivers/media/tuners/stv6120.o:(.data+0x140): first defined here
drivers/media/dvb-frontends/stid135/stid135-fe.o:(.data+0x0): multiple definition of `stvlist'
drivers/media/tuners/stv6120.o:(.data+0x140): first defined here
drivers/media/pci/tbscapture/tbs_pcie.o:(.bss+0x140): multiple definition of `wq'
kernel/locking/test-ww_mutex.o:(.bss+0x140): first defined here
Makefile:1075: recipe for target 'vmlinux' failed
make[1]: *** [vmlinux] Error 1
make[1]: Leaving directory '/MLD/kernel/src/linux-5.3.5'
Makefile:26: recipe for target 'all' failed
make: *** [all] Error 2
build failed at ./build line 546
root@51eefd5dce90:/MLD/media_build#

After that i just gave up then run make clean  :D

Thanks a lot for your help, my last question.

Maybe later i will try to compile Updatelee kernel because it supports blindscan,
If i run this command:
docker build -t mld/devel:5.4 /root/devel
It will use cache

Code: [Select]
Sending build context to Docker daemon  2.048kB
Step 1/6 : FROM debian:stretch
 ---> 4f5edfdf153f
Step 2/6 : MAINTAINER MLD Team <team@minidvblinux.de>
 ---> Using cache
 ---> ecde355c13a9
Step 3/6 : ARG DEBIAN_FRONTEND=noninteractive
 ---> Using cache
 ---> b154b6e68cd5
Step 4/6 : RUN apt-get update  && apt-get dist-upgrade -y  && apt-get install -y     make git-core software-properties-common locales locales-all
 ---> Using cache
 ---> 8962ef67ae7c
Step 5/6 : RUN git clone http://minidvblinux.de/git-5/MLD.git MLD  && cd MLD  && make checkout_base
 ---> Using cache
 ---> 0218b065a877
Step 6/6 : RUN cd MLD  && apt-get install -y $(make deps)
 ---> Using cache
 ---> b922a186b6e5
Successfully built b922a186b6e5
Successfully tagged mld/devel:5.4

How i can clean the cache directory to reset that?
« Last Edit: October 31, 2019, 15:47:26 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #36 on: October 31, 2019, 19:49:07 »
To clean the docker cache, you must remove the Images you want to rebuild. Docker build only that pats new, thhat has chanded.

You can find the dvb-mb Makefile by this:
Code: [Select]
cd /MLD
make checkout name=dvb-mb
cd dvb-mb
cat Makefile

But maybe, you should took a look at the Makefile of the dvb-dddvb package. It's a bit simpler.
« Last Edit: October 31, 2019, 19:58:38 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #37 on: November 01, 2019, 01:22:45 »
Thanks Claus, i appreciate your help  :)
I have checked the following link for the "out of the box" supported tv-cards.
https://www.minidvblinux.de/wiki/mld/tv-karten_uebersicht/tv-karten
Unfortunately, Technisat Skystar eXpress HD is not supported because there is no dvb-mb like MLD 5.3.
But you should add Technisat Skystar USB HD to your list.
It just needs this firmware SkyStar_USB_HD_FW_v17_63.HEX.fw to be copied to /lib/firmware
I don't remember if i copied it myself or it was there already.

By the way, why don't you build crazycat media_build and make it available for download in MLD repository?
Do you want that i take crazycat permission for that?
I know him from a US forum, he is a nice guy and i think he won't mind it.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #38 on: November 01, 2019, 09:53:04 »
The reason is, that we do not know about a dvb-card that is not supported by the already included dvb drivers, but supported by any other driver package.

Please add your Skystar DVB card to the list on our wiki page. Every body can extend this list.
« Last Edit: November 01, 2019, 09:57:07 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #39 on: November 01, 2019, 14:37:48 »
Please add your Skystar DVB card to the list on our wiki page. Every body can extend this list.






Done.  :)

Edit: Just tested the remote control (partially),it works fine .... remote.conf needs to be configured accordingly.
« Last Edit: November 01, 2019, 20:18:35 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #40 on: November 02, 2019, 12:35:21 »
I have reactivate the old dvb-mb package (for the unstable), witch contain the crazycat media_build. It's the plain package without all the patches we added earlyer to the package.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #41 on: November 02, 2019, 14:41:06 »
That's awesome Claus :)
I'll wait till it becomes available for download in MLD testing branch in order to test it then add my Skystar eXpress HD to the "Out of the Box"  wiki list.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #42 on: November 02, 2019, 14:44:49 »
It's already also ready for testing...
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Adv. Member
  • ***
  • Posts: 195
    • View Profile
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #43 on: November 02, 2019, 15:57:19 »
I received this error when i tried to install dvb-mb package

Code: [Select]
Removing rc-core (2:0-17.8+5.3.5.202.31) ...
sed: /boot/config.txt: No such file or directory
dpkg: error processing package rc-core (--remove):
 subprocess installed pre-removal script returned error exit status 1
Errors were encountered while processing:
 rc-core
E: Sub-process /usr/bin/dpkg returned an error code (1)

I believe it's related to Raspberry Pi not amd64, i created an empty config.txt in /boot directory then problem was solved.

However, after dvb-mb package was installed, i rebooted my pc in order to test it but it didn't work.


Code: [Select]
[   35.120290] dvb_core: Unknown symbol media_entity_pads_init (err -22)
[   35.120316] dvb_core: disagrees about version of symbol media_get_pad_index
[   35.120317] dvb_core: Unknown symbol media_get_pad_index (err -22)
[   35.120338] dvb_core: disagrees about version of symbol media_devnode_create
[   35.120339] dvb_core: Unknown symbol media_devnode_create (err -22)
[   35.120346] dvb_core: disagrees about version of symbol media_device_unregister_entity

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18028
    • View Profile
    • ClausMuus.de
(MLD 5.4 testing) kernel 5.3.5.202.31 amd64
« Reply #44 on: November 02, 2019, 16:52:19 »
I have test the dvb-mb package now. There is no problem to load the dvb-core modul and I do not get the error messages you post.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

1 2 [3] 4 >>> MLD-5.x / General / (MLD 5.4 testing) kernel 5.3.5.202.31 amd64
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.