[1] 2 >>> MLD-5.x / Systeme / Raspberry PI / analoges Video mit dem raspi 4 ?
 

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« on: June 10, 2020, 20:27:02 »
Moinsen,
nachdem der RPi3 das update >5.1 hartnäckig verweigert, habe ich mir den Luxus eines raspi 4 geleistet...

Zwar läßt sich die 5.5 über das webif installieren, ich kriege allerdings von Anfang an kein Bild über den Analog-Ausgang. Muß ich den irgendwie aktivieren? - Habe im webif "PAL" etc eingestellt - das brachte aber nichts. Leider hab ich kein Micro-Hdmi-Kabel, so daß ich nicht probieren kann, was da rauskommt.

Mit dem RPi3 funktioniert der Analog-Ausgang - Bild und Ton.

Hab ich vergessen, was zu aktivieren? - Aber den Startbildschirm mit MLD-Emblem müßte er doch eigentlich zeigen...?

Grüße vom Wolf
« Last Edit: June 10, 2020, 20:45:22 by herrdeh »

Offline skippy

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2251
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #1 on: June 10, 2020, 22:39:56 »
Hallo Wolf,

nach meinem Kenntnisstand gibt es für den RPi4 noch kein funktionierende Ausgabe-Plugin, so dass dieser momentan nur als VDR-Server zum Aufnehmen von Sendungen genutzt werden kann.

Viele Grüße skippy
meine MLDs (show / hide)

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 658
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #2 on: June 11, 2020, 12:07:00 »
Hallo skippy,

noch gar keines?
Ich hatte die Beiträge bislang so versanden, dass softhddevice nicht funktioniert. Aber was ist mit xineliboutput?

Gruß
baltic
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline skippy

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2251
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #3 on: June 11, 2020, 22:02:09 »
Hallo baltic,

wie bereits geschrieben, nach meinem Kenntnisstand nicht, u.a. gestützt durch die Aussage von Claus in diesem Post:

Das hat weniger was mit dem Streaming Client zu tun, als viel mehr damit, dass es für den RPI-4 noch kein alltagstaugliches Frontend gibt.

Viele Grüße skippy
meine MLDs (show / hide)

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
analoges Video mit dem raspi 4 ?
« Reply #4 on: June 13, 2020, 15:20:51 »
Ob der Analoge Ausgang beim RPI4 funktioniert weiß ich nicht, bzw. ich weiß nicht ob da was in der /boot/config.txt dafür eingetragen werden muss. Das hat beim RPI4 wohl noch kein MLD User ausprobiert. Da müsstest Du also selber mal nachlesen was dafür beim RPI4 nötig ist.
Ob das xineliboutput Plugin funktioniert, bzw wie gut weiß ich nicht. Wenn es funktioniert, sollten SD Videos kein Problem sein. HD Videos werden damit vermutlich ruckeln.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #5 on: June 14, 2020, 13:49:19 »
Moinsen, und Dank für die Hinweise so weit.

Habe das xineliboutput-plugin installiert und gemäß dieser Seite https://www.raspberrypi.org/documentation/configuration/config-txt/video.md ein
Code: [Select]
enable_tvout=1 in die /boot/config.txt eingefügt.

Immerhin kriege ich jetzt den MLD-5.5-Startbildschirm auf meinen uralten Metz. Schon mal fein. Allerdings bleibt er da jetzt hängen, es geht nicht weiter. Möchte jemand mal in die Logs schauen:

1XlpmP

Wünsche einen angenehmen Sonntag!

Grüße vom Wolf

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 658
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #6 on: June 14, 2020, 17:03:45 »
Hallo Wolf,

der X-Server scheitert leider mit einem SegFault, damit kann der "Rest" auch nicht mehr starten. Warum das so ist, weiß ich im Moment leider auch nicht.

Gruß
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #7 on: June 18, 2020, 09:48:58 »
Ist schon absehbar, wie die Entwicklung für den raspi4 weitergeht?

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
analoges Video mit dem raspi 4 ?
« Reply #8 on: June 18, 2020, 10:43:14 »
Die Entwicklung geht laufend weiter. Nur hat bisher noch keiner von uns Entwicklern versucht den RPI4 an einem Analogen Bildschirm anzuschließen. Und da dürfte Dein Problem liegen.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #9 on: June 21, 2020, 14:59:01 »
Bitte laßt mich wissen, wenn ich was sinnvolles beitragen kann.

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #10 on: July 23, 2020, 12:34:24 »
So sieht meine /boot/config.txt aus:

Code: [Select]
enable_tvout=1
sdtv_mode=2
sdtv_aspect=1
disable_splash=1
gpu_mem=256
kernel=kernel
initramfs initrd
cmdline=cmdline
max_usb_current=1
dtparam=i2c=on,i2s=on,spi=on,audio=on
hdmi_driver=2
hdmi_force_hotplug=1
hdmi_force_edid_audio=1
disable_overscan=1

Damit kriege ich den MLD-Startbildschirm, leider nichts weiter. Das läßt sich offenbar auch ohne angeschlossenen Analog-Monitor ausprobieren, soweit ich sehe, muß kein Stecker in der Analog-Buchse stecken, man kriegt die gleichen Fehlermeldungen.

Wenn ich versuche upzudaten, kommt diese Meldung im webIF:

Code: [Select]
Update package list
Downloading updates
E: Release file for http://www.minidvblinux.de/download/5.5/files/dists/stable/InRelease is not valid yet (invalid for another 31d 17h 52min 52s). Updates for this repository will not be applied.
failed

Wenn ich versuche, auf "testing" umzustellen, kommt dieses:

Code: [Select]
Get:1 http://www.minidvblinux.de/download/5.5/files testing InRelease [2.413 B]
Reading package lists...
E: Release file for http://www.minidvblinux.de/download/5.5/files/dists/testing/InRelease is not valid yet (invalid for another 31d 17h 52min 52s). Updates for this repository will not be applied.

Vielleicht hilft das jemandem aus der Entwicklergemeinde.
Ich troll' mich dann mal wieder zu meinem MLD 5.1 auf RPi3... (-;

Grüße vom Wolf

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
analoges Video mit dem raspi 4 ?
« Reply #11 on: July 23, 2020, 22:32:10 »
Die MLD-5.5 gibt es nicht als stable oder testing. Deshalb bekommst Du die Fehlermeldungen.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #12 on: June 26, 2021, 13:47:16 »
Moinsen, hab mal wieder den RPi4 mit der aktuellen "testing" 5.5 und den oben benannten Einstellungen ausprobiert.

Der Pi startet und zeigt den MLD-Startbildschirm, dann sagt er daß alle möglichen Komponenten installiert werden - und dann bleibt er hängen. Über Netzwerk ist er nicht ansprechbar. Leider habe ich grade keinen Mini-HDMI-Adapter da, so daß ich nicht schauen kann, was über HDMI kommt.

Mach' ich was falsch, oder muß ich die Hoffnung aufgeben, noch je eine Analogausgabe auf dem RPi 4 hinzukriegen?
(Oder ist ein externer HDMI2SCART-Adapter die Lösung der Wahl; die 5 Eums könnte ich grade noch aufbringen...)

Grüße vom Wolf
« Last Edit: June 26, 2021, 13:48:54 by herrdeh »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
analoges Video mit dem raspi 4 ?
« Reply #13 on: June 27, 2021, 10:30:57 »
Hi,
der Analoge Ausgang steht nicht sonderlich hoch auf meiner Prioritätenliste. Von daher musst Du entweder selber heraussuchen wie der aktiviert wird (falls dies nicht automatisch geschieht), oder Geduld haben bis sich das einer von uns Entwicklern anschauet.
Unabhängig von der Ausgabe sollte der Zugriff über das Webinterface von einem anderen PC aus aber funktionieren, wenn der per funktionierendem Netzwerk Kabel angeschlossen ist, denn ganz ohne Bildschirm funktioniert der ja auch.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 159
    • View Profile
analoges Video mit dem raspi 4 ?
« Reply #14 on: June 27, 2021, 17:17:54 »
Ja, ich hab Verständnis dafür, daß so fossile Elektronik wie das Röhren-Metz-Erbstück von meiner Lieblingsgroßtante keinen Entwickler zu hektischer Aktivität motiviert. Hab jetzt mal so einen HDMI2SCART-Adapter bestellt, werd sehen, wie sich das Trumm benimmt und dann berichten.

Tips für den analogen Ausgang nehme ich natürlich weiter dankend entgegen.

Grüße vom Wolf

[1] 2 >>> MLD-5.x / Systeme / Raspberry PI / analoges Video mit dem raspi 4 ?
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.