[1] MLD-5.x / Systems / x86 Systeme (PC) / {MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
 

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile


Hello,

Yesterday i decided to install Kaffeine on MLD as an alternative for VDR.
I can verify that it works fine so does the timeshift.
Except all icons are missing as in the above screenshot.
I remember i faced the same issuing after installing VLC.

How i can solve that issue?

Best Regards.
« Last Edit: July 16, 2020, 00:47:26 by gr4vity »

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
{MLD 5.4 testing} Kaffeine
« Reply #1 on: July 15, 2020, 00:00:02 »
Hi Claus,

I upgraded to kernel 5.4.42 however dvb-mb package is missing, i built it myself though.

Is it possible to release dvb-mb package without upgrading the whole kernel?
« Last Edit: July 16, 2020, 02:07:27 by gr4vity »

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
{MLD 5.4 testing} Kaffeine
« Reply #2 on: July 15, 2020, 00:05:08 »


Hi P3f,

How can you make use of your dual-tuner card?
Do you watch 2 channels simultaneously?
I's using Kaffeine + VDR as in the above screenshot, what about you?  :)

« Last Edit: July 16, 2020, 02:05:49 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18738
    • View Profile
    • ClausMuus.de
{MLD 5.4 testing} Kaffeine
« Reply #3 on: July 15, 2020, 13:51:10 »
It's corrently not possible to download the dvb-mb sources.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
{MLD 5.4 testing} Kaffeine
« Reply #4 on: July 15, 2020, 16:00:11 »
Do you mean that error?

Code: [Select]
Resolving bitbucket.org (bitbucket.org)... 18.205.93.0, 18.205.93.2, 18.205.93.1, ...
Connecting to bitbucket.org (bitbucket.org)|18.205.93.0|:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2020-07-14 19:03:26 ERROR 404: Not Found.

I ignored it then dvb-mb package was built normally.
« Last Edit: July 16, 2020, 07:18:27 by gr4vity »

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
{MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
« Reply #5 on: July 16, 2020, 19:17:50 »
Hi Claus,

Code: [Select]
MLD> dpkg -r dvb-mb
dpkg: dependency problems prevent removal of dvb-mb:
 xorg-intel depends on rc-core-drivers; however:
  Package rc-core-drivers is not installed.
  Package dvb-mb which provides rc-core-drivers is to be removed.

dpkg: error processing package dvb-mb (--remove):
 dependency problems - not removing
Errors were encountered while processing:
 dvb-mb

Why xorg-intel package conflicts with dvb-mb package?
I want to remove dvb-mb package without getting the above error.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18738
    • View Profile
    • ClausMuus.de
{MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
« Reply #6 on: July 16, 2020, 21:40:29 »
It do not conflicts with the dvb-mb Package, but it needs the rc-core package, witch is provided by the dvb-mb package. But you can also install the rc-core package separate. Than you do not need the dvb-mb package.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
{MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
« Reply #7 on: July 17, 2020, 15:10:31 »
Hi Claus,

That is correct if i installed rc-core-drivers package dvb-mb package will be removed.

Code: [Select]
MLD> apt install rc-core-drivers
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  dvb-mb
The following NEW packages will be installed:
  rc-core-drivers

However if i want to re-install dvb-mb package rc-core-drivers will be removed.

Code: [Select]
Selecting previously unselected package dvb-mb.
dpkg: considering removing rc-core-drivers in favour of dvb-mb ...
dpkg: yes, will remove rc-core-drivers in favour of dvb-mb

It will be going round in circles  :)

I repacked dvb-mb package and removed /lib/modules/~/kernel/drivers/media/rc
Now it provides : dvb dvb-vtuner only
I don't even use a remote control so i have no use for it.  :)
« Last Edit: July 17, 2020, 15:52:02 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18738
    • View Profile
    • ClausMuus.de
{MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
« Reply #8 on: July 17, 2020, 16:23:42 »
But you must know, that the kernel modules of the rc-core-drivers package are not compatible with the drivers of the dvb-mb package. So now you can istall both packages, but don't use the rc drivers.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
{MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
« Reply #9 on: July 17, 2020, 19:53:02 »
But you must know, that the kernel modules of the rc-core-drivers package are not compatible with the drivers of the dvb-mb package. So now you can istall both packages, but don't use the rc drivers.

Oh that was the reason?
Okay, i got it.
It will create a new package called rc-core-drivers-dvb-mb just in case i need it in the future  :)

[1] MLD-5.x / Systems / x86 Systeme (PC) / {MLD 5.4 testing} Kaffeine + VDR zwei Tuner Karte
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.