[1] 2 3 >>> MLD-5.x / General / [gelöst]RPi4: docker installieren
 

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
[gelöst]RPi4: docker installieren
« on: July 30, 2020, 04:02:39 »
Moinsen,

ich hätte gern eine Standard-docker-Installation auf meinem RPi4, in der ich Container laufen lassen kann.

Mir ist nicht klar geworden, ob das Paket docker-pt dieses tut - klärt mich jemand auf?

Danke, Wolf
« Last Edit: August 14, 2020, 10:01:47 by herrdeh »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18736
    • View Profile
    • ClausMuus.de
docker installieren ?
« Reply #1 on: July 30, 2020, 08:07:12 »
Ja genau. Damit installierst Du Docker und eine minimale Verwaltung um docker Container beim booten automatisch zu starten.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
docker installieren ?
« Reply #2 on: July 30, 2020, 11:11:16 »
He, das ist ja klasse - genau, was ich brauche. Super Idee, docker auf den MLD zu packen!

Hab das Paket jetzt drauf und versucht

Code: [Select]
MLD> docker run hello-world
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Versucht, den dockerd-ce aufzurufen:

Code: [Select]
MLD> dockerd-ce
-sh: dockerd-ce: Too many levels of symbolic links

Man findet einiges zu dieser Fehlermeldung - aber nichts, was ich verstehen könnte.
Was kann ich tun?

Dank und Grüße vom Wolf

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18736
    • View Profile
    • ClausMuus.de
docker installieren ?
« Reply #3 on: July 30, 2020, 15:37:46 »
Das Problem betraf nur die MLD-5.5, ist jetzt aber behoben.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
docker installieren ?
« Reply #4 on: July 30, 2020, 16:08:37 »
Die 5.5 unstable ist bei mir drauf, IMHO auch alle updates, das Problem besteht aber weiter. Was kann ich noch tun?

Grüße vom Wolf

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
docker installieren ?
« Reply #5 on: July 30, 2020, 16:35:49 »
Hello herrdeh,

What is the output of

/etc/init.d/docker restart

Best Regards.

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
docker installieren ?
« Reply #6 on: July 30, 2020, 17:15:52 »
Code: [Select]
LD> /etc/init.d/docker restart
Stopping docker                                                                                                                            done
Starting docker                                                                                                                            done
MLD> docker run hello-world
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See 'docker run --help'.
MLD>

Code: [Select]
MLD> dockerd-ce
-sh: dockerd-ce: Too many levels of symbolic links

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
docker installieren ?
« Reply #7 on: July 30, 2020, 17:56:34 »
I dunno what you are trying to do with hello-world
read the official wiki for docker installation!
https://www.minidvblinux.de/wiki/mld/entwicklung/54_entwicklungsumgebung

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
docker installieren ?
« Reply #8 on: July 30, 2020, 19:04:37 »
AFAIK, docker hello-world is a common test to find out whether a docker installation is working properly. Mine does not...  :-[

https://hub.docker.com/_/hello-world

Cheers,
Wolf

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
docker installieren ?
« Reply #9 on: July 30, 2020, 20:10:09 »
I surely know it's used to test docker installation  :)
I posted the wiki link so you follow the installation steps from there.

By the way it works fine using MLD 5.4

Code: [Select]
MLD> docker pull hello-world
Using default tag: latest
latest: Pulling from library/hello-world
4ee5c797bcd7: Pull complete
Digest: sha256:49a1c8800c94df04e9658809b006fd8a686cab8028d33cfba2cc049724254202
Status: Downloaded newer image for hello-world:latest
MLD> docker run hello-world

Hello from Docker!
This message shows that your installation appears to be working correctly.

To generate this message, Docker took the following steps:
 1. The Docker client contacted the Docker daemon.
 2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
    (arm32v7)
 3. The Docker daemon created a new container from that image which runs the
    executable that produces the output you are currently reading.
 4. The Docker daemon streamed that output to the Docker client, which sent it
    to your terminal.

To try something more ambitious, you can run an Ubuntu container with:
 $ docker run -it ubuntu bash

Share images, automate workflows, and more with a free Docker ID:
 https://hub.docker.com/

For more examples and ideas, visit:
 https://docs.docker.com/get-started/

Regards.
« Last Edit: July 30, 2020, 20:12:32 by gr4vity »

Offline gr4vity

  • Profi Member
  • ****
  • Posts: 368
    • View Profile
docker installieren ?
« Reply #10 on: July 30, 2020, 20:27:54 »
Das Problem betraf nur die MLD-5.5, ist jetzt aber behoben.

Code: [Select]
apt updateThen reinstall docker using the wiki link i posted above.

Regards.
« Last Edit: July 30, 2020, 20:34:34 by gr4vity »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18736
    • View Profile
    • ClausMuus.de
docker installieren ?
« Reply #11 on: July 30, 2020, 20:52:53 »
Ich vermute das Problem rührt vom alten defekten Paket her. Versuch's mal mit einem "apt remove docker" und danach "apt install docker". Nach dem remove sollte auch der Link /usr/bin/dockerd entfernt worden sein. Nach dem erneuten installieren ist das dann kein Link mehr.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
docker installieren ?
« Reply #12 on: July 30, 2020, 21:06:33 »
Danke!
Hab das mal mit apt entfernt und neu installiert, dann neu gestartet, leider die gleiche Situation:

Code: [Select]
MLD> docker run hello-world
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See 'docker run --help'.
MLD> dockerd-ce
-sh: dockerd-ce: Too many levels of symbolic links
MLD> ls -al /usr/bin/dockerd-ce
lrwxrwxrwx    1 root     root            19 Mar  7 15:31 /usr/bin/dockerd-ce -> /usr/bin/dockerd-ce

Logs wären hier: KxPgQS
...sollte das interessant sein.

Besten Dank einstweilen!
W

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18736
    • View Profile
    • ClausMuus.de
docker installieren ?
« Reply #13 on: July 30, 2020, 21:55:27 »
dockerd-ce gibt es gar nicht bei der MLD-5.5. Das kann also nicht funktionieren. Bei der 5.5 heißt das einfach nur dockerd.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline herrdeh

  • Adv. Member
  • ***
  • Posts: 131
    • View Profile
docker installieren ?
« Reply #14 on: July 31, 2020, 07:29:43 »
Ich habe drei oder vier Mal zwischen den Zweigen (testing, stable, unstable) hin und her gewechselt. Jetzt sehe ich, daß ich eh' nur die "unstable" herunterladen kann. Vielleicht hat sich da mal was vergurkt .

Das einfachste ist wahrscheinlich eine Neuinstallation, oder? - 5.5 unstable, das scheint die einzige Möglichkeit zu sein - korrekt?
Ich habe ja sonst in diese Installation praktisch keine Arbeit reingesteckt.

Grüße vom Wolf
« Last Edit: July 31, 2020, 08:52:25 by herrdeh »

[1] 2 3 >>> MLD-5.x / General / [gelöst]RPi4: docker installieren
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.