1 [2] 3 >>> MLD-5.x / Systems / 5.5-unstabele als VM auf einem Xen
 

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #15 on: November 19, 2020, 09:57:48 »
Moin,

mittlerweile bin, wie ich denke, ganz kurz vor dem Ziel. aber der letzte Schritt will nicht gelingen.  :'(

1. Die TV-Karte wird erfolgreich an die VM durchgereicht:

MLD-Server> lspci
00:00.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
00:00.2 Multimedia controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder [MPEG Port] (rev 05)

2. Die notwendigen Treiber werden geladen:

MLD-Server> lsmod
Module                  Size  Used by    Not tainted
ts2020                 24576  1
ds3000                 24576  1
cx88_dvb               32768 11
tas2101                24576  1 cx88_dvb
cx88_vp3054_i2c        16384  1 cx88_dvb
videobuf2_dvb          16384  1 cx88_dvb
dvb_core              135168  2 cx88_dvb,videobuf2_dvb
cx8800                 36864  0
cx8802                 24576  1 cx88_dvb
cx88xx                 86016  3 cx88_dvb,cx8800,cx8802
videobuf2_dma_sg       16384  2 cx88_dvb,cx8800
videobuf2_memops       20480  1 videobuf2_dma_sg
videobuf2_v4l2         24576  2 cx88_dvb,cx8800
tveeprom               28672  1 cx88xx
videobuf2_common       45056  6 cx88_dvb,videobuf2_dvb,cx8800,cx8802,cx88xx,videobuf2_v4l2
xen_netfront           36864  1
rc_core                49152  2 cx88xx
videodev              217088  4 cx8800,cx88xx,videobuf2_v4l2,videobuf2_common
mc                     49152  4 dvb_core,videobuf2_v4l2,videobuf2_common,videodev
i2c_dev         

3. Die richtige Firmware ist vorhanden und wird geladen:

MLD-Server> cat /var/log/messages | grep firmware
Nov 19 09:32:22 MLD user.info kernel: [    0.529275] SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
Nov 19 09:32:35 MLD user.info kernel: [   18.052578] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
Nov 19 09:32:35 MLD user.info kernel: [   18.095546] ds3000_firmware_ondemand: Waiting for firmware upload(2)...
Nov 19 09:32:36 MLD user.info kernel: [   19.704529] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
Nov 19 09:32:36 MLD user.info kernel: [   19.704552] ds3000_firmware_ondemand: Waiting for firmware upload(2)...

4. In den Logs finden sich nicht mal Warnings, geschweige denn relevante Errors:

MLD-Server> cat /var/log/messages | grep ERR
Nov 19 09:32:36 MLD user.err vdr: [1152] ERROR: no OSD provider available - using dummy OSD!

Bis hierher sollte alles chic sein. Aber leider gelingt wohl der Lock auf die Kanäle nicht, denn

5. vdradmin meldet: "Es sind keine EPG Informationen vorhanden."

6. Der Versuch, mittels VLC oder SMplayer einen Stream zu schauen führt zu einem schwarzen Bildschirm, aber nicht zu einer Fehlermeldung. Die gibt es nur, wenn ich den VDR stoppe. Also auch hier eigentlich alles gut.

Einen HW-Defekt kann ich ausschließen, denn wenn ich auf dem System meinen Eigenbau-VDR starte ist alles in Ordnung. Debug-Log liegt unter 83KLET.

Viele Grüße
Peter

OT an: Wie kann ich dauerhaft den ntpd-Server ändern? Wenn ich es in der rc.config mache, geht die Änderung ja wohl wieder verloren, oder? OT aus
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #16 on: November 19, 2020, 17:30:39 »
Den ntp Server solltest Du in der rc.config dauerhaft einstellen können.

Hast Du mal einen Kanalscan gemacht? Werden damit Kanäle gefunden?
Da Du nur eine DVB Karte hast, gibt es nur für Kanäle die Du mal eingeschaltet hattest auch EPG Infos.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #17 on: November 19, 2020, 18:06:30 »
Den ntp Server solltest Du in der rc.config dauerhaft einstellen können.

Ok, danke. Ich hatte befürchtet, dass das überschrieben wird, wenn ich irgendwo anders etwas ändere.

Hast Du mal einen Kanalscan gemacht? Werden damit Kanäle gefunden?

Ja, habe ich probiert. Der läuft aber nur ein paar Sekunden und liefert keine Ergebnisse. Und keine Ausgaben im Log.

Da Du nur eine DVB Karte hast, gibt es nur für Kanäle die Du mal eingeschaltet hattest auch EPG Infos.

Bist Du da sicher? Ich hatte mal eine als Server konfigurierte Maschine mit ebenfalls nur einer Karte, die jedoch, da Testinstallation, nur selten lief. Nach dem Start hatte die auch keine EPG-Infos, aber nach ein paar Minuten lieferte vdradmin eine gefüllte Ansicht. Er begann dann wohl gleich einen Scan über alle Transponder. Aber natürlich nur, wenn ich die Karte nicht durch Streaming-Zugriff oder eine Aufnahme blockierte.  ;)
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #18 on: November 19, 2020, 18:18:31 »
Ja, allerdings ist bei nur einer Karte die meistens blockiert. Genau genommen werden über einen Transponder die EPG Daten für mehrere Programme empfangen, und nach mehrstündiger Inaktivität startet eine EPG scan. Aber wenn der Kanalscan nichts findet stimmt da irgendwas nicht. Hast Du's mit dem Scan über das Webif versucht? Dort werden die Logs direkt angezeigt.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #19 on: November 19, 2020, 18:36:10 »
Auf einer Maschine mit Ausgabedevice ist sie natürlich meist geblockt. Auf einer Serverinstallation sieht das aber anders aus.

Den Scan habe ich über das Web-IF gemacht, aber da kam nicht viel Rückmeldung. Sah ungefähr so aus:

Start scanning
changed setup to 3:0:2:0:0:0:0:82:86:1:0:23
starting scan

Ich habe jetzt noch mal einen neuen Lauf gestartet und diesmal zeigt top eine deutlich erhöhte Aktivität an. Vllt. klappt's ja dieses Mal....
Melde mich später mit dem Ergebnis.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #20 on: November 19, 2020, 21:00:24 »
Hat leider nichts gebracht, im Web-IF keine weiteren Aussagen.

Auffällig finde ich, dass nach dem Lauf zwar die Pulldownmenüs von "Country" und "Satellite" korrekte Einträge enthalten, in "DVB type" aber nur ein Strich steht. Vor dem Start hatte ich da DVB-S ausgewählt.

Wenn ich dann "Sort" drücke, erscheint dies:

Stopping vdr
done
/etc/setup/wirbelscan.sh: line 54: update_channellist_order.sh: not found
Starting vdr
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #21 on: November 19, 2020, 21:19:51 »
Für einen Satteliten Scan musst Du auch das Land und den Satteliten auswählen, bevor Du den Scan startest.
Außerdem verwende mal das scan Paket, und nicht Wirbelscan. Da gibt's mehr Infos zum Scan.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #22 on: November 20, 2020, 08:37:14 »
Hallo Claus,

Für einen Satteliten Scan musst Du auch das Land und den Satteliten auswählen, bevor Du den Scan startest.

na klar, hatte ich auch. Und DIE Einstellungen blieben eben auch erhalten, nur bei "DVB type" stand nach dem Lauf ein Strich.

Außerdem verwende mal das scan Paket, und nicht Wirbelscan. Da gibt's mehr Infos zum Scan.

Sehr guter Hinweis, danke!
Hier mal ein Auszug:

w_scan -c DE -f s -s S19E2 -E 0
w_scan version 20170107 (mighty-p patch version 2) (compiled for DVB API 5.11)
using settings for 19.2 east Astra 1KR/1L/1N/1M
scan type SATELLITE, channellist 68
output format vdr-2.0
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
/dev/dvb/adapter0/frontend0 -> SATELLITE "Montage Technology DS3000": very good :-))

Using SATELLITE frontend (adapter /dev/dvb/adapter0/frontend0)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.11
frontend 'Montage Technology DS3000' supports
INVERSION_AUTO
DVB-S
DVB-S2
FREQ (0.95GHz ... 2.15GHz)
SRATE (1.000MSym/s ... 45.000MSym/s)
using LNB "UNIVERSAL"
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
trying 'S2 f = 10729 kHz V SR = 22000  2/3 0,35  8PSK  (0:0:0)'
(time: 00:01.663)         signal ok:   S2 f = 10729 kHz V SR = 22000  2/3 0,35  8PSK  (0:0:0)
Info: no data from PAT after 2 seconds

[schnipp]

trying 'S  f = 12729 kHz V SR = 22000  5/6 0,35  QPSK  (0:0:0)'
(time: 05:28.784)

ERROR: Sorry - i couldn't get any working frequency/transponder
Nothing to scan!!

Er findet einfach nichts, obwohl es reichlichst Einträge mit "signal ok" gibt.

Ich hatte in der Vergangenheit regelmäßig wenig Erfolg mit Kanalscans (unterschiedlichste HW, verschiedene Anschlüsse). Deshalb verwende ich üblicherweise fertige channels.conf und das klappt dann auch.
Hier habe ich als erste Maßnahme die aus der funktionierenden Eignbau-VM rüber kopiert - aber eben ohne Erfolg.

Bleibt mir eigentlich nur, die Karte mal in einen der Clients einzubauen, um zu sehen, ob es auf "echtem Blech" bessere Ergebnisse gibt. Aber irgendwie glaube ich das nicht sondern vermute, dass an den Treibern oder der FW irgendwelche "Verschlimmbesserungen" vorgenommen wurden.

Viele Grüße
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #23 on: November 20, 2020, 09:01:42 »
Hier noch mal ein Auszug aus den Startprotokollen:

MLD-Server> dmesg | egrep -i "dvb|dw2102|ds3|firmware|ts2020|frontend"
[    0.536203] SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
[    0.677552] PCI: setting up Xen PCI frontend stub
[    2.302436] pcifront pci-0: Installing PCI frontend
[    2.302637] pcifront pci-0: Creating PCI Frontend Bus 0000:00
[    3.355920] xenbus_probe_frontend: Device with no driver: device/vif/0
[    6.649141] cx88xx: subsystem: d464:9022, board: TeVii S464 DVB-S/S2 [card=86,autodetected], frontend(s): 1
[    7.192652] rc rc0: cx88 IR (TeVii S464 DVB-S/S2) as /devices/pci-0/pci0000:00/0000:00:00.0/rc/rc0
[    7.192726] input: cx88 IR (TeVii S464 DVB-S/S2) as /devices/pci-0/pci0000:00/0000:00:00.0/rc/rc0/input0
[    7.289514] cx88_dvb: cx2388x dvb driver version 1.0.0 loaded
[    7.289516] cx8802: registering cx8802 driver, type: dvb access: shared
[    7.289518] cx8802: subsystem: d464:9022, board: TeVii S464 DVB-S/S2 [card=86]
[    7.289519] cx88_dvb: cx2388x based DVB/ATSC card
[    7.289521] cx88_dvb: cx8802_alloc_frontends: allocating 1 frontend(s)
[    7.318152] DS3000 chip version: 0.192 attached.
[    7.378710] ts2020 0-0060: Montage Technology TS2020 successfully identified
[    7.381655] dvbdev: DVB: registering new adapter (cx88[0])
[    7.381661] cx88-mpeg driver manager 0000:00:00.2: DVB: registering adapter 0 frontend 0 (Montage Technology DS3000)...
[   16.849353] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
[   16.880365] ds3000_firmware_ondemand: Waiting for firmware upload(2)...


VDR-Server:~ # dmesg | egrep -i "dvb|dw2102|ds3|firmware|ts2020|frontend"
[    0.173246] PCI: setting up Xen PCI frontend stub
[    0.173754] pcifront pci-0: Installing PCI frontend
[    0.173754] pcifront pci-0: Creating PCI Frontend Bus 0000:00
[   18.542060] cx88[0]: subsystem: d464:9022, board: TeVii S464 DVB-S/S2 [card=86,autodetected], frontend(s): 1
[   19.491530] cx88/2: cx2388x dvb driver version 0.0.9 loaded
[   19.491542] cx88/2: registering cx8802 driver, type: dvb access: shared
[   19.491548] cx88[0]/2: subsystem: d464:9022, board: TeVii S464 DVB-S/S2 [card=86]
[   19.491554] cx88[0]/2: cx2388x based DVB/ATSC card
[   19.491558] cx8802_alloc_frontends() allocating 1 frontend(s)
[   19.621549] DS3000 chip version: 0.192 attached.
[   19.690172] ts2020_attach: Find tuner TS2020!
[   19.691750] DVB: registering new adapter (cx88[0])
[   19.691761] cx88-mpeg driver manager 0000:00:00.2: DVB: registering adapter 0 frontend 0 (Montage Technology DS3000)...
[   25.717951] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
[   26.070595] ds3000_firmware_ondemand: Waiting for firmware upload(2)...

Gibt ein paar kleine Unterschiede, aber nichts, was mir Aufstoßen verursacht.  :D
Ob es Sinn macht, mal die FW aus der alten Installation in die MLD-VM zu kopieren?
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #24 on: November 20, 2020, 11:38:09 »
Wenn die Firmware sich unterscheidet, wäre es einen versuch wert.
Du könntest auch mal versuchen ob's mit der MLD-5.4 besser funktioniert. Da gibt es zwei Treiber Pakete zur Auswahl, mit möglicherweise unterschiedlichen Treibern.
Aber Du hast schon grundsätzlich recht, das die fertigen Kanallisten die bessre Wahl sind, als ein eigener Scan. Mich interessierte vor allem, ob die Karte erkannt und verwendet wird.

Verwendest Du eventuell ein Unicable System?
Bist Du sicher das das Antennenkabel korrekt verbunden ist?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #25 on: November 20, 2020, 12:05:40 »
Wie bekomme ich heraus, welche Revision die Firmware hat?

Ich werde mal auf 5.4 umstellen und schauen, wie sich das System verhält. Welche Linie sollte ich versuchen?

Vom Betriebssystem wird die Karte erkannt (s. dmesg-Auszug oben). Auch scan scheint sie ja grundsätzlich richtig zu erkennen. Warum die Kommunikation scheitert, ist mir aber ein Rätsel.

Zur Verdeutlichung des Aufbaus:
Es handelt sich um ein Testsystem mit nur einer Sat-TV-Karte. Diese ist an einem Multischalter angeschlossen.
Als Basis ist ein Xen installiert, auf dem zwei VM existieren. Eine ist ein Klon meines derzeit genutzten VDR-Servers, die andere die neue MLD-Installation. Da der Klon absolut problemlos läuft, kann man HW-Probleme imho sicher ausschließen.
Wichtigster Unterschied zwischen den VMs sind die Kernelversionen (3.11 vs. 5.9) und die SW-Stände des VDR (2.2 vs. 2.4).
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #26 on: November 20, 2020, 12:46:44 »
Ja, da bleibt dann wohl nur der Treiber oder dir Firmware. Bei der Firmware muss Du wohl nen diff machen, um zu ergründen ob die sich unterscheiden.
Bei der 5.4 kannst Du testing oder stable nehmen. Das macht keinen großen Unterschied. Wenn das damit auch noch nicht will, kannst DU noch das Paket dvb-mb versuchen.
Und auch bei der MLD-5.5 kannst Du's mal mit dem dvb-mbe Paket versuchen.
Nach dem Wechsel des DVB-Paketes ist ein Reboot nötig.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #27 on: November 20, 2020, 12:54:43 »
Bin jetzt erst mal auf 5.4-stable, habe dvb-autodetect entfernt und dvb-mb installiert.

Derzeit läuft der Scan - und er findet was!  8)
Bin gespannt, ob mit dem Resultat ein Empfang möglich ist.

[OT an] Das nfs-server-Paket lässt sich in dieser Version nicht installieren, weil die libcom_err.so.2 fehlt. [OT aus]
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #28 on: November 20, 2020, 19:39:32 »
Lässt sich das nfs-server Paket nicht installieren, oder der Server nicht starten?
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #29 on: November 20, 2020, 21:18:24 »
Es gab bei der Aktualisierung der Pakete einen dpkg-Fehler und beim Neustart scheiterte der Start des nfs-Servers mit der Meldung, dass die Lib fehlt.

Leider habe ich im Rahmen von Tests mit den anderen Versionen mein System inzw. so "verbastelt", dass ich es noch mal neu aufsetzen muss. Dazu wede ich gleich die 5.4-stable nehmen.
Ich hoffe, dass ich am WE noch dazu komme, denn ab Mo ist erst nicht mehr viel mit Freizeitaktivitäten.  :(
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

1 [2] 3 >>> MLD-5.x / Systems / 5.5-unstabele als VM auf einem Xen
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.