[1] 2 >>> MLD-5.x / Systems / Raspberry PI / [MLD 5.5 Unstable] TeVii S660 läuft nicht (gelöst)
 

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
Hallo.
Ich habe einen RasPi4 heute mit MLD 5.5 bestückt. Leider wird ein per USB angehängter TeVii S660 DVB-S-Tuner nicht (mehr) erkannt. VDR kann nicht starten und dmesg meldet immer wieder:
Code: [Select]
ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
 ds3000_firmware_ondemand: Waiting for firmware upload(2)...
Ich habe die Firmware von TeVii bereits unter /lib/firmware abgelegt doch das ändert leider nichts.
Irgendwelche Ideen?

« Last Edit: April 14, 2021, 15:05:24 by whiterabbit »

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #1 on: April 12, 2021, 22:07:46 »
Hi,

ein Debug-Log wäre nicht schlecht.

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #2 on: April 13, 2021, 08:52:18 »
ein Debug-Log wäre nicht schlecht.
Alles klar: hier kommt es -- Upload-Code ist twkJeB



Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #3 on: April 13, 2021, 11:03:42 »
Hallo,

er versucht zunächst diese

dvb-usb: downloading firmware from file 'dvb-usb-s660.fw'

Firmware zu laden. Warum er es dann mit

ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)

versucht, entzieht sich meiner Kenntnis. Evtl. ist sie Teil von s660.

Ist "dvb-usb-s660.fw" in /etc/firmware vorhanden?

Gruß
baltic
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #4 on: April 13, 2021, 13:15:38 »
Hi. ich habe alle Dateien, die auf .fw enden, in den Ordner kopiert:

dvb-fe-cx24116.fw
dvb-fe-ds3000.fw
dvb-usb-s630.fw
dvb-usb-teviis660.fw

Seltsamerweise heißen die beiden Versionen für die S630 und S660 unterschiedlich?!?

Ich habe nun aber auch dvb-usb-s660.fw von einem anderen Rechner dorthin kopiert -- leider bleibt es dabei ... der Tuner wird nicht erkannt.
« Last Edit: April 13, 2021, 13:24:02 by whiterabbit »

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #5 on: April 13, 2021, 13:35:54 »
Was aber nicht bedeutet, dass der Fehler gleich bleibt.

Hat die dvb-usb-s660.fw auf dem anderen Rechner funktioniert?
Mach noch mal ein debug-Log.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #6 on: April 13, 2021, 14:46:54 »
Was aber nicht bedeutet, dass der Fehler gleich bleibt.

Hat die dvb-usb-s660.fw auf dem anderen Rechner funktioniert?
Mach noch mal ein debug-Log.
Der alte Rechner war ein easyVDR (eine alte Zotac-Kiste mit Intel Atom 330 CPU).
Da lief der DVB-S2 Empfänger ungefähr 15 Jahre lang ... von daher: Ja.

Ich habe nochmal ein Debug-Log erstellen lassen. Dieses Mal ist es:  vQcSFY
Die Meldungen sehen allerdings ziemlich identisch aus...

Nochmal zur Sicherheit geprüft:
Code: [Select]
cd /lib/firmware/
MLD> ls -la |grep 660
-rw-r--r--    1 root     root          8192 Mar  7 23:17 dvb-usb-s660.fw

MLD> ls -la |grep 3000
-rw-r--r--    1 root     root          8192 Mar  7 23:17 dvb-fe-ds3000.fw

... sind beide vorhanden.

Übrigens vorher steht unter dmesg auch:
Code: [Select]
[  347.972385] input: TeVii S660 USB as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/rc/rc0/input2
[  347.972949] dvb-usb: schedule remote query interval to 150 msecs.
[  347.972970] dvb-usb: TeVii S660 USB successfully initialized and connected.
[  348.339771] input: eventlircd as /devices/virtual/input/input3
[  352.924380] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
[  352.924561] ds3000_firmware_ondemand: Waiting for firmware upload(2)...


... erkannt wird der Tuner also! Aber dann...!??



In deinem Footer sehe ich "SkyStar2" -- gibt es da auch ein ootb-laufendes Modell für den USB3-Port des RasPi4?
« Last Edit: April 13, 2021, 15:00:05 by whiterabbit »

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #7 on: April 13, 2021, 15:27:39 »
Übrigens vorher steht unter dmesg auch:
Code: [Select]
[  347.972385] input: TeVii S660 USB as /devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/rc/rc0/input2
[  347.972949] dvb-usb: schedule remote query interval to 150 msecs.
[  347.972970] dvb-usb: TeVii S660 USB successfully initialized and connected.
[  348.339771] input: eventlircd as /devices/virtual/input/input3
[  352.924380] ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
[  352.924561] ds3000_firmware_ondemand: Waiting for firmware upload(2)...


... erkannt wird der Tuner also! Aber dann...!??

Hmm, sieht eigentlich gut aus.
Probiere mal, ob er Sender findet: Paket scan installieren und über das Web-IF einen Suchlauf starten.

Ansonsten kannst Du es mal so versuchen:

ln -s /etc/firmware/dvb-usb-s660.fw /etc/firmware/dvb-usb-s630.fw

In deinem Footer sehe ich "SkyStar2" -- gibt es da auch ein ootb-laufendes Modell für den USB3-Port des RasPi4?

Nein, das ist eine PCI-Karte. Von einer USB-Version habe ich noch nie gehört.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #8 on: April 13, 2021, 15:35:26 »
Das Problem ist wohl, dass sich der VDR ständig weghängt:

user.err vdr: FindDevice: No Monitor Mode found! Give up!
ds3000_firmware_ondemand: Waiting for firmware upload (dvb-fe-ds3000.fw)...
ds3000_firmware_ondemand: Waiting for firmware upload(2)...
user.err vdr: [21580] ERROR: unknown config parameter: softhddevice-drm.SWDeinterlacer = 1

Funktioniert denn das softhddevice auf dem RasPi4B inzwischen? Habe das in letzter Zeit nicht so verfolgt.

MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline white_rabbit

  • Newbie
  • *
  • Posts: 11
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #9 on: April 13, 2021, 16:20:14 »
Funktioniert denn das softhddevice auf dem RasPi4B inzwischen? Habe das in letzter Zeit nicht so verfolgt.
Das weiß ich nicht ... ich würde ja auch etwas anderes ausprobieren ... aber nur zu Testzwecken wollte ich mir jetzt kein anderes USB-TV-Device zulegen...
Was soll ich als nächstes ausprobieren?

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #10 on: April 13, 2021, 16:54:06 »
Da hast Du etwas falsch verstanden.

Wie es scheint, kann der VDR die Informationen nicht weiterreichen und stürzt deshalb ab. Das hat nichts mit der TeVii zu tun.

Was soll ich als nächstes ausprobieren?

Wie ich schon schrieb: Gehe ins Web-IF und mache einen Scan. Dann wissen wir, ob der Empfang grundsätzlich funktioniert.
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #11 on: April 13, 2021, 18:01:43 »
Hast du einen Monitor oder Fernseher dran?
Code: [Select]
Apr 13 14:39:25 MLD-rpi4 user.err vdr: FindDevice: No Monitor Mode found! Give up!
Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline whiterabbit

  • Newbie
  • *
  • Posts: 13
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #12 on: April 13, 2021, 18:47:49 »
Wie ich schon schrieb: Gehe ins Web-IF und mache einen Scan. Dann wissen wir, ob der Empfang grundsätzlich funktioniert.

Ok,
Code: [Select]
MLD> apt install scan

Und dann im Webinterface:
Code: [Select]
Stopping vdr
done
w_scan -c DE -f s -s S19E2
w_scan version 20210218 (mighty-p patch version 2) (compiled for DVB API 5.11)
using settings for 19.2 east Astra 1KR/1L/1N/1M
scan type SATELLITE, channellist 68
output format vdr-2.0
output charset 'UTF-8', use -C <charset> to override
Info: using DVB adapter auto detection.
/dev/dvb/adapter0/frontend0 -> SATELLITE "Montage Technology DS3000": very good :-))

Using SATELLITE frontend (adapter /dev/dvb/adapter0/frontend0)
-_-_-_-_ Getting frontend capabilities-_-_-_-_
Using DVB API 5.11
frontend 'Montage Technology DS3000' supports
INVERSION_AUTO
DVB-S
DVB-S2
FREQ (0.95GHz ... 2.15GHz)
SRATE (1.000MSym/s ... 45.000MSym/s)
using LNB "UNIVERSAL"
-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
trying 'S2 f = 10729 kHz V SR = 22000  2/3 0,35  8PSK  (0:0:0)'
(time: 00:00.499)         signal ok: S2 f = 10729 kHz V SR = 22000  2/3 0,35  8PSK  (0:0:0)
S2 f = 10729 kHz V SR = 22000  2/3 0,35  8PSK  (0:0:0) : updating network_id -> (0:1:0)
new transponder: (S2 f = 11656 kHz V SR = 22000  2/3 0,35  8PSK  (1:1:1030)) 0x4043
new transponder: (S  f = 11244 kHz H SR = 22000  5/6 0,35  QPSK  (1:1:1003)) 0x4043
....
Der findet also was ...  was nun? Dann scheint es ja prinzipiell zu funktionieren??

Ganz am Ende des Scan-Vorgangs erhalte ich dann wieder:
Code: [Select]
[...]
tune to: S  f = 11523 kHz H SR = 22000  5/6 0,35  QPSK  (1:133:1021) (time: 27:42.688)
----------no signal----------
tune to: S  f = 11523 kHz H SR = 22000 AUTO 0,AUTO  QPSK  (1:133:1021) (time: 27:48.248)  (no signal)
----------no signal----------
tune to: S2 f = 12722 kHz H SR = 23500  2/3 0,20  8PSK  (53:133:1119) (time: 27:53.838)
----------no signal----------
tune to: S2 f = 12722 kHz H SR = 23500 AUTO 0,AUTO  8PSK  (53:133:1119) (time: 27:59.388)  (no signal)
----------no signal----------
(time: 28:04.938) dumping lists (1099 services)
..
Done, scan time: 28:04.958
Starting vdr   
failed

Ich habe übrigens einen Monitor und kein TV angeschlossen. Das ganze ist momentan ja "nur" eine Testumgebung.
« Last Edit: April 13, 2021, 19:39:34 by whiterabbit »

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #13 on: April 13, 2021, 19:55:16 »
Hast du im WebIF bei 'Konfiguration/Anzeige' was eingestellt?

Denn es schmiert bei dir der VDR ab, das wird nichts mit dem TeVii zu tun haben.

Gruß,
 Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
[MLD 5.5 Unstabel] TeVii S660 läuft nicht
« Reply #14 on: April 13, 2021, 20:22:42 »
Hi Roland,

verstehe ich Dich richtig, dass das softhddevice-dpm inzwischen (halbwegs) praxistauglich ist?
Ich überlege nämlich, angesichts ständig steigender Strompreise meinen alten Client in Rente zu schicken, weiß aber noch nicht recht, womit ich ihn ersetzen soll.

Gruß
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

[1] 2 >>> MLD-5.x / Systems / Raspberry PI / [MLD 5.5 Unstable] TeVii S660 läuft nicht (gelöst)
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.