[1] 2 >>> MLD-5.x / Systeme / Raspberry PI / Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
 

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Nabend.  :) Gibt es ein bekanntes Problem mit CEC (vdr-plugin-cecremote und libcec4) beim Raspi 4 unter MLD 5.5 (testing/unstable)?

Starte ich ohne installierte CEC-Pakete, läuft mein Fernsehbild nach dem Hochfahren problemlos durch (ich kann bloß so nichts fernbedienen).

Starte ich mit installierten CEC-Paketen, verschwindet das Fernsehbild nach etwa anderthalb Minuten und der TV-Bildschirm zeigt schwarz.

In den Sekunden zuvor meldet tail -f /var/log/messages:
Code: [Select]
Jun  8 22:51:30 MLD-rpi4 user.err vdr: [cecremote] cCECRemote Startup
Jun  8 22:51:30 MLD-rpi4 user.err vdr: [cecremote] cCECRemote::PushCmdQueue
Jun  8 22:51:30 MLD-rpi4 user.err vdr: [cecremote] cCECRemote::PushCmdQueue
Jun  8 22:51:31 MLD-rpi4 user.err vdr: [cecremote] Channel switch OK
Jun  8 22:51:57 MLD-rpi4 user.err vdr: [cecremote] END cCECRemote::Open OK
Jun  8 22:52:42 MLD-rpi4 user.err vdr: [cecremote] CEC ERROR:    failed to request the physical address
Jun  8 22:52:48 MLD-rpi4 user.err vdr: [cecremote] END cCECRemote::Initialize
Jun  8 22:52:48 MLD-rpi4 user.err vdr: [cecremote] Wait
Jun  8 22:52:54 MLD-rpi4 user.err vdr: [cecremote] PowerOnDevice failed for TV
Jun  8 22:52:54 MLD-rpi4 user.err vdr: [cecremote] (-1) Action finished
Jun  8 22:52:54 MLD-rpi4 user.err vdr: [cecremote] Wait
Jun  8 22:52:54 MLD-rpi4 user.err vdr: [cecremote] CECSourceActivatedCallback address 2 activated 1
Jun  8 22:53:01 MLD-rpi4 user.err vdr: [cecremote] SetActiveSource failed
Jun  8 22:53:01 MLD-rpi4 user.err vdr: [cecremote] (-1) Action finished
Jun  8 22:53:01 MLD-rpi4 user.err vdr: [cecremote] Wait
Jun  8 22:53:01 MLD-rpi4 user.err vdr: [cecremote]   Signal

Direkt nach den Logeinträgen Wait und vor allem Signal ist das TV-Bild dann weg.

"/etc/init.d/vdr restart" erweckt das Bild nicht wieder zum Leben. Ich kann nur den Stecker ziehen und den Raspi 4 neu hochfahren.

Ich hatte erst mein Micro-HDMI-auf-HDMI-Kabel im Verdacht. Aber beim Test mit dem gleichen Kabel und LibreELEC (Kodi) gibt es mit CEC keine Probleme, auch das Fernbedienen funktioniert dort. Ich bin daher etwas ratlos.

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #1 on: June 08, 2021, 23:50:10 »
Hi,

bei CEC liegt viel auch auch am Monitor/Fernseher was der kann bzw. durchreicht.
besser wäre eine Fernbedienung am RPI4 direkt.

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #2 on: June 09, 2021, 00:01:30 »
Nun ja, mein Problem ist ja nicht, dass nicht genug durchgereicht würde, sondern dass es (wie ich es deute) einen "Fehler" gibt, der bei softwaremäßigem Vorhandensein der CEC-Pakete das Fernsehbild nach 1-2 Minuten aussetzen lässt, wie oben beschrieben. Also: CEC ist installiert -> VDR läuft nicht stabil.

... gleicher Samsung-TV und MLD 5.0 -> keine Probleme, gleicher TV und Kodi -> keine Probleme.

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #3 on: June 09, 2021, 00:05:56 »
Nun ja, mein Problem ist ja nicht, dass nicht genug durchgereicht würde, sondern dass es (wie ich es deute) einen "Fehler" gibt, der bei softwaremäßigem Vorhandensein der CEC-Pakete das Fernsehbild nach 1-2 Minuten aussetzen lässt, wie oben beschrieben. Also: CEC ist installiert -> VDR läuft nicht stabil.

... gleicher Samsung-TV und MLD 5.0 -> keine Probleme, gleicher TV und Kodi -> keine Probleme.

MLD 5.0 ist aber nicht auf einem RPI4
Das sind schon große Unsterschied, der Kernel ist ein ganz anderer.
Und die Hardware auch, der RPI4 ist nicht mit allen anderen RPI's zu vergleichen.

Kannst du mal ein Debug-Log erstellen

Gruß,
  Roland
« Last Edit: June 09, 2021, 00:09:00 by rfehr »
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #4 on: June 09, 2021, 00:22:24 »
Kannst du mal ein Debug-Log erstellen

Sicher doch. :)
-> pN8GbI

In den 1-2 min, bevor am Ende das Bild schwarz wird, funktioniert CEC auch nicht.

Ich frage mich, ob unter LibreELEC womöglich CEC-Pakete in einer anderen Version vorliegen, da CEC dort bei ansonsten gleicher Hardware keine Schwierigkeiten macht.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #5 on: June 09, 2021, 00:36:10 »
Da stellt sich dann auch die Frage, ob das cecremote Plugin überhaupt kompatibel zum softhddrm Plugin ist, bzw. zum RPI4.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #6 on: June 09, 2021, 00:40:14 »
Laienhaft gefragt: Kann man schauen, welche CEC-Pakete LibreELEC nutzt und diese in MLD für den Raspi 4 einbinden?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #7 on: June 09, 2021, 11:05:18 »
Nein, das würde nicht helfen, den CEC ist sicherlich ein Teil von Kodi so wie das cecremote Plugin ein Teil vom VDR ist. Da sind also keine Systemfunktionen für zuständig. Das ist also nichts das sich von Kodi auf den VDR übertragen ließe. Außerdem funktioniert CEC ja grundsätzlich mit dem VDR, nur halt noch nicht auf dem RPI4.
Du könntest mal testen ob das mit Kodi unter der MLD funktioniert. Dann wüssten wir schon mal ob es sich um ein generelles Problem handelt, oder lediglich den VDR betrifft.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #8 on: June 09, 2021, 11:08:53 »
Alternativ könntest Du mal schauen was das Tool cec-client sagt, das Teil des Paketes cec-utils ist. Wenn ich das richtig erinnere kann das Dir anzeigen welche CEC Events am RPI ankommen.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #9 on: June 09, 2021, 15:56:24 »
In Ordnung, ich kümmere mich drum.

Wird ne kleine Fummelarbeit, weil ich nach dem Hochfahren von MLD immer bloß 1-2 Minuten habe, bevor der VDR stirbt (bzw. sein TV-Bild). Das passiert völlig unabhängig davon, ob ich die Fernbedienung (und somit CEC) benutzt habe oder nicht. Das Sterben findet nur statt, wenn das CEC-VDR-Plugin installiert ist, ansonsten nicht.

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #10 on: June 09, 2021, 16:39:12 »
So, fertig. Und ich fürchte, ich kann nicht wirklich viel zur Erhellung beitragen.

1. Test: MLD-5.5-Unstable-System mit installiertem VDR-CEC-Plugin:

System fährt hoch, ich mache nichts, schaue nur zu, nutze nicht die FB.

Boot-Animation, Fernsehbild, nach 1-2 min Fernsehbild weg, kommt auch nach vdr restart nicht zurück. Log oben ja schon gepostet.

2. Test: MLD-5.5-Unstable-System ohne installiertes VDR-CEC-Plugin (cec-utils, libcec4 aber noch da):

Boot-Animation, Fernsehbild, Fernsehbild bleibt, ist aber keine Lösung, weil kein CEC-Support mehr.

3. Test: LibreELEC mit Kodi, absolut gleiche Hardware, gleiche Kabel:

Kodi läuft hoch und lässt sich mit CEC fernbedienen. Alles top.

4. Test: MLD-5.5-Unstable-System ohne installiertes VDR-CEC-Plugin, Fokus auf Output CEC-Client:

Ich drücke Tasten auf der FB. CEC-Client zeigt die Keys nicht an, sondern:

Code: [Select]
No device type given. Using 'recording device'
CEC Parser created - libCEC version 4.0.4
no serial port given. trying autodetect:
 path:     Raspberry Pi
 com port: RPI

opening a connection to the CEC adapter...
DEBUG:   [             683] Broadcast (F): osd name set to 'Broadcast'
WARNING: [             683] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [             683] Open - vc_cec could not be initialised
ERROR:   [             684] could not open a connection (try 1)
WARNING: [            1651] unhandled response received: opcode=0 initiator=e destination=0 response=0
WARNING: [            1684] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            1684] Open - vc_cec could not be initialised
ERROR:   [            1684] could not open a connection (try 2)
WARNING: [            2684] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            2684] Open - vc_cec could not be initialised
ERROR:   [            2684] could not open a connection (try 3)
WARNING: [            3212] unhandled response received: opcode=0 initiator=e destination=0 response=0
WARNING: [            3685] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            3685] Open - vc_cec could not be initialised
ERROR:   [            3685] could not open a connection (try 4)
WARNING: [            4685] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            4685] Open - vc_cec could not be initialised
ERROR:   [            4685] could not open a connection (try 5)
WARNING: [            4774] unhandled response received: opcode=0 initiator=e destination=0 response=0
WARNING: [            5686] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            5686] Open - vc_cec could not be initialised
ERROR:   [            5686] could not open a connection (try 6)
WARNING: [            6337] unhandled response received: opcode=8f initiator=e destination=0 response=0
WARNING: [            6686] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            6686] Open - vc_cec could not be initialised
ERROR:   [            6686] could not open a connection (try 7)
WARNING: [            7687] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            7687] Open - vc_cec could not be initialised
ERROR:   [            7687] could not open a connection (try 8)
WARNING: [            7901] unhandled response received: opcode=8f initiator=e destination=0 response=0
WARNING: [            8687] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            8687] Open - vc_cec could not be initialised
ERROR:   [            8687] could not open a connection (try 9)
WARNING: [            9461] unhandled response received: opcode=0 initiator=e destination=2 response=1
WARNING: [            9688] RegisterLogicalAddress - vc_cec_set_logical_address(E) returned device is busy (3)
ERROR:   [            9688] Open - vc_cec could not be initialised
ERROR:   [            9688] could not open a connection (try 10)
unable to open the device on port RPI
NOTICE:  [           10688] connection opened
ERROR:   [           10688] could not start CEC communications
Segmentation fault

5. Test: Installation von KODI auf MLD-5.5-Unstable

Start von Kodi per OSD-Menü, startet nicht, TV-Bild kommt nach wenigen Momenten zurück.

/var/log/messages zeigt:

Code: [Select]
Jun  9 16:15:20 MLD-rpi4 authpriv.info atd[2733]: pam_unix(atd:session): session opened for user root by (uid=1)
Jun  9 16:15:24 MLD-rpi4 user.err vdr: [2340] ERROR: no OSD provider available - using dummy OSD!
Jun  9 16:15:29 MLD-rpi4 user.err vdr: [2340] ERROR: Kanal blockiert (zeichnet auf)!
Jun  9 16:15:29 MLD-rpi4 user.err vdr: [2340] ERROR: no OSD provider available - using dummy OSD!
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.582527] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.619796] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.620690] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.650915] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.655572] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.656871] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:31 MLD-rpi4 user.err kernel: [  308.658052] vc4_hdmi fef05700.hdmi: ASoC: error at snd_soc_dai_startup on fef05700.hdmi: -19
Jun  9 16:15:42 MLD-rpi4 authpriv.info atd[2733]: pam_unix(atd:session): session closed for user root
Jun  9 16:15:42 MLD-rpi4 cron.err atd[2733]: Exec failed for mail command: No such file or directory

6. Test: Ich tippe "kodi" in der Konsole und achte auf Meldungen. Es kommt:

Code: [Select]
* failed to add service - already in use?
Segmentation fault

Ich habe zwar meine Probleme, das Gesehene richtig zu deuten, fürchte aber, ich konnte nicht wirklich weiterhelfen. Der CEC-Client hat schon Schwierigkeiten, nicht in erster Linie das VDR-Plugin.
« Last Edit: June 09, 2021, 16:41:18 by LarsX »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19377
    • View Profile
    • ClausMuus.de
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #11 on: June 09, 2021, 17:15:30 »
Ja, da hilft wohl nur, dass einer unserer Entwickler selber mal Tests mit dem CEC durchführt und die Besonderheiten des RPI-4 im Bezug auf CEC recherchiert.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #12 on: June 09, 2021, 22:34:45 »
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 1339
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #13 on: June 09, 2021, 22:39:19 »
Hi LarsX,

1 Frage habe ich, welchen HDMI Port nutzt du bei deinem RPI4?

Gruß,
  Roland
1x OctopusNet 4x DVB-C
1x Zotac ITX-A Atom 330
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
2x RPi4
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline LarsX

  • Adv. Member
  • ***
  • Posts: 128
    • View Profile
Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
« Reply #14 on: June 09, 2021, 22:53:28 »
Den linken, also direkt neben der Strombuchse, über den rechten bekam ich kein Bild.
« Last Edit: June 09, 2021, 22:57:11 by LarsX »

[1] 2 >>> MLD-5.x / Systeme / Raspberry PI / Gibt es CEC-Probleme auf dem Raspi 4 mit MLD 5.5?
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.