1 2 [3] MLD-5.x / Systems / 5.5-unstabele als VM auf einem Xen
 

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #30 on: November 20, 2020, 22:16:16 »
Ich hab die Installation mal getestet. Bei mir gab's bei der stable keine Fehler.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #31 on: November 21, 2020, 10:44:04 »
Moin Claus,

ich habe mir in neues ISO auf Basis 5.4-stable-server gebaut und die Installation lief fehlerfrei durch.

Leider startet aber jetzt der VDR nicht und das Log wird mit solchen Meldungen überflutet:

Error opening terminal: vt102.
VDR exits at Sa Nov 21 10:16:21 CET 2020

Das wiederholt sich alle 12 Sekunden.
Ich vermute, dass ein Paket fehlt, das mit der netinstall automatisch an Bord kam. Leider habe ich nicht den blassesten Schimmer, welches das sein könnte.

Viele Grüße
Peter

MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 19408
    • View Profile
    • ClausMuus.de
5.5-unstabele als VM auf einem Xen
« Reply #32 on: November 21, 2020, 11:44:34 »
Wie ist der Dateiname von dem Image. Und lade mal ein Debug-Log hoch.
MLD 5.4 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.4 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #33 on: November 21, 2020, 14:46:43 »
Den Dateinamen habe ich beim Abspeichern verändert, um ihn "griffiger" zu machen. Er dürfte daher nutzlos sein.

Aber ich bin durch eine Änderung in der domU-Konfig einen Schritt weiter gekommen. Zwar sehe ich jetzt weite Teile des Bootvorganges nicht mehr auf der Xen-Konsole, aber das ist nicht schlimm. Ich kann mich nach Abschluss des Boots per ssh und Web-IF verbinden, das reicht völlig. Dabei sehe ich, dass alles ordentlich durchgebootet hat.

Was wieder nicht geht, sind der Zugriff auf einen Stream und im EPG ist auch wieder nix drin. Allerdings geht diesmal der Scan.
Momentan kann ich die Maschine nicht starten, da ich die andere VM benötige. Das Log wird also leider noch brauchen.....
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #34 on: November 21, 2020, 17:53:38 »
Hallo Claus,

manchmal tut boot eben doch gut - auch unter Linux!  ;D

Jedenfalls habe ich die VM gerade gestartet, um das Debug-Log zu erstellen, aber sicherheitshalber noch mal kurz getestet. Und was soll ich sagen: Es klappt!  8)
Dann kann ich also bald beginnen, das System fertig zu konfigurieren, auf meinen Server zu portieren, die Clients einzurichten.....Weihnachten wird also, trotz Corona, sicher nicht langweilig.  :D

Überhaupt scheint heute ein Glückstag zu sein, denn ich habe auch noch einen Ausdruck des Treibermods gefunden. Wo liegen noch mal die Sourcen?

Wieder mal ganz herzlichen Dank für Deine Unterstützung und Geduld!

Viele Grüße und einen schönen Sonntag
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline P3f

  • Administrator
  • Expert Member
  • ********
  • Posts: 1401
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #35 on: November 21, 2020, 19:54:38 »
Hi Peter,
Überhaupt scheint heute ein Glückstag zu sein, denn ich habe auch noch einen Ausdruck des Treibermods gefunden. Wo liegen noch mal die Sourcen?

Welche Sourcen meinst Du? Oder ist das gefundene was Du suchtest um den Kernelpatch zu erstellen?

Gruß,

Pit
----------------------------------------------------------------------
VDR 1:(MLD 5.4-64), ZOTAC ION ITX F-E, 1GB 1033, ATRIC-Einschalter, ImonLCD, Cinergy S2 HD
VDR 2 MLD-BPI: BananaPI | 16 GB SD-Card | MLD 5.3 in Entwicklung
MLD-WTK: WeTek-Play | 8 GB MicroSD-Card | MLD 5.3 als SatIP-Server

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #36 on: November 21, 2020, 20:13:14 »
Hallo Pit,

genau, ich meine die Treibersourcen, damit ich den für meine Karten anpassen kann. So lässt sich die HW-seitig vorhandene Spannungsabschaltung bei Nichtnutzung aktivieren.
Sind bloß ein paar ganz kleine Änderungen, aber die Diff funktioniert so nicht mehr, da schon bei späteren 3er-Kerneln die Zeilen nicht mehr stimmten.

Viele Grüße
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #37 on: February 14, 2021, 10:38:07 »
Hallo Pit,

nach längerer Abwesenheit wegen Montage, Krankheit und Trauerfall bin ich nun wieder "an Deck".  :)

Ich habe jetzt mal die imho notwendigen Anpassungen in der relevanten Datei vorgenommen und das Ergebnis hier angehängt. Das Ergebnis sollte sowohl für die 5.4er wie die 5.10er Kernel passen. Wenn Du magst, kannst Du sie ja beim nächsten Kernel-Build einpflegen und mir Bescheid geben. Ich teste dann umgehend.

Viele Grüße
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

Offline P3f

  • Administrator
  • Expert Member
  • ********
  • Posts: 1401
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #38 on: February 14, 2021, 14:14:19 »
Hallo Peter,

Danke für die Bereitstellung. Ich habe daraufhin einen Patch erstellen können und baue gerade bei mir lokal den neuesten Kernel. Sofern damit erstmal keine Fehler produziert werden, bringe ich ihn beim nächsten Kernelupgrade mit in die MLD 5.5

Gruß,

Pit
----------------------------------------------------------------------
VDR 1:(MLD 5.4-64), ZOTAC ION ITX F-E, 1GB 1033, ATRIC-Einschalter, ImonLCD, Cinergy S2 HD
VDR 2 MLD-BPI: BananaPI | 16 GB SD-Card | MLD 5.3 in Entwicklung
MLD-WTK: WeTek-Play | 8 GB MicroSD-Card | MLD 5.3 als SatIP-Server

Offline baltic

  • MLD-Debugger
  • Expert Member
  • *****
  • Posts: 673
    • View Profile
5.5-unstabele als VM auf einem Xen
« Reply #39 on: April 13, 2021, 10:50:23 »
Hallo Pit,

nachdem ich nun gesehen hatte, dass es einen neuen Kernel gibt, habe ich den Server mal umgebaut, MLD aktualisiert, rebootet und die Spannung am Ausgang der Sat-Karte gemessen. Und ich darf vermelden: Es klappt wie erhofft, die Spannung sinkt nach dem Stoppen des VDR auf 0V!   8)
Nun muss ich "nur" klären, warum plötzlich das streamdev-plugin am Client kein Bild mehr liefert und vdradmin keinerlei EPG-Daten bekommt. Empfang besteht jedenfalls, denn ein Scan ist erfolgreich und findet so ziemlich alles, was Astra von sich gibt. Keines der Logs zeigt irgendeine Spur von Auffälligkeit. Aber ok, das ist eine andere Baustelle, da mache ich ggf. ein neues Thema auf.

Herzlichen Dank für Deine Mühe!  :)
Peter
MLD 5.5 – unstable  Asus M3N78-EM  SkyStar2

1 2 [3] MLD-5.x / Systems / 5.5-unstabele als VM auf einem Xen
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.